none
IE9, Win7: How to get rid of "What do you want to do with ...doc? Open, Save, Save as

    Question

  • My web application downloads a .doc file.  With IE9 and Windows 7 it displays the dialog "What do you want to do with xxxx.doc? Open, Save, Save as"  Prior to IE9 I could check the box that said "remember" but with IE9 I do not see a way to prevent the dialog from occurring every time.  How can I turn off this dialog like I can in all prior versions of IE?  I have looked through the forums and the answer might be here but most threads seem to be a little different problem.  Some of my customers are switching to FireFox and Chrome because of this problem so I would like to find a solution.  I found another thread that had a potential solution (1. Click Tools - Internet Options - Security Tab. 2. Click Local intranet, click Sites, uncheck "Automatically detect intranet network" if you checked it. Then check "Include all network paths (UNCs)".  Click Advanced, add the intranet to the zone. Then Close and OK.) but that did not solve my problem.
    Wednesday, April 04, 2012 8:22 PM

Answers

  • Hi,


    Based my research, due to increasing in security, we cannot disable Download Manager of Internet Explorer 9 from changing settings, editing registry keys or editing settings in Group Policy. This can prevent websites downloading automatically. Instead, we can set default download location.


    For reference:

    http://social.technet.microsoft.com/Forums/en/ieitprocurrentver/thread/21798a87-8c04-4995-a988-ed9275062f82


    And for more detailed information, please refer to Safer and Faster Downloads in IE9.


    Hope this helps.


    If a post solved your problem, click “Mark as Answer” on the post. If a post helped you, click "Vote As Helpful" on the left side of post.

    Friday, April 06, 2012 5:29 AM
  • Hi Sbro and JJQVA,


    Please understand that the download manager or download prompt cannot be disabled. I think this feature is by design in Internet Explorer 9 and it is one of the differences between Internet Explorer 9 and previous versions of Internet Explorer.


    This feature prevents downloading automatically in background without your permission and catching you attention in Internet Explorer. In my opinion, the feature helps increase security. All that we have to do is only to click once more (Save) than before and we also can customize the default download folder as before.


    However, if you have any feedback about Internet Explorer, please contact Internet Explorer Feedback Program.


    Hope this helps.


    If a post solved your problem, click “Mark as Answer” on the post. If a post helped you, click "Vote As Helpful" on the left side of post.

    Wednesday, April 11, 2012 3:21 AM

All replies

  • Hi,


    Based my research, due to increasing in security, we cannot disable Download Manager of Internet Explorer 9 from changing settings, editing registry keys or editing settings in Group Policy. This can prevent websites downloading automatically. Instead, we can set default download location.


    For reference:

    http://social.technet.microsoft.com/Forums/en/ieitprocurrentver/thread/21798a87-8c04-4995-a988-ed9275062f82


    And for more detailed information, please refer to Safer and Faster Downloads in IE9.


    Hope this helps.


    If a post solved your problem, click “Mark as Answer” on the post. If a post helped you, click "Vote As Helpful" on the left side of post.

    Friday, April 06, 2012 5:29 AM
  • Not sure how those links answered my question.  When a user clicks on a link to a .DOC attachment, I want Word to come up without asking me to save or Open; I just want to Open.  Prior to IE9, when the download dialog appears there was a checkbox that said "always do this for this file type" so the user could check the box and do an Open and it forced an Open anytime that filetype was clicked on in the future.
    Friday, April 06, 2012 8:50 PM
  • We are having the exact same problem except that some of our users are prompted with the "What do you want to do. . ." message and others are not.  I've gone through every IE and file association setting and have not found the solution.  Hope there is a solution soon!
    Tuesday, April 10, 2012 3:34 PM
  • Hi Sbro and JJQVA,


    Please understand that the download manager or download prompt cannot be disabled. I think this feature is by design in Internet Explorer 9 and it is one of the differences between Internet Explorer 9 and previous versions of Internet Explorer.


    This feature prevents downloading automatically in background without your permission and catching you attention in Internet Explorer. In my opinion, the feature helps increase security. All that we have to do is only to click once more (Save) than before and we also can customize the default download folder as before.


    However, if you have any feedback about Internet Explorer, please contact Internet Explorer Feedback Program.


    Hope this helps.


    If a post solved your problem, click “Mark as Answer” on the post. If a post helped you, click "Vote As Helpful" on the left side of post.

    Wednesday, April 11, 2012 3:21 AM
  • Thank you Jeremy for the response.  I understand the security but since we are running in the Local intranet zone we do not have the security issue.  Would have been nice if IE 9 at least let this be an option in the zone configuration and default to off for Local intranet and/or Trusted sites.  While this is only "one more click", many of my customers are not as comfortable with computers and this extra step confuses them as they are doing a function in our web page that causes a Word Document to come up and they do not think about it as "downloading".
    Wednesday, April 11, 2012 3:30 AM
  • This is not acceptable.  Is Microsoft working on a fix for this?  Changing the way everyone's web sites work is not generally a good idea.  MS needs to fix this immediately.
    Thursday, June 07, 2012 1:31 PM
  • I have this occur for 'normal' pages of html that I click on.   I don't want to click on another box that says it is OK to just open a link in a page!

    Monday, October 29, 2012 4:26 PM
  • Hi,

    We use IE9 in our standardized environment and this additional step in opening (mostly) pdf documents from our production applications is very annoying feature. These applications create lots of pdf's and users open them via web UI (IE9 with Adobe Reader plug-in). Package lists, pallet labels, reports, lab results, etc. = lots of unnecessary clicks.

    Since these systems run in either local inranet zone or trusted sites zone, I can not see any additional security in this step, users click "open" any way to open and print.

    Why is this behavior global in all IE zones? In my opinion it should be configurable in intranet and trusted site zones? I hope someone from MS IE dev team is regular reader in this forum. (I'll try the IE feedback also)

    /juha

    Wednesday, November 21, 2012 9:32 AM
  • Hello,

    My problem is beyond this. I'm OK with clicking "Open" to open the file, in my case an .mdb file. However, I still got a message at the bottom of IE saying "<filename> couldn't be downloaded."  with 3 buttons "Retry", "Cancel", "View downloads" even though my file is already opened by Access.

    Why do I get that message? How can I turn it off?

    Thanks.

    Tuesday, July 02, 2013 2:43 PM
  • Why do I get that message? How can I turn it off?

    Security/obscurity.  Use ProcMon to try to figure out what is going on and use this document as a reference for some of the registry values you see doing that:

    http://msdn.microsoft.com/en-us/library/bb250462(VS.85).aspx

     
    Alternatively, try experimenting with less security.  E.g. change the security zone or elevate the tasks involved.

     



    Robert Aldwinckle
    ---

    Tuesday, July 02, 2013 3:11 PM
  • Found by accident!  If you save the link as a "DOC" it will not ask the question.  It will ask the question for DOCX and XLSX extensions.  This is great - save your newly created documents in old Word format for production use.  

    • Proposed as answer by Mussel Thursday, September 26, 2013 10:15 PM
    Thursday, September 26, 2013 10:15 PM
  • Hi,

    I have a slightly different issue. When our website users click on an html attachment embedded on a web-page in IE9, the download manager will not display the "Open" option. It will only display "Save" and "Cancel" which our users don't like, having to save the html document in a folder to open it. When downloading doc types like pdf etc. all three options are displayed. 

    Is there a setting to tweak, which will display all the 3 options for HTML attachments as well?

    Sunday, October 06, 2013 7:15 AM
  • Hi,

    Has this been resovled?  We are facing the same issue.

    thanks in advance!

    Wednesday, January 01, 2014 4:09 PM