none
how to uninstall & reinstall MCX (mobility) service in LYNC 2013

Answers

  • The mobility service is built into the Lync 2013 front end server, you can’t reinstall the mobility service separately.

    Please check the deployment process for mobility.

    http://technet.microsoft.com/en-us/library/hh690023.aspx

    You can use the command Test-CsMcxP2PIM to test your mobility deployment.


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.

    Thursday, July 11, 2013 1:27 PM
    Moderator

All replies

  • I had this issue as well. I think, for me, the resolution was to limit service usage to selected ip addresses for my FE. Publish the topology and reboot the server. I have a collocated mediation server and I read somewhere that "use all configured ip addresses" would not support mobility.

    Hope this helps.

    Wednesday, July 10, 2013 12:51 PM
  • Hi,

    Check this old thread which is answered. It might helpfull.

    http://social.technet.microsoft.com/Forums/lync/en-US/5f527276-a441-4254-a1f8-e59b45d33064/how-to-uninstall-lync-mobility

    http://social.technet.microsoft.com/Forums/lync/en-US/a2528a87-1776-4e76-ae8c-d529d975bfa2/remove-mobility-lync-2010


    Whenever you see a helpful reply, click on Vote As Helpful & click on Mark As Answer if a post answers your question.

    Wednesday, July 10, 2013 3:35 PM
  • Thanks for replying..

    Those are explaining for Lync 2010 and I have Lync 2013, and as you might be aware that mobility is in built to Lync 2013 so I don't see any related in program and feature to uninstall. And also like in Lync 2010 there was MCXstandalone.msi for installation of mobility, I don't see such for lync 2013.

    I am having a thought though....do you think this is MCX vdir issue? Cause I am able to do everything from mobile when I configure my mobile manually. I can login and do IM etc.

    It seems issue with autodiscover but my desktop lync client can discover my lync pool successfully using autodiscover. Don't know what going wrong with Mobile, I have tried with other mobiles too...same issue.

    Anyone here have any idea iif this could be issue with internal certificate using on TMG? Though I have installed root certificate on mobile phone.  And also desktop client can login using these certs.

    Thanks..


    MCTS|MCSE|MCSA:Messaging|CCNA

    Thursday, July 11, 2013 5:16 AM
  • Hi

    Simply publishing the topology and rerunning local setup actually "reinställs" it for you, or resets stuff that are wrong at least.

    You don't need the MCXstandalone.msi in 2013 its already included, and the MCX is only used for the 2010 version of the mobile clients.

    Also verify that all is good for both Lync and Exchange at https://www.testexchangeconnectivity.com/

    And check the Outlook Anywhere rule in the firewall so that all the required paths for lyncdiscover  are there.

    Make sure that the cert is trusted. I guess that's where I would start.


    Please “Vote As Helpful” and “Mark As Answer” if this post helped you :) Best Regards // Tommy Clarke - Please follow me @ <a href="http://www.ultimate-communications.com/"> Blog</a><br/> and <a href="http://twitter.com/itommyclarke">Twitter</a><br/>

    Thursday, July 11, 2013 11:43 AM
  • The mobility service is built into the Lync 2013 front end server, you can’t reinstall the mobility service separately.

    Please check the deployment process for mobility.

    http://technet.microsoft.com/en-us/library/hh690023.aspx

    You can use the command Test-CsMcxP2PIM to test your mobility deployment.


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.

    Thursday, July 11, 2013 1:27 PM
    Moderator