none
Option Not available to check compliance >= current driver version

    Question

  • Hi

    iam building the configuration item based on WQL Query check 

    when i create the compliance rule, iam not getting the "greater than or equal to" option in drop down 

    i get this option when i create the rule based on the registry key check 

    Regards

    Tanoj

    Wednesday, October 09, 2013 10:02 AM

Answers

  • Thanks for sharing screen shots. As I mentioned in my previous post "Can you please make sure that you are selecting correct Data type in WQL settings?", so what i observed is that you are selecting String Data type to verify version which is not recommended (and even "greater than or equal to" is not applicable for string data type) so better to use Version as data type then you will be able to select "greater than or equal to" operator in rules to verify Version.

    Plesae select Data type="Version" while creating WQL Settings to verify versions. Hope this helps you.


    This posting is provided "AS IS", provides no warranties, and confers no rights. -Praveen S.

    Thursday, October 10, 2013 6:39 PM
  • it worked !... Thank you
    Thursday, October 10, 2013 7:27 PM

All replies

  • Could you provide a screenshot please?

    Torsten Meringer | http://www.mssccmfaq.de

    Wednesday, October 09, 2013 10:31 AM
  • iam trying to attach a screen shot , however getting error that my account needs to be verified first before i can attach screen shot
    Wednesday, October 09, 2013 10:33 AM
  • i can mail you the screenshot if you ping me your mailid
    Wednesday, October 09, 2013 10:40 AM
  • Can you please make sure that you are selecting correct Data type in WQL settings? What options are listed in dropdown list on create rule page? Thanks


    This posting is provided "AS IS", provides no warranties, and confers no rights. -Praveen S.

    Wednesday, October 09, 2013 6:54 PM
  • [IMG]http://i42.tinypic.com/imttew.png[/IMG]

    Please open the above url, i have uploaded the picture

    Regards

    Tanoj

    Thursday, October 10, 2013 10:36 AM
  • 'Greater than or equal to' is not available so you have to put the logic in your script ... something like "if version > 1.2.3 return true else return false" and use that output in the CI.

    Torsten Meringer | http://www.mssccmfaq.de

    Thursday, October 10, 2013 10:45 AM
  • [IMG]http://i42.tinypic.com/s4z3sx.png[/IMG]

     i have uploaded two new pics, could you please check and suggest were i need to add the statement 

    Because what i on General tab, it will look for the class , once the class is up the "compliance rule" is the correct part to check Existential, Revision Rule, greater than on equal to current version rule

    i get this options when i create the CI with Registry key check

    Tanoj

    Thursday, October 10, 2013 11:44 AM
  • Thanks for sharing screen shots. As I mentioned in my previous post "Can you please make sure that you are selecting correct Data type in WQL settings?", so what i observed is that you are selecting String Data type to verify version which is not recommended (and even "greater than or equal to" is not applicable for string data type) so better to use Version as data type then you will be able to select "greater than or equal to" operator in rules to verify Version.

    Plesae select Data type="Version" while creating WQL Settings to verify versions. Hope this helps you.


    This posting is provided "AS IS", provides no warranties, and confers no rights. -Praveen S.

    Thursday, October 10, 2013 6:39 PM
  • it worked !... Thank you
    Thursday, October 10, 2013 7:27 PM
  • can you please marked the correct answer? This will helps other IT guys those having similar problem. Thank you!!!

    This posting is provided "AS IS", provides no warranties, and confers no rights. -Praveen S.

    Thursday, October 10, 2013 8:28 PM