none
Set max screen resolution after deployment has finished?

    Question

  • Whenever I deploy for example a HP Elitebook 2530p that has the max screen resolution 1280x800, the deploy always end with the screen resolution 1024x768. I was wondering if it is possible to set the screen resolution to max in the task sequence? I know there is a Xresolution andXresolution that you could set in the customsettings.ini but different laptops have different screen resolutions.

     

    /Alex
    Friday, April 02, 2010 7:37 PM

Answers

  • Set the screen resolution per Model in customsettings.ini (or in the MDT database, Make/Model node)

    Example with just the cs.ini:

    [Settings]
    Priority=Model, Default

    [Default]
    OSInstall=Y

    [Latitude D630]
    BitsPerPel=32
    VRefresh=60
    XResolution=1440
    YResolution=800

    [HP Compaq 8510w]
    BitsPerPel=32
    VRefresh=60
    XResolution=1920
    YResolution=1200

    • Marked as answer by Baatch Thursday, April 08, 2010 2:34 PM
    Saturday, April 03, 2010 8:09 AM
    Moderator

All replies

  • I have an HP EliteBook 2730P and 8530P. During deployment and on the login screen, the resolution is 800x600 or something similar but, upon first login, the resolution automatically jumps to the highest possible for that device (provided the driver installed correctly, of course.)

    As far as setting resolution during deployment, I know this can be done in Unattend.txt and/or Sysprep.inf but I've never had reason to test it.  

    Friday, April 02, 2010 8:02 PM
  • Do you mean when you log into a domain or just locally after the deployment? I have tried to log in locally as administrator after the deployment is finished but the screen resolution is still the same. The video drivers are installed.
    Friday, April 02, 2010 8:06 PM
  • Either/or. I have an automatic login after deployment to configure a few things - postsetup scripts - and the resolution remains. Laptop/tablet then reboots. Upon return to login screen, the resolution is usually fixed or the same and, in the situation where it is the same, once someone logs in to the domain - or a local admin logs in - the resolution changes to maximum. There's nothing in my postsetup scripts that have anything to do with resolution, so I assume it's the reboot that does the trick.

    Friday, April 02, 2010 8:12 PM
  • Set the screen resolution per Model in customsettings.ini (or in the MDT database, Make/Model node)

    Example with just the cs.ini:

    [Settings]
    Priority=Model, Default

    [Default]
    OSInstall=Y

    [Latitude D630]
    BitsPerPel=32
    VRefresh=60
    XResolution=1440
    YResolution=800

    [HP Compaq 8510w]
    BitsPerPel=32
    VRefresh=60
    XResolution=1920
    YResolution=1200

    • Marked as answer by Baatch Thursday, April 08, 2010 2:34 PM
    Saturday, April 03, 2010 8:09 AM
    Moderator
  • Thanks Johan, I used your settings for customers who uses Dell and HP laptops and it worked great. Couldn't use it on customers who uses lenovo laptops tho as the model code returns 20552CG and can be different for the same models. But I think I can solve it with a Set Task Sequence variable step with WMI query option.

    Thursday, April 08, 2010 2:34 PM
  • Johan,

    does the task sequence use the string between the [] brackets to WMI query the model? For instance Latitude D630 has to be exactly the same as the WMI ComputerSystem model name?

    Somehow our cs.ini won't effect the resolution at the end.

    Regards,
    Dutch guy

    Wednesday, December 08, 2010 1:21 PM
  • Exact the same... it doesn't do wildcards

    If you want wildcards you can have a userexit script do that for you

    / Johan

    Wednesday, December 08, 2010 2:44 PM
    Moderator
  • Johan and Dutch guy,

    My company also uses Dell Latitude laptops with wide screens and found that we had to remove the "Display" settings within the AnserFile of the Unattend.xml. "oobeSystem\x86_Microsoft-WindowsShell-Setup_neutral\display"  We discovered that the cs.ini would not set the resolution and caused our laptops to start the first time with the 1024x768 defined by the oobesystem. 

    Once we removed this our laptops opened at their highest resolution.

    GeeJay

    Tuesday, December 14, 2010 12:44 AM
  • That's odd, the configure action normally updates that info, even if it exist in the unattend.xml file...

    To satisfy my curiosity - would you mind zipping up the logs, uploading them somehwere and post the link?

    / Johan

    Tuesday, December 14, 2010 11:51 AM
    Moderator
  • Hi Team...

    Can you pls help on below

    how do i set customsettings ff it is Lenovo T530 Thinkcenter.

    Thursday, January 10, 2013 9:14 AM
  • Hi,

    Can you please tell me how did you setup for Lenovo...even i am also searching for the same...

    anything can be done in Task sequence

    Thursday, January 10, 2013 10:12 AM
  • All the computers I deploy have the perfect resolution by default.

    In order to do this, follow these steps:

    1. Manage that graphics driver will be injected during deployment
    2. Do NOT specifiy screen settings in customsettings.ini / bootstrap.ini or other configuration file
    3. Ensure that screen settings are NOT set in unattended.xml which is being used

    This way the best resolution will be used by default.

    Edit:
    Screen resolution is wrong when I deploy with attached monitor or attach the monitor afterwards.
    That's just a way more compley scenario, maybe even that can be figured out by someone :)


    • Edited by orioon Thursday, January 10, 2013 6:28 PM
    Thursday, January 10, 2013 6:25 PM