none
Getting "Windows could not parse or process the unattend answer file for pass [specialize]" with IE10 integration? Read this...

    Question

  • Hey guys,

    I just discovered an issue with using MDT to integrate Internet Explorer 10 into Windows 7 & 2008 R2 image files. Building the images was no problem at all, but when I tried to deploy them it would bomb with this error every time:

    "Windows could not parse or process the unattend answer file for pass [specialize]."

    So a very annoying and cryptic error to say the least. Obviously the issue was with the unattend.xml file that gets auto-generated by MDT, but all the items under "specialize" had worked just fine when I built the image and the IE version was the only item that had changed. After comparing the Windows 7 & Server 2008 R2 unattend.xml files to my Windows 8 & Server 2012 unattend.xml files (because they have IE 10 native) I discovered that the following flag was missing from the Windows 8 & Server 2012 unattend.xml files:
    <IEWelcomeMsg>false</IEWelcomeMsg>

    So I simply commented it out like so:



    Re-ran my test deployment and viola, 100% successful with zero errors. I was a little embarrassed/annoyed that this took me so long to track down, then I realized others might be struggling with this too so thought I'd share.

    Hope my time spent saves someone else some grief!
    Saturday, March 16, 2013 1:22 AM

Answers

  • Can you explain little more how we can integrate IE with win7 ?

    Regards, Shishir Kushawaha "If this thread answered your question, please click on "Mark as Answer"


    Yeah I'm assuming you have two shares, one for building image files and one for deploying them. When you build your image the first time just run Windows Update, install IE 10 and create your image file. Then just follow the instructions above for your image deployment share before you import and deploy your image.
    Saturday, March 16, 2013 12:15 PM

All replies

  • Can you explain little more how we can integrate IE with win7 ?

    Regards, Shishir Kushawaha "If this thread answered your question, please click on "Mark as Answer"

    Saturday, March 16, 2013 4:37 AM
  • Can you explain little more how we can integrate IE with win7 ?

    Regards, Shishir Kushawaha "If this thread answered your question, please click on "Mark as Answer"


    Yeah I'm assuming you have two shares, one for building image files and one for deploying them. When you build your image the first time just run Windows Update, install IE 10 and create your image file. Then just follow the instructions above for your image deployment share before you import and deploy your image.
    Saturday, March 16, 2013 12:15 PM
  • take a look at this post win7 +IE10

    and specifically to the solution by drcheese

    ok, this was pretty easy to fix actually.

    Right click your task sequence > OSinfo > edit unattend.xml.

    Wait 5 hours for it to process (zzzzz)

    Then in WSIM find Microsoft-Windows-IE-InternetExplorer

    Look for  IEWelcomeMsg > right click and disable "write image value" Save the unattend.

    You should be able to deploy then.

    to not wait 5 hours you can go to the control folder in your DS and look for the folder with your task sequence id and open the Unattend.xml from there with wsim it will save you time.

    might be that you need to point wsim to the right catalog file then though.


    Monday, March 18, 2013 8:48 AM
  • Brill... Thanks for posting, that's saved me quite some faffing around! :-)

    Cheers,

    Steve

    Monday, March 18, 2013 4:06 PM
  • Brilliant ! Thanks mate, it was driving me nuts.

    Ramu V Ramanan

    Monday, March 25, 2013 3:46 AM
  • Thank you, that solved my issue.  I spent days poking with no solution.
    Monday, April 08, 2013 7:02 PM
  • Fixed my issue. Was ready to give up on my Deployment Server. Thanks!

    Friday, April 12, 2013 4:11 PM
  • Wow.  You are awesome!  Thanks for posting this.  I have been banging my head against the wall for the past week because none of my new images would work.  Thanks a ton!
    Friday, April 12, 2013 7:22 PM
  • Wow. I spent days working on the solution to this problem. Just when I was about to give up..............here is the answer! This was a huge help.
    Friday, April 12, 2013 11:42 PM
  • Thank you for this post!

    Exactly the issue I was having when trying to deploy a new Windows 7 SP1 image with IE 10 pre-installed. We use third-party deployment software, called SpecOps, and I just couldn't work out why it wasn't working. Assumed it was the software.

    Many thanks, Luke.

    Monday, April 22, 2013 9:01 AM
  • Thank You! Just ran into this. IE 10 was the one thing I changed with my image.

    Thanks Again!



    Wednesday, April 24, 2013 10:51 PM
  • Thank you so much for this.  This was driving me crazy and I just had a feeling this was an IE10 issue because of the WSIM validation error.
    Thursday, April 25, 2013 7:25 PM
  • Top Notch!

    you should ask for a salary from Microsoft by doing their work. Imo it is crazy that IE10 causes this kind of problem. We also encountered IE10 issues when creating silent installers for deployment as well as a weird bug in a combination of IE10, follow-me printing and Sharepoint 2010 and a few documents.

    but back on topic:

    I ran my build a couple of times now and so far so good.

    I needed to remove the line though as I received the notorious 0x80004005 error if I left these lines in my unattend.xml, even when I commented them and verifying the comment in Notepad++.

    Thank you very much for sharing!

    Thursday, May 23, 2013 3:42 PM
  • I know the last reply was from a couple weeks ago, but honestly, I haven't been able to find anything else in the last week of searching Google. I'm new to the MDT process but I'm having the same issue with what you posted. I can shift-F10 during the "Applying system settings" and open my unattend.xml file and remove the IEWelcomeMsg line and the image deploys perfectly, so I know that's my problem. I can't figure out where that line is coming from. I have edited every unattend.xml file in the Templates folder under MDT and also the one in my deployment task sequence, but somewhere during that deployment, that one setting gets added back to the unattend file and nukes the whole image. I'm about to pull my hair out. I'm implementing MDT to save time but I feel like the last couple of weeks trying to get it to work have been a waste. I have thought about backing my reference image back to IE9, but having to deploy IE10 post image seems like it's an unnecessary burden. Any help would be appreciated.

    ~Adam

    Monday, June 10, 2013 6:53 PM
  • the template is only used when making new deployment shares

    you should go to your deploymentshare and go to your control folder in there you find folders named like your Task sequence ID in there is the unattended.xml which you have to edit.

    Monday, June 10, 2013 7:25 PM
  • Stefan,

    Thanks for the reply. I have modified the Unattend.xml file under my Control\Deployment Task Sequence folder, yet when I run that deployment sequence, I still get an Unattend.xml file on the client with the IEWelcomeMsg entry in it. Is there a step in the deployment process where this might be added back into the unattend file?

    Thanks.

    Tuesday, June 11, 2013 11:39 AM
  • if you make sure the little enable sign is not next to write value it will still be in there but the actual value will be not be used so you won't have any problems

    or do like OP did and just edit your unattend.xml with notepad or something and comment out the

    <IEWelcomeMsg>false</IEWelcomeMsg>

    Friday, June 14, 2013 5:57 PM
  • Just checked my unattend.xml in MDT and IEWelcomeMsg is enabled again after I disabled it a while ago. It doesn't seem to cause a problem anymore even when it's enabled. Does anyone have any idea why? Thanks.
    Thursday, June 27, 2013 3:42 PM
  • If this works I will find you....and hug you.
    Thursday, July 25, 2013 7:23 PM
  • You are not getting a hug....
    Thursday, July 25, 2013 7:50 PM
  • If this works I will find you....and hug you.  The other guy was wrong.  Bad things will befall him I'm sure.
    Thursday, July 25, 2013 7:52 PM
  • Wrong MAK key. Could have been the IE 10 thing too but looks like it was the wrong key.  They are in the same section.
    Thursday, July 25, 2013 8:25 PM
  • I can't believe this kind of bug exists.  This bug exists in the latest releases of MDT 2012.  

    This needs a patch.  Its unreasonable to expect people to manually modify the unattend.xml for all their different task sequences.  My custom and noncustom os's are failing if I include the latest microsoft patches in my MDT packages folder.  One of the windows updates is incompatible with the default unattend.  

    Sloppy Job Dev team.


    • Edited by madmaan Wednesday, August 14, 2013 10:45 PM
    Wednesday, August 14, 2013 10:44 PM
  • I can't believe this kind of bug exists.  This bug exists in the latest releases of MDT 2012.  

    As a note, it's been fixed in MDT 2013 Preview. : )

    David Coulter | http://DCtheGeek.blogspot.com | @DCtheGeek

    Thursday, August 15, 2013 12:22 AM
    Answerer
  • I can't believe this kind of bug exists.  This bug exists in the latest releases of MDT 2012.  

    As a note, it's been fixed in MDT 2013 Preview. : )

    David Coulter | http://DCtheGeek.blogspot.com | @DCtheGeek

    I just tested this and this statement does not appear to be true.  A clean install of the new mdt 2013 still has this bug.
    Friday, August 23, 2013 6:17 PM
  • Zeus - you da man.

    Saturday, August 24, 2013 2:51 PM
  • Thanks! My x64 wim worked perfectly but I got this bug on my x32 image (Windows 7).
    Wednesday, September 18, 2013 10:56 AM
  • I think this would surely solve the problem. Only one question though. In order to edit the unattend.xml directly as the OP did, where exactly do I do that at. Should this be done in DeploymentShare\Control\TS_Name\unattend.xml? Or somewhere else. I swear I changed it here and when I tried to deploy, got the error. However, when I went back in just now to check it, the comments were stripped out again. 

    Maybe I changed a different one, but just wanted to double check where this needed to be done. Thanks!

    Mike

    Friday, September 27, 2013 3:17 PM
  • Mike, I was running into the same problem.  

    You're in the right place for the unattend.xml   deploymentshare\control\[TS_Number]\unattend.xml

    During deployment, it stripped out the comment tags in my unattend, or that's at least what i'm assuming. I ended up (backing up the file) and deleting the whole IE component from the .xml using MS notepad. 

    I just tested with another deployment and it went through fine. Hope it works for you too!

    -Tom

    EDIT: Go into SIM and add component "microsoft-windows-IE-InternetExplorer_8.0.7601.17514_neutral"  I changed a couple options and saved it over the unattend in [control\TS_#\unattend.xml]

    I had a second deployment image in which I tried my first fix and concluded that it was only a partial fix.

    • Edited by R4ngerT0m Tuesday, October 01, 2013 3:03 PM completed fix
    Monday, September 30, 2013 3:01 PM
  • This worked for me as well.

    To comment out the offending line here's the format:

    Before:  <IEWelcomeMsg>false</IEWelcomeMsg>

    After:  <!-- <IEWelcomeMsg>false</IEWelcomeMsg> -->

    • Proposed as answer by Big_Mark Wednesday, October 16, 2013 5:58 PM
    Wednesday, October 16, 2013 5:57 PM
  • A massive thank you!

    I was suspecting IE10 was culprit since with IE9 I got clean builds, but I changed far too much in the config to be able to find it.

    Respect!

    So much for Microsoft "Out Of Box experience"...lol!

    Wednesday, November 13, 2013 9:11 AM
  • You definitely saved me some grief. Thanks so much! I used the Windows SIM, which had it located in the location of Unattend->Components->4 Specialize->amd64_Microsoft-Windows-IE-InternetExplorer_neutral->IEWelcomeMsg. I just deleted the entire IEWelcomeMsg object and had no further problems.

    Hope this helps!

    Wednesday, January 08, 2014 4:39 PM
  • Thanks guys

    I had same issue with deployment and this helped me to solve the issue

    Monday, March 24, 2014 5:47 AM