none
Windows 7 - Cannot run multiple instances of excel using "Ignore other applications that use DDE" option

    Question

  • To make it short and simple, I need to be able to have an excel workbook open in a new instance every time I double-click an excel file. As of right now, when multiple excel workbooks are opened, they all get dumped into the same excel instance. There seems to be no viable resolution to this for Windows 7 users.

    With Windows XP, the option to display multiple excel 2007 instances at once could be achieved by checking the "Ignore other applications that use Dynamic Data Exchange (DDE)" checkbox. In Windows 7, when this option is checked, an error comes up stating "There was a problem sending the command to the program". I work at an accounting firm, so the ability to run multiple workbooks in different excel instances is absolutely crucial for daily workflow. Below are the steps I have attempted to get multiple excel instances running in Windows 7. If no one can offer a viable solution to this problem, I will be downgrading to Windows XP and will not deploy Windows 7 in our office until Microsoft acknowledges and resolves this issue.
    • I have ran excel 2007 in every compatible mode listed and tried switching the 'Run as Administrator' option off and on with each compatible mode.
    • I attempted to edit the startup command for excel to the following: “C:Program FilesMicrosoft OfficeOffice12EXCEL.EXE” /e “%1″ , but could not locate which registry setting to change ("The application to perform action" field has been removed from the folder options in Windows 7).
    • I installed the runexcel batch file, pointed all .xls and .xlsx files to run this batch file instead of excel 2007, and changed the icon settings. This allowed for multiple instances of excel to be opened from a saved file. However, we use a program called Engagement that utilizes accounting binders that have excel sheets in them. When opening excel files from this program, the files don't seem to associate with running in the batch file and revert back to opening in a single instance. It seems that the workaround needs to be tied directly to Microsoft excel and not to a batch file.
    • The option to span an excel instance over two monitors and open two workbooks in one spanned instance is not a viable option. Each accountant opens dozens of excel sheets every day, which makes the workaround far too unwieldy.
    Wednesday, February 24, 2010 8:50 PM

Answers

  • Got this from an outside source and thought I would share :)
    In Windows 7 you have to edit the registry to remove DDE completely. This should work for Vista too. Check the "Ignore other applications that use Dynamic Data Exchange (DDE)" box in Excel -> Excel Options -> Advanced This alone might work for you by itself - didn't for me, I got an error every time I double-clicked on an excel document. BACK UP your registry.

    Open regedit, browse to HKEY_CLASSES_ROOT\Excel.Sheet.8\shell\Open Delete the ddeexec key, (or just rename it if you are worried - i just renamed it and it worked) Then click on the "command" key and replace the /e on the Default and command string in that key with "%1" Quotes around %1 are important. NO QUOTES MEANS NO WORKIE!!!!

    HKEY_CLASSES_ROOT\Excel.Sheet.8\shell\Open\command should look like this: (Default) REG_SZ "C:\Program Files (x86)\Microsoft Office\Office12\EXCEL.EXE" "%1 command REG_MULTI_SZ vUpAVX!!!!!!!!!MKKSkEXCELFiles>tW{~$4Q]c@II=l2xaTO5 "%1"

    Do the same for Excel.Sheet.12 Now Both .xls and .xlsx should open in new windows with no errors.

    I have confirmed that the same problem occurs in Office 2010x64 (32bit probably also) when checking the dde option. This should fix All vista and windows 7 problems with opening excel in seperate windows :) Enjoy!
    • Proposed as answer by MikeT1831 Tuesday, March 09, 2010 4:14 PM
    • Marked as answer by David Wolters Friday, August 20, 2010 5:56 PM
    Tuesday, March 09, 2010 3:27 PM

All replies

  • Agreed.

    I hope this is fixed soon. While I don't open that many spreadsheets each day, I do open 15-20 different ones throughout the week. It would be much better to have several Excel windows open on different monitors than to try struggling with looking at one monitor.

    I concur on the DDE issue - if it is checked, Excel will not open the file even if only one spreadsheet is loaded.
    Tuesday, March 02, 2010 8:14 PM
  • Got this from an outside source and thought I would share :)
    In Windows 7 you have to edit the registry to remove DDE completely. This should work for Vista too. Check the "Ignore other applications that use Dynamic Data Exchange (DDE)" box in Excel -> Excel Options -> Advanced This alone might work for you by itself - didn't for me, I got an error every time I double-clicked on an excel document. BACK UP your registry.

    Open regedit, browse to HKEY_CLASSES_ROOT\Excel.Sheet.8\shell\Open Delete the ddeexec key, (or just rename it if you are worried - i just renamed it and it worked) Then click on the "command" key and replace the /e on the Default and command string in that key with "%1" Quotes around %1 are important. NO QUOTES MEANS NO WORKIE!!!!

    HKEY_CLASSES_ROOT\Excel.Sheet.8\shell\Open\command should look like this: (Default) REG_SZ "C:\Program Files (x86)\Microsoft Office\Office12\EXCEL.EXE" "%1 command REG_MULTI_SZ vUpAVX!!!!!!!!!MKKSkEXCELFiles>tW{~$4Q]c@II=l2xaTO5 "%1"

    Do the same for Excel.Sheet.12 Now Both .xls and .xlsx should open in new windows with no errors.

    I have confirmed that the same problem occurs in Office 2010x64 (32bit probably also) when checking the dde option. This should fix All vista and windows 7 problems with opening excel in seperate windows :) Enjoy!
    • Proposed as answer by MikeT1831 Tuesday, March 09, 2010 4:14 PM
    • Marked as answer by David Wolters Friday, August 20, 2010 5:56 PM
    Tuesday, March 09, 2010 3:27 PM
  • This worked! FINALLY!

    Excel 2003
    Windows 7 Pro 64 bit

    NOTE: make sure to do this for CSV files too if you use them!

    Thank you Turbo2001rt!
    Tuesday, March 09, 2010 4:18 PM
  • The registry hacked worked great on my Windows 7 Pro machine, running Excel 2007. Thank you!

    Friday, March 26, 2010 9:01 PM
  • this works great on my computer, and the problem is finally fixed, thanks so much for the information!

     

    truly helpful! 

    Wednesday, April 07, 2010 3:02 AM
  • THANKS DUDE!  My only other option was to launch Excel and then use File > Open, which was annoying...

    I have Windows 7 Ultimate, 32-bit (got it free from a Microsoft convention hehe) and Office 2003.  I hate Office 2007...

    I only had the Sheet.8 so I only changed that one.  It worked great. I didn't have to do Sheet12.

    I think Turbo missed a quote at the end of his DEFAULT string value.  He just put: "%1

    It should be "%1"

    Anyways, for my HKEY_CLASSES_ROOT\Excel.Sheet.8\shell\Open\command\, it had these two string values and this is what they looked like AFTER I changed them:

    Default string value:    "C:\Program Files\Microsoft Office\OFFICE11\EXCEL.EXE" "%1"

    Command string value:    (f'^Vn-}f(ZXfeAR6.jiEXCELFiles>!De@]Vz(r=f`1lfq`?R& "%1" 

     

    Sunday, May 09, 2010 12:48 AM
  • Dear Turbo2001rt,

    Thanks a lot for sharing your know-how!

    No longer get  the message "There was a problem sending the comand to the application" while oppening excel files. Your solution worked smoothly for Excel 2003 under Windows 7.

    Regards

     

     

     

    Thursday, May 13, 2010 7:38 PM
  • Thank you, Turbo2001rt, that worked like a charm.  I would also like to have multiple instances of excel for other file types like .csv (comma separated values) and .xlsm (macro-enabled spreadsheets).  Does anyone know which registry keys I need to change to get those to work?  In general, how can you tell which keys refer to which file types?  It doesn't seem intuitive that "Excel.Sheet.12" affects .xlsx files and "Excel.Sheet.8" affects .xls files to me, so I don't know how to extrapolate.

     

    Saturday, June 05, 2010 2:22 AM
  • I've created an account just to thank Turbo2001rt for the Registry Hack! Worked great on my Win7-64 / Office 2010-64 setup.

    Althoug instead of "/e" I replaced "/dde"..

    Monday, July 26, 2010 12:54 PM
  • I made a reg file to apply this quickly and easily. (Export your registry keys first, as always.)

    Save as .reg file, execute/merge, rejoice. (Rejoicing is optional.)

    Windows Registry Editor Version 5.00
    
    [HKEY_CLASSES_ROOT\Excel.Sheet.8\shell\Open]
    @="&Open"
    
    [-HKEY_CLASSES_ROOT\Excel.Sheet.8\shell\Open\ddeexec]
    
    [HKEY_CLASSES_ROOT\Excel.Sheet.8\shell\Open\command]
    @="\"C:\\Program Files (x86)\\Microsoft Office\\Office14\\EXCEL.EXE\" \"%1\""
    "command"=hex(7):78,00,62,00,27,00,42,00,56,00,35,00,21,00,21,00,21,00,21,00,\
     21,00,21,00,21,00,21,00,21,00,4d,00,4b,00,4b,00,53,00,6b,00,45,00,58,00,43,\
     00,45,00,4c,00,46,00,69,00,6c,00,65,00,73,00,3e,00,56,00,69,00,6a,00,71,00,\
     42,00,6f,00,66,00,28,00,59,00,38,00,27,00,77,00,21,00,46,00,49,00,64,00,31,\
     00,67,00,4c,00,51,00,20,00,22,00,25,00,31,00,22,00,00,00,00,00
    
    [HKEY_CLASSES_ROOT\Excel.Sheet.12\shell\Open]
    @="&Open"
    
    [HKEY_CLASSES_ROOT\Excel.Sheet.12\shell\Open\command]
    @="\"C:\\Program Files (x86)\\Microsoft Office\\Office14\\EXCEL.EXE\" \"%1\""
    "command"=hex(7):78,00,62,00,27,00,42,00,56,00,35,00,21,00,21,00,21,00,21,00,\
     21,00,21,00,21,00,21,00,21,00,4d,00,4b,00,4b,00,53,00,6b,00,45,00,58,00,43,\
     00,45,00,4c,00,46,00,69,00,6c,00,65,00,73,00,3e,00,56,00,69,00,6a,00,71,00,\
     42,00,6f,00,66,00,28,00,59,00,38,00,27,00,77,00,21,00,46,00,49,00,64,00,31,\
     00,67,00,4c,00,51,00,20,00,22,00,25,00,31,00,22,00,00,00,00,00
    
    [-HKEY_CLASSES_ROOT\Excel.Sheet.12\shell\Open\ddeexec]
    
    


    Thursday, August 05, 2010 5:04 PM
  • Thanks for the tip. I am running office 2003 on a windows 7 machine. I tried your fix and its not working for me below you will find what my registry entries look like. am I missing some thing. thanks for any help you can give.

    sheet8

    "C:\Program Files (x86)\Microsoft Office\OFFICE11\EXCEL.EXE" "%1"

    ']gAVn-}f(ZXfeAR6.jiEXCELFiles>!De@]Vz(r=f`1lfq`?R& "%1"

    sheet12

    "C:\PROGRA~2\MICROS~1\OFFICE11\EXCEL.EXE" "%1"

     

    Wednesday, September 15, 2010 1:02 PM
  • I tried this...and bing it worked.Thanks a ton!!!

    I'm running Windows 7 (64 bit) and Office 2010.

    Woot!!

     

    P.S.  As stated above, I swapped out the "%1" with /dde instead of /e. In addition to my registery for command looked different.

    Here's what they both looked liked after:

    "C:\Program Files (x86)\Microsoft Office\Office14\EXCEL.EXE" "%1"

    xb'BV5!!!!!!!!!MKKSkEXCELFiles>VijqBof(Y8'w!FId1gLQ "%1"

     

    • Proposed as answer by kalenb Friday, October 08, 2010 1:19 AM
    • Unproposed as answer by David Wolters Monday, February 06, 2012 9:31 PM
    Friday, October 08, 2010 1:11 AM
  • Turbo's solution worked for me - I now get a new excel instance when selecting files from Windows Explorer.  However, sometimes I want the files to open in the same instance, but this solution gives a new instance for each excel document.  I normally have two instances, one for each screen, and I want to be able to open an excel file from Windows Explorer into the last instance that I had active.  I'm used to how Windows XP works, but can't seem to figure out how to get Windows 7 to work exactly the same.  Does anybody have the answer?

    Wednesday, October 20, 2010 1:57 PM
  • Hi,

    I had the same problem and Turbo2000's solution worked! But I'm having the problem with PowerPoint and I can't seem to fix it because I can't find the PowerPoint's ddeexec registy key. Any ideas?

    Thanks

    Thursday, November 04, 2010 4:22 PM
  • How about opening the second one via the Excel icon? 

    Meaning, double click on one file ie: budget.xlsx to open Excel and then go to your Start/All Programs/Microsoft Office and right click on the Excel icon.  Or you have Excel shortcut on your taskpane, right click on it and choose Microsoft Excel, usually 3rd from the bottom in the list.

    Works for me.

    Thursday, November 04, 2010 5:50 PM
  • Turbo2001rt,

    I just wanted to say thank you passing along this information. This one was hard to find, but man it worked perfectly!

    All the best,

    John

    Wednesday, November 17, 2010 6:22 PM
  • Hi, I am using Windows 7 (64 Bit) with MS Office 2007. I think I have the exact opposite problem. When I double click on an excel file it opens in an entirely new instance. So if I have to apply formulas or VLookUps between two different sheets the Function Argument box doesn't recognize the other excel file which is open. Can you please guide me as to how to enable excel to open the file(s) in the same instance when I double click them. Thanks a million.
    Monday, March 07, 2011 11:26 AM
  • Hello All

    This has definitely been the easiest way to sort out this problem. Many thanks to everyone.

    Sunday, April 03, 2011 3:22 PM
  • This fix finally worked like a charm after what felt like an eternity of searching the web.

     

    Thanks a bunch!

    Thursday, April 14, 2011 4:06 PM
  • Thank you! This worked!
    Friday, July 22, 2011 6:01 AM
  • Thank you, Turbo2001rt, that worked like a charm.  I would also like to have multiple instances of excel for other file types like .csv (comma separated values) and .xlsm (macro-enabled spreadsheets).  Does anyone know which registry keys I need to change to get those to work?  In general, how can you tell which keys refer to which file types?  It doesn't seem intuitive that "Excel.Sheet.12" affects .xlsx files and "Excel.Sheet.8" affects .xls files to me, so I don't know how to extrapolate.

     

    For .csv and .xlsm file, do the same to "Excel.CSV" and "Excel.SheetMacroEnabled.12"

    Wednesday, August 31, 2011 4:29 PM
  • Thanks Turbo2001rt. Your solution worked like a charm. This has been bugging me for ages.
    Wednesday, October 05, 2011 9:59 AM
  • I have the same problem, do you could solve?
    and if so, could you tell me how you did it?

    thanks

    Wednesday, February 01, 2012 2:24 PM
  • MikeT1831, Thanks for the answer! I spent hours trying to solve this for a client and was out of ideas when I read your post. I should mention that this works for my client's set up:

    • Windows 2008 Foundation Server R2
    • Office 2010 Pro running Business Contact Manager

    Again, thanks for taking the time. If I could buy you a cup of coffee I would.

    -- Kevin

    Friday, February 10, 2012 9:54 PM
  • Thanks Turbo2001rt!
    Wednesday, February 15, 2012 5:30 PM
  • Thanks!

    Actually I only had to check the "Ignore other applications that use Dynamic Data Exchange (DDE)" option and it worked! :)

    Cheerz,

    Arne

    Friday, March 09, 2012 12:47 PM
  • So excited to try TURBO's solution this with Excel.  Does anyone know how to do this with PowerPoint?  Same need exists as Excel.  TY!!
    Wednesday, March 14, 2012 10:24 PM
  • This worked like a champ for me!  I appreciate it!  I do have one more question for you.  Now when I receive an excel file via email, I can't open the attachment.  Well better said I can open the attached excel file, but when it opens it just shows a blank screen.  All toolbars, home buttons, or the "ribbon" etc... are still there, but that is about it.  If I copy the file and then save it to my desktop or my documents and then open it, it works just fine.  I just can't open and view the file when trying to open it from my email inbox (Outlook 2010).  Any ideas or suggestions?

    Thanks!

    Wednesday, May 16, 2012 4:27 PM
  • The registry edit works absolutely for Excel/Office 2010.

    Both the (default) and command keys must be edited as described and the ddeexec key must be removed or renamed. I renamed mine to avoid any surprise, but there was none.

    I can now dbl-clk on shortcuts and each opens in a new instance of Excel.

    Saturday, July 28, 2012 12:26 AM
  • Hi All,

    Here is another solution. In windows explorer navigate to "Program Files (x86)\Microsoft\Office\Office14" (this path may differ slightly depending on your version of MS Office), right-click on EXCEL.EXE and choose "create shortcut". Then cut or copy this shortcut and navigate to "%AppData%\Microsoft\Windows\SendTo" in windows explorer and paste the EXCEL.EXE shortcut.

    Now, when you want to open an excel spreadsheet from windows explorer, right-click on the spreadsheet and choose "Send To" then choose "Excel". This will open your file in a new instance of Excel every time.

    ***

    Another possible solution: Press keyboard keys START+R (START is also known as the WINDOWS key) which opens the RUN command. Type in "excel" and press ENTER. This will open a new instance of EXCEL. If you do no want to use the file+open dialogue to open your spreadsheet at this point, you can drag and drop the spreadsheet from windows explorer into the new excel instance and it will load the file.

    This may be easier (and safer for some) than registry editing.

    --digband

    • Edited by digband Wednesday, August 08, 2012 5:43 PM
    • Proposed as answer by digband Wednesday, August 08, 2012 5:45 PM
    Wednesday, August 08, 2012 5:29 PM
  • Follow these steps:

    Start -> type "run" into the "Search Programs and files" and hit Enter -> type regedit and hit Enter:

    Left column: HKEY_CLASSES_ROOT/Excel.Sheet.8/shell/Open/commend:

    Right column {adding (space)"%1"}: (be sure to include the quotation marks when typing)

    Double Click on (Default) and write - "C:\Program Files\Microsoft Office\Office12\EXCEL.EXE" /e "%1"

    Right Click on Command – choose "rename" and add something to the name  - for example 2 (commend2).

    Left column: HKEY_CLASSES_ROOT/Excel.Sheet.8/shell/Open/ddeexec:

    Right Click on the folder ddeexec and choose "rename" and add something to the name  - for example 2 (ddeexec2)

    Left column HKEY_CLASSES_ROOT/Excel.Sheet.12/shell/Open/commend:

    Right column {adding (space)"%1"}

    Double Click on (Default) and write - "C:\Program Files\Microsoft Office\Office12\EXCEL.EXE" /e "%1"

    Right Click on Command – choose "rename" and add something to the name  - for example 2 (commend2).

    no restart needed. You can do this for .CSV files as well. Have Fun, and please share this answer with others

    Tuesday, November 27, 2012 10:36 PM
  • Turbo2001rt  you are the MAN!  I spent 3 days to find out the problem, and only your (regedit)directions helped! I'm so happy now! I'm not much into computers, but your explanation worked! Thank you very much!!!!
    Wednesday, April 24, 2013 7:24 PM
  • Hi guys, maybe I'm missing the point here or something but there's a really simple run command for this. For example go to run and enter the file path to excel followed by the /secondary command "C:\Program Files\Microsoft Office\Office14\EXCEL.EXE" /secondary This should open up a second instance of excel without the need to edit the registry, run batch files or any other unnecessary stuff. If I've completely missed the point here let me know :)
    Monday, May 06, 2013 7:35 AM
  • Hello,

    I was using this fix for excel now, as of 09/16/2013, it appears that an update was done and multiple instances is not working I cannot figure out a fix any ideas????? Any help will be much appreciated!!!!!

    Thursday, September 19, 2013 7:23 PM
  • Running Win 7 64 bit with Office 2010 32 bit and this worked perfectly for me.  Thanks for the help.

    Ron

    Tuesday, September 24, 2013 1:58 PM
  • THANK YOU SO MUCH.  I have been banging my head trying to fix this! Yours worked!

    Friday, April 25, 2014 3:33 AM
  • There is a " missing after 1 in this line

     "C:\Program Files (x86)\Microsoft Office\Office12\EXCEL.EXE" "%1

    Thursday, May 15, 2014 6:02 AM
  • This worked perfectly for me. It took nearly an hour of searching to find this article, as none of the other fixes worked for me.

    I am running Microsoft Office 2013 on Windows 8 x64 (in Virtualbox on my Mac) and it worked perfectly.

    Thanks a TON!

    Thursday, July 31, 2014 6:14 PM
  • Plenty of people already mentioning the "%1" replacement option, which is GREAT! (and thank you to all those for providing that)

    However....that doesn't work for the 'Print' context option.  (sure, it's less used: That's not the point)

    Same DDE error, and you need to be able to tell excel to do more to get it to print.  In word, there are macros you can call to do this at the launch command line, BUT: they don't exist in Excel.  (that I could find/get to work, anyway)

    (My 'solution' for our users was to edit the context menu for all (ack) excel controlled files and remove the 'print' option - so they can directly print any file you want, as long as it's not a spreadsheet...or csv...etc...)

    Cmon, MS....I have a copy of 2013 SP1 (unpatched) that works fine.  Obviously the hotfixes after SP1 have broken something (apparently this issue has been fixed/broken/fixed/broken/ etc etc...)

    Friday, August 01, 2014 1:37 AM
  • Ignore other applications that use dynamic exchange DDE

    To fix up this in Ms Office uncheck the option from> Options>  advanced > "Ignore other applications that use dynamic exchange DDE" that's it.

    

    Thursday, August 14, 2014 12:37 PM