none
Document Conversion Failing

    Question

  • I am getting the following errors when trying to run a document conversion in Sharepoint 2007.

    Document Conversions           Communication                  75fl Medium   Trying to get launcher from load balancer 
    Document Conversions           Communication                  75fk Medium   Requesting launcher from load balancer 
    Document Conversions           Communication                  5476 Critical Load Balancer not responding:  The remote server returned an error: (407) Proxy Authentication Required. 
    Document Conversions           Communication                  75fm High     Couldn't talk to Load Balancer or Launcher 
    Document Conversions           Timer Job                      5448 Critical Le convertisseur de documents n'a pas pu convertir le fichier.

    However, at intervals I get the following messages logged (which I also get on the working dev environment)
    Document Conversions           Launcher Service               7jdv Verbose  EnsureLoadBalancerStatus called 
    Document Conversions           Launcher Service               7jg8 Verbose  Calling LoadBalancer.RegisterLauncher 
    Document Conversions           Load Balancer Service          7jhf Medium   RegisterLauncher called with uri ..//svrName:port/HtmlTrLauncher 
    Document Conversions           Load Balancer Service          7jht Verbose  LoadList: Add Called: ..//svrName:port/HtmlTrLauncher, 0 
    Document Conversions           Load Balancer Service          7jhu Verbose  (note: expected after EnsureLoadBalancerStatus call) register launcher called for uri that's already registered: ..//svrName:port/HtmlTrLauncher 
    Document Conversions           Launcher Service               7jg9 Verbose  LoadBalancer.RegisterLauncher succesful 

    Document Conversion used to work in this environment but at some point (I don't know when) it has stopped working.
    This is our QA environment and I have compared user accounts and sharepoint settings with our dev environment which is still working.
    Our QA farm has 3 servers with the Load Balancer and Launcher running on the same machine as the CA.

    In particular I have checked the following settings,

    svrName\HVU_svrName is a member of Guests group
    I have given this user Logon to this machine permissions but this made no difference (our dev hvu_user does not have this permission)


    Permissions on ..Program Files\Microsoft Office Servers\12.0\Bin\ HtmlTrLauncher
     Hvu_svrName - Full permissions
     System – Full permissions

    Regedit
     HKEY_LM\software\Microsoft\Office Server\12.0\LauncherSettings  (..//svrName:port/HtmlTrLoadBalancer)
     HKEY_LM\software\Microsoft\Office Server\12.0\LoadBalancerSettings

    In CA, the server is selected as the Load Balancer and the ports match with the registry settings.

    Services
     Office Document Conversions Load Balancer Service runs under Local Service
     Office Document Conversions Launcher Service runs under Local System
    (I have tried changing the Balancer to run under Network Service but this did not work - I have reset it back to Local Service and reset the Timers on the servers in the farm)

    Config files for the Load Balancer and Launcher
    ..\Program Files\Microsoft Office Servers\12.0\Bin\Microsoft.Office.Server.Conversions.Launcher.exe.config
    ..\Program Files\Microsoft Office Servers\12.0\Bin\ Microsoft.Office.Server.Conversions.LoadBalancer.exe.config

    Checked Publishing Services are turned on for both the site and the Site Collection

    Launch order - Started the Load Balancer and then the Launcher service

    Tried netstat –an to see if the ports are being listened to which they are.

    Any help and additional suggestions for fixes or troubleshooting will be greatly appreciated - thanks.

    Thursday, August 08, 2013 11:28 AM

Answers

  • Thank you for your reply. I have already tried bypassing the proxy and this made no difference (and again, the setting here is the same as in our dev environment). I will work through it again using Fiddler.

    Many thanks.

    Thursday, August 15, 2013 8:08 AM

All replies

  • Hi NKT01,

    I am trying to involve someone familiar with this topic to further look at this issue.

    Thanks,
    Daniel Yang
    Forum Support
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com. 


    Daniel Yang
    TechNet Community Support

    Monday, August 12, 2013 1:26 AM
    Moderator
  • Hi NKT01,

    regarding this issue there are some parts that you may want to try,

    1. bypass proxy,

    • Configure proxy server settings to bypass the proxy server for local addresses

      1.  In Internet Explorer, on the Tools menu, click Internet Options.

      2.  On the Connections tab, in the Local Area Network (LAN) settings area, click LAN Settings.

      3.  In the Automatic configuration section, clear the Automatically detect settings check box.

      4.  In the Proxy Server section, select the Use a proxy server for your LAN check box.

      5.  Type the address of the proxy server in the Address box.

      6.  Type the port number of the proxy server in the Port box.

      7.  Select the Bypass proxy server for local addresses check box.

      8.  Click OK to close the Local Area Network (LAN) Settings dialog box.

      9.  Click OK to close the Internet Options dialog box.

    2. check fiddler to trace web request

    In Fiddler, Under Rules, check “Automatically Authenticate”.

    and then check your web.config :

    <system.net>
       
    <defaultProxy>
    <proxy proxyaddress="address:port" bypassonlocal="True" />
       
    </defaultProxy>
     
    </system.net>

    3. set application with proxy.

    Example : 
    DataSetmyds = new DataSet();
    //Set the system proxy with valid server address or IP and port.
    System.Net.WebProxy pry = new System.Net.WebProxy("172.16.0.1",8080);
    //The DefaultCredentials automically get username and password.
    pry.Credentials = CredentialCache.DefaultCredentials;
    GlobalProxySelection.Select = pry;
    myds.ReadXml("http://msdn.microsoft.com/netframework/rss.xml", XmlReadMode.Auto);
    myds.WriteXmlSchema(@"c:\\f.xml");
    this.GridView1.DataSource = myds.Tables[2];
    this.GridView1.DataBind();

    if should these 3 parts already checked, then i suggest that you ask for your network admin help to trace out the network monitor and check if should the package is correct, and the health of your load balance application.

    if you may compare between your dev stage and prod stage, check if should this fix implemented: http://support.microsoft.com/kb/962928/en-us


    Regards,
    Aries
    Microsoft Online Community Support


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.

    Monday, August 12, 2013 3:10 AM
  • Thank you for your reply. I have already tried bypassing the proxy and this made no difference (and again, the setting here is the same as in our dev environment). I will work through it again using Fiddler.

    Many thanks.

    Thursday, August 15, 2013 8:08 AM
  • Hi NKT01,

    regarding this issue, is there any updates that we may have?


    Regards,
    Aries
    Microsoft Online Community Support


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.

    Wednesday, August 21, 2013 1:40 AM
  • Hi NKT01,

    for temporary, i will mark your post as propose as answer,

    if should you have more questions or updates in the future, you may reply to this thread, or you may open an advisory ticket to us so that we may give you better support regarding this issue.


    Regards,
    Aries
    Microsoft Online Community Support


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.

    Tuesday, August 27, 2013 3:09 AM