none
SCCM 2012 Automatic Deployment for Endpoint Protection error - " Auto Deployment Rule Download Failed 0x87D20417'

    Question

  • Hello,

    We changed the proxy server at our organisation and after that the auto deployment rule for MSEP2010 is not running, it fails with Auto Deployment rule Download fialed 0x87D20417, It is showing all the Software updates but it is not downloading, the internet is working fine on the server, i have changed the proxy settings in sccm 2012.

    I connected back to my old proxy server and everything works fine, the only difference between the two proxy server is the old one we have to mention a IP with the new one we dont have to.

    Am i missing something some settings in sccm 2012


    Regards, Joel

    Tuesday, November 05, 2013 4:22 AM

Answers

  • Finally i resolved the issue,

    even though i removed the proxy settings from my internet explorer, it was still reflecting in the registry, i reset the internet explorer then manually removed the proxy from the registry, and auto deployment started running and all the updates were downloaded. There were no errors in ruleengine.log and wsyncmgr.log.


    Regards, Joel

    • Marked as answer by joyjoel_sccm Monday, November 11, 2013 3:52 AM
    Monday, November 11, 2013 3:51 AM

All replies

  • the only difference between the two proxy server is the old one we have to mention a IP with the new one we dont have to.

    Could you please explain this.

    I've found that it's often easier to configure the proxy to allow traffic unfiltered and unscanned from the ConfigMgr servers to the MS updates sites. It often avoids this kind of strange behaviour.

     



    Gerry Hampson | Blog: www.gerryhampsoncm.blogspot.ie | LinkedIn: Gerry Hampson | Twitter: @gerryhampson

    Tuesday, November 05, 2013 7:16 AM
  • Hi,

    It definatly sounds like a problem with the Proxy server. are there any useful information in Rulengine.log?

    Regards,
    Jörgen


    -- My System Center blog ccmexec.com -- Twitter @ccmexec

    Tuesday, November 05, 2013 7:21 AM
    Moderator
  • Dear Gerry,

    thank you for the response, in the old proxy i had to mention a Proxy Server IP in internet explorer, But now i only have to check in 'Automatically detect Settings' I confirmed with my network team they have set a rule to allow all the trafic from my SCCM Server and i am able to browse on the server


    Regards, Joel

    Tuesday, November 05, 2013 9:45 AM
  • Dear Jorgen,

    Thank you for the response i am getting the following error in ruleengine.log,

    An also the updates folders are getting generated with no content; and i am able to see all the latest software updates in configuration manager, but they are not downloading.



    Regards, Joel

    Tuesday, November 05, 2013 9:49 AM
  • 12029 = A connection with the server could not be established.

    The proxy is certainly affecting the traffic. As I said it's easier to "whitelist" this traffic on the proxy - ie not scan or filter. It's not enough just to allow it.



    Gerry Hampson | Blog: www.gerryhampsoncm.blogspot.ie | LinkedIn: Gerry Hampson | Twitter: @gerryhampson

    Tuesday, November 05, 2013 9:54 AM
  • There is a separate policy on the proxy not to block any traffic from the server, 

    I have changed the proxy settings as below (Site System Properties), is there any other changes i have to make. 

    


    Regards, Joel

    Tuesday, November 05, 2013 10:28 AM
  • Proxy authentication and filtering are two different things. If you have also removed the need for authentication this should be OK. If not you need to enter credentials here.


    Gerry Hampson | Blog: www.gerryhampsoncm.blogspot.ie | LinkedIn: Gerry Hampson | Twitter: @gerryhampson

    Tuesday, November 05, 2013 10:37 AM
  • does it make any difference if you try to reset any proxy settings configured earlier using the following command:

    netsh winhttp reset proxy

    and you can also set the proxy via netsh winhttp set proxy

    Tuesday, November 05, 2013 11:03 AM
  • I think i have figured out the exact issue, i have changed the proxy settings in Configuration Manager Console,

    But when i checked the registry it is still showing the old settings, i tried editing the settings but it still changes to the old one, from where the registry is taking this old values

    Computer\HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\SMS\AIUS

    Computer\HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\SMS\WSUS


    Regards, Joel

    Friday, November 08, 2013 3:25 AM
  • Finally i resolved the issue,

    even though i removed the proxy settings from my internet explorer, it was still reflecting in the registry, i reset the internet explorer then manually removed the proxy from the registry, and auto deployment started running and all the updates were downloaded. There were no errors in ruleengine.log and wsyncmgr.log.


    Regards, Joel

    • Marked as answer by joyjoel_sccm Monday, November 11, 2013 3:52 AM
    Monday, November 11, 2013 3:51 AM