none
Change Bindings on SBS Web Applications

    Question

  • I need to install an application (ADFS & CRM) that is using port 443 which will conflict with SBS Web Applications. This will conflict with "SBS Web Applications" which has the binding "Sites on *:80(http),*:443(https)" Therefore, I went ahead and change the port from 443 to 445. After doing so this site stopped. When I try to start it I get a dialog saying "The process cannot access the file because it is being used by another process". How can I keep "SBS Web Applications" running but just on a different port? I assume I will also have to change "Sites on *:80" to something like "Sites on *:8080".
    Friday, March 02, 2012 9:36 PM

Answers

  • In principal it should.First take a backup of iis:

    c:\windows\system32\inetsrv>appcmd add backup "Name of backup"

    then you can either remove sbs web app or a better option would be to remove 443/445 binding all together so it does not conflict with anything.

    Saturday, March 03, 2012 7:02 PM

All replies

  • if u remove 443 from sbs web apps then ur exchange and rww won't work.
    Saturday, March 03, 2012 3:30 PM
  • Jkazama, thanks. We are using Office365 hosted by MS for email and sharepoint. We don't care about rww. As for exchange, I assume this is if we would host exchange. So all the email routing for CRM will still work, correct?
    Saturday, March 03, 2012 6:01 PM
  • In principal it should.First take a backup of iis:

    c:\windows\system32\inetsrv>appcmd add backup "Name of backup"

    then you can either remove sbs web app or a better option would be to remove 443/445 binding all together so it does not conflict with anything.

    Saturday, March 03, 2012 7:02 PM
  • Why not setup the new application on port 80 and 443 using a host header? Therefore you shouldn't have to change anything.


    Thanks Robert Crane [MVP-Office365] www.ciaops.com

    Sunday, March 04, 2012 4:15 AM
  • I don't think you can have host header if u choose "HTTPS" instead of "HTTP"
    • Edited by Jkazama Sunday, March 04, 2012 8:51 AM
    Sunday, March 04, 2012 8:51 AM
  • Why not? https://sites:987 is a host header on port 443 isn't it for the existing companyweb?


    Thanks Robert Crane [MVP-Office365] www.ciaops.com

    Sunday, March 04, 2012 8:54 AM
  • Please Check again...https is attached to the cert on port 987 and there is a separate binding for port 80 with host header companyweb.

    And this was in 2008,in 2011 there is a different website called companyweb[for 987 its called sbs sharepoint[

    the option for host header is grayed out as you select a certificate


    • Edited by Jkazama Monday, March 05, 2012 9:52 AM
    Sunday, March 04, 2012 12:04 PM
  • For those not using O365 and are using exchange and owa, do you have any suggestions?
    • Edited by cypcloud Friday, April 27, 2012 9:03 AM spelling
    Friday, April 27, 2012 9:03 AM