none
FIM 2010 delete metaverse object

    Question

  • We are using the FIM coming with SharePoint 2010 (User Profile Sync Service) to synchronous user profile from an external data source (Oracle DB) to AD.

    I developed the MV rules extension for the MV object provisioning and it's working fine for adding and updating user profile to AD, but for the deprovisioning (delete) the IMVSynchronization.ShouldDeleteFromMV in my MV rules extension never get called. The connector in the external object MA get deleted when I run a import operation, but the MV object is not deleted after I run full Sync operation.

    So how do I trigger the deprovisioning  (delete) process to delete the MV object? Should I develop MA rules extension?

    Any help is highly appreciated.

    Bin

    Wednesday, February 06, 2013 10:18 AM

Answers

  • The deletion is working now after I configure the Object Deletion Rule under the Metaverse Designer and select "stage a delete on the object for the next export run" for the "Configure Deprovisioning" for both MA.

    Thanks Soren and Markus.

    Bin

    • Marked as answer by wb131 Thursday, February 07, 2013 2:20 AM
    Thursday, February 07, 2013 2:20 AM

All replies

  • MV object disappear when all connectors disconnect - so make sure that your setup disconnects all connectors

    Regards, Soren Granfeldt
    blog is at http://blog.goverco.com | twitter at https://twitter.com/#!/MrGranfeldt

    Wednesday, February 06, 2013 10:26 AM
  • The lifecycle of a metaverse object is governed by the object deletion rule.
    You can configure this rule to delete the metaverse object when disconnected from the SharePoint connector.
    For more details, see  Understanding Deprovisioning in FIM.

    Cheers,
    Markus


    Markus Vilcinskas, Knowledge Engineer, Microsoft Corporation

    Wednesday, February 06, 2013 11:41 AM
    Owner
  • hi Søren,

    How to setup disconnects all connectors?

    I have try all the Deprovisioning Options in the Configure Deprovisioning section but still doesn't work.

    Thanks,

    Bin

    Wednesday, February 06, 2013 8:17 PM
  • How to open the "Configure Object Deletion Rule" section in FIM? I didn't find this section.

    Thanks,

    Bin

    Wednesday, February 06, 2013 8:26 PM
  • The deletion is working now after I configure the Object Deletion Rule under the Metaverse Designer and select "stage a delete on the object for the next export run" for the "Configure Deprovisioning" for both MA.

    Thanks Soren and Markus.

    Bin

    • Marked as answer by wb131 Thursday, February 07, 2013 2:20 AM
    Thursday, February 07, 2013 2:20 AM