none
Word2007-There was a problem sending the command to the program!

Answers

  • I may have a fix that worked for my Laptop (Windows 7 Home Premium).  In the Word Properties, under the compatibility tab there was a box checked "Run This Program as an Administrator".  Unchecked the box and voila, no problems.  Give that a whirl as it appears the REGEDIT suggestions don't work. 

    Good luck, that's all it took for me.
    • Proposed as answer by daydreamer278 Tuesday, February 16, 2010 2:26 PM
    • Marked as answer by David Wolters Saturday, July 17, 2010 3:08 AM
    Sunday, January 03, 2010 1:17 AM
  • This is a very strange problem.  I was moving towards an issue of not being on the corporate network (in the company I work in).  However in this thread there was one post that talked about changing the default printer.  This worked like a charm!  Let me describe some so all of you can have another option to try.

    Setup:
    work laptop - windows 7 enterprise (joined to work domain / default printer to a company xerox etc..) - also joined to homegroup @ home
    home computer - windows 7 ultimate (with a homegroup setup) - has HP CX4200 printer attached via usb

    Issue:
    when I am at work - everything works fine - word opens etc..
    when I go home - I get the '..problem sending a command...' error and can not get word to open up

    Percieved solution:
    when I am on my home network, though some troubleshooting I assumed the only way to get word to work was to vpn into my corporate network - as word would launch fine (thinking in my mind word is tied to our corporate sharepoint or some dependency of some type in the corporate network)

    The real problem:
    when I am on my work computer only attached to my home network (no vpn) my default printer is set to the CX4200 via the homegroup - for whatever reason I get the problem with word in this setup (maybe having an issue talking to the printer - driver etc.. haven't dug into it that far yet)
    When I vpn into my corporate network I am isolated from my home network and my default printer moves to the corporate printer (which doesn't seem to have a problem)

    The solution (simple one):
    while on the home network on my work laptop - I changed my default printer over to the Microsoft XPS doc writer.  Problem solved.

    Now since I can't leave this one alone :)  off to figure out if this is a driver issue.

    Hope this helps..   -Jason

    • Marked as answer by David Wolters Saturday, July 17, 2010 3:10 AM
    Saturday, March 06, 2010 4:07 PM
  • I finally found the answer after many agonizing hours of desperate attempts.

    Go to http://support.microsoft.com/kb/921541 and follow the instructions under "Delete the Word Data registry key".  After executing the procedure, Word finally works.  No need to go to Open Office yet.

    Larry
    • Marked as answer by David Wolters Friday, July 30, 2010 5:05 PM
    Saturday, November 21, 2009 5:51 AM

All replies

  • I have the same problem. Any ideas how to fix that?
    • Proposed as answer by BridgeN Wednesday, June 05, 2013 4:49 AM
    Sunday, November 01, 2009 7:36 PM
  • Same problem here.  Using Windows 7, Office Ultimate 2007, and can't open Word.  Tried command line prompt "sfc/scannow" and after scanning, returned message "Windows Resource Protection did not find any integrity violations."

    Went directly to Winword.exe, and still error message "...problem sending the command to the program".  I reinstalled the complete office again, and still the problem persists.  

    Excel opens fine.

    Is this a problem with Windows 7 and Office 2007 compatibility?  

    Please help.  How can this be fixed?  Without Word, I'm speechless (wordless?).

    Larry
    • Proposed as answer by larry_sfsu Friday, November 20, 2009 5:09 AM
    • Unproposed as answer by David Wolters Saturday, July 17, 2010 3:01 AM
    Friday, November 20, 2009 3:37 AM
  • Performed Office Diagnostics, but it could not find any problems that could be solved.

    Figured out a temporary work around.  Open Winword.exe in Safe Mode by holding down the <ctl> key while clicking.  In the alternative, you can go to All Programs and look for Microsoft Office, then Microsoft Word, hold down the <ctl> key while starting Word.  Word starts, but it still doesn't look normal at this point.  But, if you go the the Word menu and "Open" a file of your choice, it will open.

    I'll be doing this until there's an answer how to fix this xxxx problem.  Hope this helps someone else.

    Larry
    Friday, November 20, 2009 5:15 AM
  • I finally found the answer after many agonizing hours of desperate attempts.

    Go to http://support.microsoft.com/kb/921541 and follow the instructions under "Delete the Word Data registry key".  After executing the procedure, Word finally works.  No need to go to Open Office yet.

    Larry
    • Marked as answer by David Wolters Friday, July 30, 2010 5:05 PM
    Saturday, November 21, 2009 5:51 AM
  • I have the same problem. If I just open word directly, its fine. If I click on a word file, first I get the error message, then word opens, without the file opening. I attempted the fix reported above, but it did NOT resolve the problem. I suspect some issue with word 2007 and windows 7. Strange that word 2003 worked fine. I'm also hopeful this will be fixed, since MS has 2010 coming out soon, and they may not be paying much attention to 2007.
    Saturday, December 05, 2009 1:18 PM
  • I have the same issue and deleting the data registry key also did not solve the issue. However, for me it started happening after I installed OpenOffice as well, so is there a conflict? Probably not, as double-clicking a file in Explorer open Word 2007 but not the document. I'm thinking it's a DDE error.
    • Proposed as answer by skyvale0120 Friday, March 08, 2013 7:10 AM
    Thursday, December 10, 2009 1:04 AM
  • Just posted the following message to the related excel-thread:

    "I had the same "there was a problem sending document"-problem when opening word-documents (Windows 7, 64bit, office 2007). Strangely, the problem disappeared when I changed my default printer! Earlier I had an USB-printer connectected to Buffalo Linkstation Pro Duo as the default printer and the problem seems to occur when the printer is not available. When I change the default printer to e.g. "Microsoft XPS Document Writer", file opening by double-clicking works just fine!"
     
    This isn't really a solution to the problem, but might help to find the real fix.
    Friday, December 11, 2009 3:23 PM
  • I have this problem with both Excel and Word. There seems to be a lot of it going round, but the exact program combination seems to be different for everybody. It's extremely frustrating for me, as sometimes the error message locks up my computer and I can't regain control (even through task manager) for upward of a minute. Clearly it's an issue, and it seems to have been for a while. Hopefully there will be a fix forthcoming
    Monday, December 14, 2009 2:22 AM
  • I may have a fix that worked for my Laptop (Windows 7 Home Premium).  In the Word Properties, under the compatibility tab there was a box checked "Run This Program as an Administrator".  Unchecked the box and voila, no problems.  Give that a whirl as it appears the REGEDIT suggestions don't work. 

    Good luck, that's all it took for me.
    • Proposed as answer by daydreamer278 Tuesday, February 16, 2010 2:26 PM
    • Marked as answer by David Wolters Saturday, July 17, 2010 3:08 AM
    Sunday, January 03, 2010 1:17 AM
  • i have the same problem with office 2007.  but I realized that I have word 2003 viewer installed on the pc.  after I uninstalled that.  it works.

    • Proposed as answer by itscoldoutside Monday, December 27, 2010 12:11 AM
    Friday, January 08, 2010 3:25 AM
  • PROBLEM SENDING COMMAND TO PROGRAM

    Installed Windows 7 upgrade and Office Home and Student 2007.
    Suddenly I get an error message when I go to documents and try to open a Word document.
    The document does not open but Word does and a dark blank screen.
    I went to Word Properties
    Clicked the Compatibility Tab
    Then under Compatibility Mode unchecked the box "Run This Program In Compatibility Mode"
    Check Apply
    Then OK

    Now I do not get the message and my documents open in Word as it normally does.
    Saturday, January 09, 2010 12:07 AM
  • I have the same problem with Windows 7 and Word 2007. I don't even have the option of Word Properties or the compatiblity tab....any more suggestions? Word opens but with just a blank blue screen.
    • Proposed as answer by Varun 23 Thursday, January 14, 2010 6:43 PM
    • Unproposed as answer by David Wolters Saturday, July 17, 2010 3:03 AM
    Sunday, January 10, 2010 12:34 AM
  • Hi,

    You need to click start->All Programs-> Microsoft Office-> right click on Microsoft Office Word and click on properties there you would have the compatibility tab in Win 7.. You need to uncheck the option for run as admin and it would resolve your issue
    • Proposed as answer by pjwsna Saturday, February 13, 2010 3:28 PM
    Thursday, January 14, 2010 6:46 PM
  • Following the instructions above, these are the tabs that I have after I click on properties: General, Sharing, Security, Previous Versions, Customize. Where do I find the option to uncheck run as admin? Thank you for your help:) Right now, I am downloading everything to my desktop and then unblocking the file and it still takes forever to open:(
    Thursday, January 14, 2010 11:25 PM
  • What is your operating system? Would you also let me know about the exact error message
    Friday, January 15, 2010 2:29 PM
  • Hi..The OS is Windows 7 Home Premium 32 bit....don't know if it makes a difference, but I am working on a laptop (although my desktop gives me the same error message - also with Windows 7 but 64 bit). Laptop is a Toshiba Satellite L505D-S5983. I am using Word 2007 and when I try to open word docs, specifically templates for work, the error message: There was a problem sending the command to the program is what flashes on the screen, then Word opens up, I go to the office button, hit open, and I am unable to locate the document. When I download to the desktop, I can open the Zip file, but an error message opens when I extract the files (too fast to read), then I go to to office button, click on the zip file, click on the specific document, move it to the desktop, right click, go to properties, then unblock the document, go back to Word, find the doc, then FINALLY it opens! Very frustrating...especially since I need to do this to work and I get paid on production and this whole process takes time. The help desk through my work was no help at all unfortunately....so far, the suggestions on here have seemed more helpful. Do you think I need to do something with the security/permissions having to do with Word? I appreciate your help:)

    Friday, January 15, 2010 2:56 PM
  • Hi,
    i belive there might be some registry permission issue on the computer.
    Lets try to use the https://support.microsoft.com/kb/313222 fixit and check
    Friday, January 15, 2010 3:50 PM
  • Hi,
    Please check whether you have the admin privilidges.
    MAy be you can try creating a new user a/c.

     

    • Proposed as answer by Rebel_Priest Monday, January 18, 2010 7:09 PM
    Friday, January 15, 2010 8:50 PM
  • To all,
    Please check file associations.  Ocassionally, and for reasons unknown even to MS, these change.  You may find (if you are able to opena  doc from the Open function) that is currently associated with Microsoft Word Viewer.  Hence it knows what program created the file and the RPC is fulfilled, but it really wants to call Viewer and the issue arises.
    Friday, January 22, 2010 3:50 PM
  • To resolve this issue (in my case), I unchecked the run in Windows XP SP2 compatibility mode. Not sure how/when it got checked but unchecking that box resolved the problem.

    Win7 Pro / Office 2007

    • Proposed as answer by shaggy73 Sunday, December 12, 2010 5:58 PM
    Saturday, January 23, 2010 11:30 PM

  • We have had the 'problem sending command ... message' with Word 2003 on Windows 7 Home Premium (64bit).

    The problem has gone away (so far!) simply by unchecking 'run as admin' having already unchecked 'run in compatibility mode'.

    this is a great relief because the cost of upgrading to 2007 professional is significant (assuming that would fix the problem) and because we have wasted a lot of time trying to make work something that worked fine under XP and even on Windows 7 for our first few days. 
    • Proposed as answer by daydreamer278 Tuesday, February 16, 2010 2:39 PM
    Saturday, February 13, 2010 3:39 PM
  • JYD19 -- your solution worked for me.  Thanls!
    Sunday, February 14, 2010 5:16 PM
  • I may have a fix that worked for my Laptop (Windows 7 Home Premium).  In the Word Properties, under the compatibility tab there was a box checked "Run This Program as an Administrator".  Unchecked the box and voila, no problems.  Give that a whirl as it appears the REGEDIT suggestions don't work. 

    Good luck, that's all it took for me.
    this is the ultimate solution for me..
    thank you soooooooooooooooooooooooooo very much!!
    May Allah bless you!!!
    you're the king!!
    • Proposed as answer by daydreamer278 Tuesday, February 16, 2010 2:36 PM
    • Unproposed as answer by David Wolters Saturday, July 17, 2010 3:09 AM
    Tuesday, February 16, 2010 2:35 PM
  • I may have a fix that worked for my Laptop (Windows 7 Home Premium).  In the Word Properties, under the compatibility tab there was a box checked "Run This Program as an Administrator".  Unchecked the box and voila, no problems.  Give that a whirl as it appears the REGEDIT suggestions don't work. 

    Good luck, that's all it took for me.
    this is the ultimate solution for me..
    thank you soooooooooooooooooooooooooo very much!!
    May Allah bless you!!!
    you're the king!!
    P.s my CPU info:
    Processor: Core II duo
    Windows 7
    Office Version: MS Office Enterprise 2007
    • Proposed as answer by daydreamer278 Tuesday, February 16, 2010 2:38 PM
    • Unproposed as answer by David Wolters Saturday, July 17, 2010 3:09 AM
    Tuesday, February 16, 2010 2:38 PM
  • I had this issue for quite a while now on my Laptop running Win 7 with MS office Ultimate 2007.
    But the issue was only with word rest of the office programs worked fine.
    I started with diagnostics.
    Then followed this
    http://support.microsoft.com/kb/921541

    Before starting "Rename the Normal.dot or Normal.dotm global template file"
     
    I clicked start and on the properties of Word 2007 under the compatibility tab I unchecked everything.
    Restarted the computer.Still didn't work.
    So I started to follow "

    Rename the Normal.dot or Normal.dotm global template file"

    But the command : Word 2007:
    ren %userprofile%\Application Data\Microsoft\Templates\OldNormal.dotm Normal.dotm
    won't work
    SO in my computer i browsed to the Local disk C\ users\ My user name(watever is your user name)\
    App Data\Roaming\Microsoft\Templates\
    Here I renamed Normal.dotm (right click rename) to
    OldNormal.dotm

    Now word works like a charm
    I took the  time to post this message here. Please do so for helping others as well
    Thanks and good luck
    • Proposed as answer by jeffm209 Thursday, February 25, 2010 6:10 AM
    Wednesday, February 17, 2010 5:10 AM
  • Bless you, Larry!  I knew it was a registry key somewhere!  THANK YOU!

    ~Tina
    Friday, March 05, 2010 3:47 AM
  • This is a very strange problem.  I was moving towards an issue of not being on the corporate network (in the company I work in).  However in this thread there was one post that talked about changing the default printer.  This worked like a charm!  Let me describe some so all of you can have another option to try.

    Setup:
    work laptop - windows 7 enterprise (joined to work domain / default printer to a company xerox etc..) - also joined to homegroup @ home
    home computer - windows 7 ultimate (with a homegroup setup) - has HP CX4200 printer attached via usb

    Issue:
    when I am at work - everything works fine - word opens etc..
    when I go home - I get the '..problem sending a command...' error and can not get word to open up

    Percieved solution:
    when I am on my home network, though some troubleshooting I assumed the only way to get word to work was to vpn into my corporate network - as word would launch fine (thinking in my mind word is tied to our corporate sharepoint or some dependency of some type in the corporate network)

    The real problem:
    when I am on my work computer only attached to my home network (no vpn) my default printer is set to the CX4200 via the homegroup - for whatever reason I get the problem with word in this setup (maybe having an issue talking to the printer - driver etc.. haven't dug into it that far yet)
    When I vpn into my corporate network I am isolated from my home network and my default printer moves to the corporate printer (which doesn't seem to have a problem)

    The solution (simple one):
    while on the home network on my work laptop - I changed my default printer over to the Microsoft XPS doc writer.  Problem solved.

    Now since I can't leave this one alone :)  off to figure out if this is a driver issue.

    Hope this helps..   -Jason

    • Marked as answer by David Wolters Saturday, July 17, 2010 3:10 AM
    Saturday, March 06, 2010 4:07 PM
  • This is a very strange problem.  I was moving towards an issue of not being on the corporate network (in the company I work in).  However in this thread there was one post that talked about changing the default printer.  This worked like a charm!  Let me describe some so all of you can have another option to try.

    Setup:
    work laptop - windows 7 enterprise (joined to work domain / default printer to a company xerox etc..) - also joined to homegroup @ home
    home computer - windows 7 ultimate (with a homegroup setup) - has HP CX4200 printer attached via usb

    Issue:
    when I am at work - everything works fine - word opens etc..
    when I go home - I get the '..problem sending a command...' error and can not get word to open up

    Percieved solution:
    when I am on my home network, though some troubleshooting I assumed the only way to get word to work was to vpn into my corporate network - as word would launch fine (thinking in my mind word is tied to our corporate sharepoint or some dependency of some type in the corporate network)

    The real problem:
    when I am on my work computer only attached to my home network (no vpn) my default printer is set to the CX4200 via the homegroup - for whatever reason I get the problem with word in this setup (maybe having an issue talking to the printer - driver etc.. haven't dug into it that far yet)
    When I vpn into my corporate network I am isolated from my home network and my default printer moves to the corporate printer (which doesn't seem to have a problem)

    The solution (simple one):
    while on the home network on my work laptop - I changed my default printer over to the Microsoft XPS doc writer.  Problem solved.

    Now since I can't leave this one alone :)  off to figure out if this is a driver issue.

    Hope this helps..   -Jason


    It's really helpful. Thanks.

    I have the same problem when I try to double word files. I have already tried several methods mentioned in above, but they did not work for me. Your message give me an idea that this problem may be caused by default printers that can not be connected. That is my case. When I am in office, I need to connect to internal network if I would like to print something.  If I don't connect to the internal network, my default printer in fact is not connected. So I change the default printer, the problem is solved.
    Thursday, March 11, 2010 2:02 PM
  • This worked for me too!  The only thing that I didn't realize - not being a really technical type of person - is that under the compatibility tab, you have to go to the box at the bottom that says Change Settings For All Users, then you uncheck the Run This Program As An Administrator box.  After months of it not working....finally, it works just fine!!!!

    Thank you!

    Monday, March 22, 2010 2:12 PM
  • A simple solution, after all.

    I went through these posts attentively, experimented with the proposed solutions, but in the end found the most obvious problem for starting Word - the template. Deleting the corrupted Normal.dotm resolved the problem immediately.

    The file can be found in:  %userprofile%\Application Data\Microsoft\Templates\

    Thursday, April 22, 2010 4:45 AM
  • I have windows 7 with word 2007 and I ran into a DDE problem where I could not open exsisting documents without Word 2007 already being open.  I would double click the document and get "There was a problem sending the command to the program".  Essentially, as far as I can reckon, it was hiccuping at the point where DDE openned the new instance of Word before sending the open commend.  Anyhow, this finally SEEMS to have fixed it.

    My understanding is that I am telling word to open a new instance of word with each double click... the annoyance of the error message is worse than my caring about multiple words being open.

    rename:

    HKEY_CLASSES_ROOT \ Word.Document.12 \ shell \ Open \ ddeexec
    to
    HKEY_CLASSES_ROOT \ Word.Document.12 \ shell \ Open \ ddeexec.bk

    HKEY_CLASSES_ROOT \ Word.Document.12 \ shell \ Open \ command \ command
    to
    HKEY_CLASSES_ROOT \ Word.Document.12 \ shell \ Open \ command \ command.bk

    copied:
    HKEY_CLASSES_ROOT \ Word.Document.12 \ shell \ Open \ command \ (Default)
    to
    HKEY_CLASSES_ROOT \ Word.Document.12 \ shell \ Open \ command \ Default.bk

    editted:
    HKEY_CLASSES_ROOT \ Word.Document.12 \ shell \ Open \ command \ (Default)
    from
    "C:\Program Files (x86)\Microsoft Office\Office12\WINWORD.EXE" /n  /dde
    to
    "C:\Program Files (x86)\Microsoft Office\Office12\WINWORD.EXE" /n  "%1"

    Thursday, April 22, 2010 6:45 PM
  • Thanks to Ironfeliks23 for posting the solution that finally worked for me.  It seems to be a little different problem for everyone, but his solution did the trick on my computer.  Just to highlight one important detail that I missed the first time I followed his solution:

    When you rename ddeexec, you are renaming the registry key (left side of the regedit window).  But when you rename command to command.bk, you are renaming the registry value (right side of the window) not the registry key (left side of the window).  That's what he has, but you have to be paying more attention than I was the first time since there is both a key and a value named "command"

    There are also two other locations I've found where you may need to make the same changes, as well.  

    If you find yourself still having the same trouble with files from previous versions of Word, then you probably need to go through the same procedure in the HKEY_CLASSES_ROOT\Word.Document.8\shell\Open folder of the registry (that is, make the same changes for version 8 of Word, instead of 12).  That fixed that problem for me.

    I also had to make the same changes in the HKEY_CLASSES_ROOT\Word.OpenDocumentText.12\shell\Open folder of the registry in order to open files directly from the Win7 jumplist.  I found this location by looking for a command like the others I had edited, but without any real knowledge of what I was doing, so I've posted it here because I couldn't find it elsewhere.  But I would advise caution following my example...

    Thanks to everyone who has posted. One less little irritation in my life!

     

     

    Friday, May 07, 2010 7:06 PM
  • None of these solutions worked for me. Word 2007 is still broken on one certain file, I don't know why. It could possibly be the formatting or whatever is in the file because when I copy and paste the information into a new document the file does not open and does the same thing. The only way I can open this file was to right click on the file and click the edit. It will open up the document without giving you the message "There was a problem sending the command to the program." Double clicking for some reason still does not work. Hope this helps anyone else who gets this error.
    Monday, May 31, 2010 1:46 AM
  • Had the same problem - Word would not start and open the document when I dobble-clicked on the document via explore (or inside an email). Strange thing was that if I dobble-clicked on a document while WORD was started, it worked OK.

    Followed the hints from the Microsoft support side http://support.microsoft.com/kb/921541 and for me it turned out to be the COM Add-ins that caused the problem (last suggestion on the support side of course). Removing the 'Outlook Contacts Add-in' solve it all, and WORD started correctly the first time - also from attached emails! :)

    Wednesday, June 09, 2010 9:27 PM
  • Hi I am using Windows 7 and Office 2007 and seemed to be having the same problem as you guys (i.e. the same error prompt).

     

    I tried a couple of the solutions to no avail. However, the cause of my problem was probably not the same for some. Anyway, all I did was change the default program that opened my file. That is, I did the following:

    1. Right click any of my word documents and click Properties
    2. Under the "General" tab click "Change"
    3. Select "Microsoft Office Word" (Apparently I had "Word Viewer" selected -which I might add worked without a hitch since I got this laptop-).
    4. Click "OK" on both windows.
    5. All my icons now have a different image, but they open when double clicked.

    Simple solution that worked for me.

    Sunday, June 13, 2010 10:25 PM
  • I recently had the problem return for me (again, only referring to my situation).  I believe I downloaded an update for Office which reset my registry changes.  Lo and behold, the entries had been reset to their default settings.  So I repeated my process for both Word.Document.12 (2007 documents) and Word.Document.8 (97 documents) and the problem again was fixed.  I am still not entirely sure why this only affects Word documents for me, my understanding is that DDE is an office-wide protocol.  I should have the same issues with Excel and Powerpoint, but I do not.
    Tuesday, June 22, 2010 1:19 PM
  • I have a fresh install of Windows 7 Ultimate and Office 2007 Pro. I have similar problems with Wrod and Excel, i.e. click on the "open" button and nothing happens. Click on the "save as button" and nothing happens. Files can only be opened by double clicking on Explorer.

    I have tried many suggested solutions by deleting the relevant registry and also by delecting the normal.dat etc. etc. No help. 

    Picking up some hints from this thread, I right clicked on the Word icon and changed the compatability mode to "Windows Vista (Swervice Pack2)" (my "Run the program as administrator" option is always unchecked). Well, Word works normal after that. And mysteriously so does my Excel.

    Microsoft surely produces funny machines.

     

    Monday, July 12, 2010 5:35 PM
  • This sounds like the problem I am having. I even closed out my personal desktop and started using my wifes desktop. Now it is doing the same thing on hers. Does anyone have an answer on what may have caused this and how do I fix this?

    Wednesday, July 14, 2010 10:18 PM
  • I am having the same problem with my word. I can create a document but I cannot open it up. what's going on?
    Wednesday, July 14, 2010 10:22 PM
  • IF YOU TRY THIS PLEASE BACKUP YOUR REGISTRY FIRST!!!

    Is anybody still having this problem? You don't realise how many docs you open until something like this happens.

    I'm running Windows 7 Ultimate with Office 2007 Professional and have been battling with it for weeks now.

    My problem was that Word opened fine from the shortcut but I couldn't open documents from Windows Explorer or email attachments. I kept getting the good old "The command could not be sent to the program".

    The problem only existed on my profile.

    I have finally solved it on my setup.

    Following on from the initial post which directed us to registry changes, they didn't work for me. Given the problem was only with my profile it had to be something in HKCU.

    So, I backed up:

    HKCU\Software\Microsoft\Office\12.0\Word
    HKCU\Software\Microsoft\Office\12.0\User Settings\Word_Core
    HKCU\Software\Microsoft\Office\12.0\User Settings\Word_Intl

    Then I deleted these keys.

    Problem solved.

    I'm guessing the problem was with the two keys in the User Settings for me as I tried the top one first and it didn't work.

    Looks like I'll need to set my preferences in Word again but I'm much happier to do that that mess around opening Word documents the long way.

    IF YOU TRY THIS PLEASE BACKUP YOUR REGISTRY FIRST!!!

    • Proposed as answer by Gonch_1979 Monday, July 19, 2010 8:26 AM
    Monday, July 19, 2010 8:26 AM
  • I had the same problem. I tried everything in this forum from editing the registry to changing settings like "run as administrator". Finally it turned out that I had a Macro from E-Sword installed in MS Word. I uninstalled it and it worked great !!! Make sure you do not have any incompatible macros installed

    Steve

    Monday, July 19, 2010 11:34 PM
  • I had the same problem. I tried everything in this forum from editing the registry to changing settings like "run as administrator". Finally it turned out that I had a Macro from E-Sword installed in MS Word. I uninstalled it and it worked great !!! Make sure you do not have any incompatible macros installed

    Steve
    • Proposed as answer by j0shu4 Tuesday, August 17, 2010 9:38 PM
    Monday, July 19, 2010 11:35 PM
  • Hi, I have same problem  here in win7, unchecking the "run as administrator" will help but I meet other functionality problem. My CAD dwg pasted on word page can't run/link to AutoCAD. It will not perform as what I expected from xp OS. Any help?
    Wednesday, July 21, 2010 2:14 AM
  • I had the same problem. I tried everything in this forum from editing the registry to changing settings like "run as administrator". Finally it turned out that I had a Macro from E-Sword installed in MS Word. I uninstalled it and it worked great !!! Make sure you do not have any incompatible macros installed

    Steve
    This worked for me, but it wasn't an e-Sword macro, but an e-Sword template. Unchecked the template in Word Options, then removed the template file. Worked like a charm!
    • Proposed as answer by kenix1 Sunday, October 31, 2010 4:33 AM
    Tuesday, August 17, 2010 9:39 PM
  • Thank you so much Jason!!!!!...I had added a network/wireless printer to my wifes laptop and whatever word checks when it starts for potential printing seemed to have been causing it to hang up if the printer was offline or if it couldn't communicate with it for whatever reason. I am a tech by trade and the fact that I could not resolve this was driving me insane. I had done everything from deleting templates,deleting temporary files, removing add-ons,diagnositcs,repairs,deleting reg entried and completely reisntalling the whole thing to no avail. I thought there was some program causing a conflict on her system but could not pinpoint anything. Tried going back and removing any updates and removing any recent programs but just completely forgot about the printer addition. It is annoying that it does this and there is probably a fix to stop word from checking the printer status but for now I have had more than enough headache for me to leave it alone for another day!!!...Something also strangeis that a lot of the people with the same complaint speak of having enterprise. I realize that this is typically used in large corporate environments where networked printers etc. would be used, but is it really just this version that is causing this issue???

    I should have googled that command error message sooner rather than just "word 2007 hangs on startup!"...oh well, even us techs live and learn everyday. Thanks again.

    Tuesday, August 24, 2010 1:43 AM
  • Thank you so much Jason!!!!!...I had added a network/wireless printer to my wifes laptop and whatever word checks when it starts for potential printing seemed to have been causing it to hang up if the printer was offline or if it couldn't communicate with it for whatever reason. I am a tech by trade and the fact that I could not resolve this was driving me insane. I had done everything from deleting templates,deleting temporary files, removing add-ons,diagnositcs,repairs,deleting reg entried and completely reisntalling the whole thing to no avail. I thought there was some program causing a conflict on her system but could not pinpoint anything. Tried going back and removing any updates and removing any recent programs but just completely forgot about the printer addition. It is annoying that it does this and there is probably a fix to stop word from checking the printer status but for now I have had more than enough headache for me to leave it alone for another day!!!...Something also strangeis that a lot of the people with the same complaint speak of having enterprise. I realize that this is typically used in large corporate environments where networked printers etc. would be used, but is it really just this version that is causing this issue???
    I should have googled that command error message sooner rather than just "word 2007 hangs on startup!"...oh well, even us techs live and learn everyday. Thanks again.
    Tuesday, August 24, 2010 1:44 AM
  • It worked! i thought I was going to have to take my computer into the tech geeks at my school, but this really worked! There was a tech support system that tried to charge 35 dollars for them to click that one button.
    Monday, August 30, 2010 4:40 PM
  • It is likely the Compatibility setting under the Microsoft Word icon as JYD19 stated in January.  The Compatibility settings for users other than you did not change when you changed your user settings.  That is why Word works fine as other users.  Each part of the Office 2007 suite is a separate program and has its own compatibility settings.  That explains why Word does not work and the other programs in Office do.

    Opening winword.exe directly bypasses the settings associated with the icon. 

    Reinstalling office did not fix this issue for me either.  I had to manually check and change the compatibility settings.

    So just clear all the check boxes under the compatibility settings of your Word icon or entry in the programs list .  You get to these by right-clicking on the icon or menu entry and selecting properties. 

    No doubt this is another inadvertent "feature enhancement" in Office 2007<grimace>.

    Monday, September 13, 2010 2:41 AM
  • This should fix it for everyone.

    Open Microsft Word. Click on the Office symbol in the upper left corner and on the bottom choose Word Options. This will bring up the Word Option window. Choose Advanced on left. Scroll to the very bottom and under Compatibilty Options. Change Layout this document as if created in: to Microsoft Word 2003. You can always save it as a 2007 word doc after ii is open if you wish.


    chris
    Tuesday, September 14, 2010 5:01 PM
  • Thank you SOOO MUCH larry_sfsu the above solution worked perfectly, the first time around; it was quick, easy and once again, successful!:D

     

    Thursday, September 23, 2010 2:17 PM
  • 1. Thanks. After all the effort I´ve put in solving this, I´ve tried to uninstall EndnoteX and then guess what - all the opening Word troubles have gone! Now the problem is what should I learn from this? I am a novice in this matter so have no idea ...

    2. The other thing is after that I´ve installed Adobe Acrobat and while opening new document I´ve noticed that Acrobat add-in does not appear in Word Toolbar. What should I do?

    Thanks for help!

    Monday, September 27, 2010 1:06 PM
  • This suggestion worked perfectly for me!!! (turn off "Run This Program as an Administrator")

    The "Uncheck - Ignore other applications that use DDE" did not work for any applications that were experiencing this error message!

    This was the fix for both MS Word 2003 SP3 and MS Excel 2003 SP3 on WIN 7 32-bit Dell computer!

    • Proposed as answer by clplcl Tuesday, April 12, 2011 10:23 AM
    Tuesday, October 05, 2010 1:45 AM
  • Cheers, that worked for me.
    Monday, October 11, 2010 8:01 PM
  • I have windows 7 with word 2007 and I ran into a DDE problem where I could not open exsisting documents without Word 2007 already being open.  I would double click the document and get "There was a problem sending the command to the program".  Essentially, as far as I can reckon, it was hiccuping at the point where DDE openned the new instance of Word before sending the open commend.  Anyhow, this finally SEEMS to have fixed it.

    My understanding is that I am telling word to open a new instance of word with each double click... the annoyance of the error message is worse than my caring about multiple words being open.

    rename:

    HKEY_CLASSES_ROOT \ Word.Document.12 \ shell \ Open \ ddeexec
    to
    HKEY_CLASSES_ROOT \ Word.Document.12 \ shell \ Open \ ddeexec.bk

    HKEY_CLASSES_ROOT \ Word.Document.12 \ shell \ Open \ command \ command
    to
    HKEY_CLASSES_ROOT \ Word.Document.12 \ shell \ Open \ command \ command.bk

    copied:
    HKEY_CLASSES_ROOT \ Word.Document.12 \ shell \ Open \ command \ (Default)
    to
    HKEY_CLASSES_ROOT \ Word.Document.12 \ shell \ Open \ command \ Default.bk

    editted:
    HKEY_CLASSES_ROOT \ Word.Document.12 \ shell \ Open \ command \ (Default)
    from
    "C:\Program Files (x86)\Microsoft Office\Office12\WINWORD.EXE" /n  /dde
    to
    "C:\Program Files (x86)\Microsoft Office\Office12\WINWORD.EXE" /n  "%1"


    THANK YOU IRONFELIKS23!!!  I was extremely reluctant to attempt this, but followed your instructions.  Upon closing the registry editor, and clicked on a WORD document, it opened... and NO ERROR MESSAGE!

    Thanks for taking the time to post a viable solution.

    Tuesday, October 19, 2010 10:43 PM
  • Ok, removing DDE from opening Word file solved the problem.

    I wasted whole day trying to fix this stupid problem. Office is a disaster with DDE starting from 2000 to 2010. Why don't MS get rid of DDE?

    Sunday, October 24, 2010 4:11 AM
  • FINALLY! After months (literally) of searching for the answer, trying every valid suggestion, reinstalling Office... I simply deleted the e-Sword macro and Word now opens documents with no hesitation.

    MANY THANKS!!!

    Sunday, October 31, 2010 4:37 AM
  • I was haveing the same problem as Hyper-Group Ma, and then I found Ms Word was not configured to run as an administrator.  Turns out that when I check the box to run as administrator, it solved my problem.  My OS is Windows 7 Home Premium
    Saturday, December 25, 2010 6:17 PM
  • This method works!!! It's fast and easy to do.
    Monday, December 27, 2010 12:12 AM
  • I figured out a way to bypass this for filed that have already been saved. Instead of pressing open, press edit. It has worked every time for me for files that have given me that error whenever I try to open them, but right clicking and pressing edit seems to bypass whatever is causing the bug.
    Sunday, January 02, 2011 6:51 PM
  • Thank You!

    I have been looking for the answer on and off for six months and your fix Works!

     

    • Proposed as answer by iamNeKi Friday, February 11, 2011 12:33 PM
    Saturday, January 29, 2011 3:47 PM
  • My OS is windows 2007 and I had the same problem.  Here is how it fixed it.

    Go "Start"

    "All Programs"

    "Microsoft Office"

    Right Click on Word - Go to properties - click compatibility

    Untick "Run  this program in compatibility for"

    Untick "Run this program as administrator"

    Bingo.. safe and close.

    Do the same for Exel and whatever other Microsft Office you have installed.

    Cheers  PME3006

     

    Thursday, February 03, 2011 3:17 AM
  • Hi All,

    while trying to open an word document from SharePoint 2007 site, its giving below error. Its occurring only for single user. Is this issue of client machine?

    Error details:

    Run-time error '1177':

    The document name or path is not valid.

    try one more of the fallowing:

    • check the path to make sure it was typed properly.
    • On the file menu, click open. search for the file using this dialog box.

    http://... path/ file.doc

     

    Machine details.

    XP machine, IE6, office 2003 with SP2

    WINWORD.exe process is always running on the machine, even after closing word documents.

     

    -------------------

    Thanks

    V235

    Thursday, February 03, 2011 12:09 PM
  • Tried this after working on the problem for 3 hours. This worked perfect and took 2 seconds. Thanks for the post JYD19 and daydreamer278!!
    Saturday, February 19, 2011 3:12 AM
  • I had this problem, but only in Word. I tried all the microsoft solutions from their site, but nothing was working. I created a new user profile and tried to open a document, and everything worked fine, i didn't get the error message, so i realised it was a problem in my user. I solved the problem by going to C:\Users\*insert your user name here*\AppData\Roaming\Microsoft\Word and deleted everything in that folder, including the STARTUP folder. The STARTUP folder contains your addins so they may be deleted as well, and in the Word folder there was also a file called ListGal.dat. But i deleted everything in the "Word" folder, and everything worked fine after that.
    • Proposed as answer by Gr8zy Monday, February 21, 2011 6:59 AM
    Monday, February 21, 2011 6:58 AM
  • Awesome.  It worked without a problem.  Thanks Larry.

     

    • Proposed as answer by Nubian Monday, April 11, 2011 8:19 PM
    • Unproposed as answer by Nubian Monday, April 11, 2011 8:19 PM
    • Proposed as answer by shaolo Thursday, April 21, 2011 5:45 PM
    • Unproposed as answer by shaolo Thursday, April 21, 2011 5:45 PM
    Wednesday, March 02, 2011 1:22 PM
  • if nothing before works, try to create a new user, log into that user and open a word document, if the error persist bad luck, but if the error it solved, copied all your files and some files of configuration from app dat, and welcome to you new user. It works for me.
    • Proposed as answer by Potis13 Wednesday, May 04, 2011 9:22 AM
    Thursday, April 21, 2011 5:48 PM
  • I had the same problem but the word crashed when i tried to make a pdf file from the Acrobat tab. Word, powerpoint etc that the plugin works had this problem but not excel. tried to change registry, change compatibility  etc with no luck. the solution i found was in the printer!. then tried to convert to a pdf the word uses an adobe printer that caused the problem and turned it automatically to default. so each time i was trying to open a word it was crashing. the onlly thing i did was to go control panel --> printers and make a default printer any other.

     

    problem fixed

    Wednesday, May 04, 2011 9:27 AM
  • I had tried all the other suggested resolutions, and sqlmania's answer completely resolved my issue: Word 2003 Viewer was evidently the culprit and uninstalling it instantly resolved the problem.
    Monday, May 30, 2011 7:31 AM
  • This worked for me.  Thank you.  As soon as I found the .exe and unchecked "Run as Admin" the problem went away.
    Wednesday, June 01, 2011 7:54 AM
  •  

    Windows RC
    It's fine for a long time,suddenly doesn't work,maybe the change of some other programs or system
    I can only start the word 2007 first,then I can open the file,but in other account such as guest my word is ok.
    If I right-click the word

    Other sutes of Office 2007 bisides word 2007 is ok

    My version is office 2007 enterprise.

    Reinstall the office doesn't take effect.

    Open winword.exe directly is fine.

    http://zaq5sa.bay.livefilestore.com/y1pzX0dVQyt4ZEHxhBnyejMVvmPvplVBErUTYRlMj5XJpIkSL2jzMrt9VAa3Cy11aFNukFOMpBP3ejVL2gy8D2dZUvxls2dJx47/Untitled%20-%20Copy.jpg

    Try right click on the word icon, go to properties, compatibility tab, then choose your operating system. That worked for me some how when it installed it installed for windows xp and I have windows 7
    Tuesday, June 21, 2011 3:16 PM
  • Brilliant!

     

    This fixit worked for me ... as the man says, go to http://support.microsoft.com/kb/921541 ... and use the automated fix, ie, let MS do it for you ... it really works guys!

     

    But why does this stuff happen ... who writes this stuff ... computers, huh?

    Sunday, December 04, 2011 10:51 PM
  • Thank you Sir, it was the printer. I wasted 2 hours of my time trying all the complicated solution Microsoft suggested for this problem. All I had to do was just to turn my printer on, or change the default printer. 
    Thursday, January 12, 2012 5:09 PM
  • This is what fixed it for me. I did the regedit 6 or so steps and that did not help. As soon as I saw this message I knew that was the fix I was looking for. I had just checked "Run This Program as an Administrator" a short time ago. When the problem first showed up I had forgotten the Administrator suggestion. Thanks David job well done.
    Tuesday, July 17, 2012 12:39 AM
  • thank you very much sir....that was a outstanding solution...I've been trying to fix this for more then 5 months and all other answers would not work for me, but the link you provided took care of it in a instant...thank you once again!
    Sunday, July 22, 2012 6:26 PM
  • In my case Tuneup utilities 2012 program deactivator was causing the problem. Uninstalling it solved the problem.
    Sunday, August 12, 2012 5:09 AM
  • This was exactly what was able to fix my Word documents from not opening.  Not sure why all of the sudden it started to act up, but I'm glad this was the solution!!!

    Thanks!! :)

    Wednesday, September 05, 2012 1:15 AM
  • JYD19 Thankyou, thankyou, thankyou !!!! I had tried everything posted on this subject (even your suggestion -  but it did not work first time so I only decided to give it another go after reading you post ! ).

    FINALLY - cleared up this problem ........ I may be 2+ years late in thanking you but thank you anyway

    Monday, October 01, 2012 6:26 PM
  •  thank you thank you thank you I'll be honest was not expecting this to work but it did so happy tried everything :)
    Sunday, October 07, 2012 6:07 AM
  • As a work around, open word and open the document from within word. It seems to only happen when you double-click the file.

    DJ

    Tuesday, November 06, 2012 8:03 PM
  • I fixed that. in my case problem with antivirus program. Change setting to less secure

    BR

    Garmr

    Tuesday, December 04, 2012 7:44 AM
  • this work for me thanks
    Thursday, January 31, 2013 6:22 AM
  • Miss, your answer solved my problem-I was crying my eyes out trying to figure out a solution to keep Word 2003 alive in...Windows 8! Impossible? No, thanks to your correct identification of DDE as the problem, I was inspired to download 'File Extension Manager 2', which works fine under Windows XP SP3 Compatibility mode. I can even change the icons back to their correct places with this app! Thank you!!! Attention all-If you thought Office Pro 2003 was dead, think again!

    2nd note: If this doesn't work for you (as it did not after I re-installed Windows 8 after it crashed [sob]) then do this: bring up the Registry Editor (Windows-key+R, then regedit) and go to:

    Computer\HKEY_CLASSES_ROOT\WordDocument.*\shell\open\command

    * means the version, not year, of Word that you're using,

     and edit BOTH values end parts to /n "%1". Then delete the ddexec key below the command key to have Windows stop displaying the error message I saw. Word opens the file without hesitation. Kudos to ingenuity for a job well answered!

    • Edited by skyvale0120 Thursday, March 14, 2013 3:02 AM 2nd problem detected
    • Proposed as answer by skyvale0120 Thursday, March 14, 2013 3:02 AM
    Friday, March 08, 2013 7:15 AM
  • Thanks for the info here guys, I wanted to keep my Office 2007 in my Win 8. 

    Showing same error.

    What did it for me is the above without having to delete the ddexec key.

    by delete ddexec key word would not start.

    Hope it helps other who stumble across this issue.

    Keep up the good work

    Monday, March 18, 2013 2:29 AM
  • Only have to change 

    Computer\HKEY_CLASSES_ROOT\WordDocument.12\shell\open\command/(Default)

    from the end of

    /dde 

    to

    %1

    dont have to change this value for 

    Computer\HKEY_CLASSES_ROOT\WordDocument.12\shell\open\command/command

    I did it for 

    WordDocument.8

    WordDocument.12

    Tuesday, March 19, 2013 2:29 AM
  • Here is what worked for me, and the easiest solution as nothing above worked!

    CTRL+ALT+DELETE --> Start Task Manager --> Processes Tab --> click on spoolsv.exe --> end process --> Wait 1-5 minutes --> Microsoft Word opened no problem for me!

    Monday, April 22, 2013 8:30 PM
  • After trying several tips, this finally worked for me! Had to change it to compatibility mode for Windows 7. Thanks!

    Friday, November 15, 2013 8:23 PM
  • This finally resolved the issue, thank you!!!!!!!!!!!!!!!!!!!!!!!!!!
    Sunday, December 15, 2013 4:38 AM
  • This worked for me  on my Alianware (Windows 8.1 Home Premium).  In the Word Properties, under the compatibility tab there was a box checked "Run This Program as an Administrator".  Unchecked the box and all worked.  no problems. I tried everything for a day and a 1/2 including the REGEDIT suggestions and it didn't work, I was at my last straw and on the phone to Microsoft when I found this thred. 

    Owe I wish I found this first.

    Good luck, It worked for me.

    Tuesday, January 14, 2014 4:50 PM
  • Just wanted to post what worked for me for anyone who may find it useful.

    My problem started after I installed Windows and Office updates.

    Tried deleting Normal.dotx but didnt work. Run This Program as an Administrator was already unselected.

    At the end, going into the Word document properties and selecting Change and then changing it from Word Viewer to MS Word fixed the issue - someone has already mentioned the detailed steps so follow those if you are not sure.

    Thanks.


    • Edited by Gr8Leaner Monday, January 27, 2014 7:17 PM
    Monday, January 27, 2014 7:15 PM
  • I fixed this problem by recreating the user profile. I tried alot of other fixes but the one outlined in this post was the only one that worked

    Regards Jake Gardner If you found this post helpful, please give it a &quot;Helpful&quot; vote. If it answered your question, remember to mark it as an &quot;Answer&quot;. This posting is provided &quot;AS IS&quot; with no warranties and confers no rights! Always test ANY suggestion in a test environment before implementing! Sorry if my grammar is incorrect as I am probably on writing to you from my phone.

    Monday, June 16, 2014 8:04 AM
  • Works for me - thank you so much

    Only thing is took me ages to find properties - eventually found right click on program short cut

    Wednesday, July 30, 2014 8:36 AM
  • Thank you! I have been having this problem forever, but this finally worked.
    Tuesday, September 02, 2014 10:49 PM
  • Use microsoft office diagnostics and it is solved.
    Sunday, September 28, 2014 10:14 AM