none
Ping FQDN responds "Reply from ::1: time<1ms" when IPv6 is disabled

    Question

  • I have a system where Pinging the FQDN gets a response "Reply from ::1: time<1ms" when IPv6 is disabled. I've checked DNS and there are no AAAA records and the HOSTS file is OK on the local machine.

    Why is the system responding with "Reply from ::1: time<1ms" rather than from the IPv4 address? What am I overlooking?
    Wednesday, September 07, 2011 12:28 PM

Answers

  • Is IPv6 disabled or simply unbound from the NIC? Big difference. Simply unchecking IPv6 in the NIC properties is not disabling IPv6, it just unbinds it from the NIC.

    ::1 is the IPv6 loopback address (similar to 127.0.0.1 in IPv4). Pinging the loopback address does not ever make it to the physical layer thus it doesn't matter if IPv6 is bound to a NIC or not because the ping never makes it to the NIC; the protocol stack handles it because it knows that ::1 is itself.

    Also, because you simply unbound IPv6, but IPv6 is the default protocol and there are no other valid IPv6 addresses available, it uses the only one it knows about, the loopback.


    Jason | http://myitforum.com/cs2/blogs/jsandys | Twitter @JasonSandys
    • Marked as answer by GUNDERSTONE Wednesday, September 07, 2011 4:02 PM
    Wednesday, September 07, 2011 1:44 PM

All replies

  • Is IPv6 disabled or simply unbound from the NIC? Big difference. Simply unchecking IPv6 in the NIC properties is not disabling IPv6, it just unbinds it from the NIC.

    ::1 is the IPv6 loopback address (similar to 127.0.0.1 in IPv4). Pinging the loopback address does not ever make it to the physical layer thus it doesn't matter if IPv6 is bound to a NIC or not because the ping never makes it to the NIC; the protocol stack handles it because it knows that ::1 is itself.

    Also, because you simply unbound IPv6, but IPv6 is the default protocol and there are no other valid IPv6 addresses available, it uses the only one it knows about, the loopback.


    Jason | http://myitforum.com/cs2/blogs/jsandys | Twitter @JasonSandys
    • Marked as answer by GUNDERSTONE Wednesday, September 07, 2011 4:02 PM
    Wednesday, September 07, 2011 1:44 PM
  • So I have only cleared the check box for IPv6 from the LAC properties; should I follow the steps as outlined at http://www.tomstricks.com/how-to-disable-and-turn-off-ipv6-feature-in-windows-vista/
    • Proposed as answer by Scott Wichall Monday, April 07, 2014 1:38 PM
    Wednesday, September 07, 2011 2:09 PM
  • It depends on what you are trying to do?

    If you simply want to ping via IPv4, then type the following:

    ping -4 fqdn

    In general, turning off IPv6 completely is not recommended by Microsoft although there are potential security concerns with leaving it on (in theory at least).

    If you want to turn IPv6 off completely, then here's a KB: http://support.microsoft.com/kb/929852.


    Jason | http://myitforum.com/cs2/blogs/jsandys | Twitter @JasonSandys
    Wednesday, September 07, 2011 3:52 PM
  • It depends on what you are trying to do?

    If you simply want to ping via IPv4, then type the following:

    ping -4 fqdn

    In general, turning off IPv6 completely is not recommended by http://support.microsoft.com/kb/929852.


    Jason | http://myitforum.com/cs2/blogs/jsandys | Twitter @JasonSandys

    It works, Thanks

    Efra Riv

    Friday, January 11, 2013 2:21 PM
  • Surfing through the net looking for this answer, this was a major help! THANK YOU!!!!
    Thursday, February 06, 2014 12:53 AM
  • Edit your host file to pint IP to FQDN. For example let's say your FDQN is XYZ.domain.com with IP 192.168.1.1,

    add an entry in HOST file like

    192.168.1.1 XYZ.domain.com

    Save the host file and try to ping! :)

    Monday, May 26, 2014 9:56 AM