locked
windows 8 disk usage high

    Question

  • I noticed that windows 8 DP task manager showing 100% disk usage for about 10 mintes after logging in which is making me afraid. What is causing it ?

    Pranav Cm

    Wednesday, May 30, 2012 6:30 PM

Answers

All replies

  • Open Task Manager, in the Processes tab you can find the disk usages of all processes. Then you will find the cause.

    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread. ”

    Thursday, May 31, 2012 8:11 AM
    Moderator
  • Also share your computer configuration, that makes troubleshooting a bit easy.

    Microsoft Most Valuable Professional, blog at : http://www.thecomputernext.com

    Friday, June 01, 2012 6:16 PM
  • I have 100% disk usage at 50-200KB/sec. That is all Windows 8 can muster for the drive. Things were fine in Windows 8 CP (upgraded from 7), only started in clean install of RP.

    This is SATA disk connected to a SB750's SATA port; a SSD connected to the same chipset controller performs fine. I tried installing AMD's AHCI SATA driver but this just leads to boot disk not found BSOD.

    CPU usage is at 1% or less and memory is at 28%. There's basically nothing running and this is on a clean boot. The disk idles fine, but even the most minuscule of disk activity brings it to 100%.


    • Edited by Michael Hsu Thursday, June 07, 2012 11:45 AM
    Thursday, June 07, 2012 11:45 AM
  • Folow this guide:

    Using Xperf to investigate slow I/O issues

    But use the new xperf / Windows Performance Tollkit version from the Windows 8 ADK:

    http://www.microsoft.com/en-us/download/details.aspx?id=29929


    "A programmer is just a tool which converts caffeine into code"

    Thursday, June 07, 2012 1:44 PM
    Answerer
  • I already reset the installation using the new Windows 8 reset feature and it seems to have taken care of the issue for now - I think the problem may stem from broken driver installations because installing AMD's chipset drivers (including SATA driver) causes the system to become unbootable.

    MsMpEng is still hogging up a lot of disk activity though - to the point where it noticeable effects disk performance - with multiple (5+) simultaneous file accesses. Given that it's a standard rotating hd, this brings the responsiveness down to its knees. It may be a consequence of indexer services. If that's true, these really need to run with lower priority and/or lower simultaneous IO.


    • Edited by Michael Hsu Thursday, June 07, 2012 6:07 PM
    Thursday, June 07, 2012 6:05 PM
  • I am seeing the same problem on an Intel  I7  machine

    I have upgraded to Windows 8  have 4 drives configured and drive D: occasionally goes a 100% for about 60 seconds. Drive D is my media and download drive.   Any video or audio or media application stutters during this time. I assume someone in Microsoft is looking at this problem  since there are many mentions of it with no specific solution in various forums.

    Wednesday, November 21, 2012 4:52 AM
  • I am seeing the same problem on an Intel  I7  machine

    I have upgraded to Windows 8  have 4 drives configured and drive D: occasionally goes a 100% for about 60 seconds.

    also make the xperf trace and provide the zipped ETL file.

    "A programmer is just a tool which converts caffeine into code"

    Wednesday, November 21, 2012 2:37 PM
    Answerer
  • My system was doing the same thing.

    I increased the size of disk space for my local drive under system protection. Then after a reboot my disk util. was about 10%. Also, run a manual defrag regardless of what percent your disk is defragmented.

    Hope this helps!

    Sunday, December 02, 2012 8:27 PM
  • run the xperf trace and provide the zipped ETL file.

    "A programmer is just a tool which converts caffeine into code"

    Monday, December 03, 2012 5:45 AM
    Answerer
  • Can I join in and run the xperf and provide the zipped ETL?

    Because I have the same issue on a 2 days old laptop, Windows 8 with appearently the System process continuously using the HD.

    Wednesday, February 27, 2013 8:59 AM
  • yes, also upload the xperf file. But please add +DISK_IO to the command line (after DRIVERS). I need this too see if the FileIO also causes disk IO.

    "A programmer is just a tool which converts caffeine into code"

    Wednesday, February 27, 2013 9:07 AM
    Answerer
  • The Windows Search service was affected in any of the updates this year causing a bug that - possibly - puts you in the loop and / or causes it to be sweeping the entire disk and rebuilding indexes all the time. The palliative solution suggested - who apparently worked at people - was to disable the service via "services.msc".
    Wednesday, May 15, 2013 1:12 PM