none
FUNCION "SUMAR.SI"

    Question

  • =SUMAR.SI(A1:A5;B1;E1:E5),  fórmula que sólo utiliza un criterio.En este caso el de la columna B.

     

    ¿ Se podría manejar dos criterios dentro de la misma fórmula citada ?.  Por ejemplo: el criterio de la columna B (que está en la fórmula) más el criterio de la columna C (que nó está en la fórmula porque no lo admite ó nó se hacerlo).

     

    Me voy arreglado habilitando otra columna más (que podría ser la D), donde fusiono (CONCATENAR) las columnas B+C y es dicha columna D la que tomo como único criterio.

     

    Esta solución no me parece muy ortodoxa ó técnica.

     

    ¿ Alguien me puede ayudar ?

     

    Gracias de antemano.

     

    Luis 

    Friday, June 29, 2007 6:13 PM

Answers

  • Opcion 1: Lenta - normal

    =SUMAPRODUCTO(--(A1:A100="U");--(B1:B100="S");C1:C100)

     

    Opcion 2: Rapida - matricial (se confirma mediante CTRL+SHIFT+ENTER)

    =SUMA(SI(A1:A100="U";SI(B1:B100="S";C1:C100)))

     

    Opcion 3: Rapida, pero aparatosa

    Usar la funcion BDSUMA (revisa la Ayuda)

     

    Opcion 4: Lenta - matricial (se confirma mediante CTRL+SHIFT+ENTER)

    =SUMA((A1:A100&B1:B100="US")*C1:C100)

    Monday, July 02, 2007 10:28 PM

All replies

  •  

    Dependiendo de lo que realmente quieres decir con tu explicacion...

     

    Supuesto 1:

     

    =SUMA(SUMAR.SI(A1:A5;B1:C1;E1:E5))

    =SUMAR.SI(A1:A5;B1;E1:E5)+SUMAR.SI(A1:A5;C1;E1:E5)

    =SUMA(SUMAR.SI(A1:A5;{"x"\"y"};E1:E5))

    =SUMAR.SI(A1:A5;"x";E1:E5)+SUMAR.SI(A1:A5;"y";E1:E5)

    =SUMAPRODUCTO(--(A1:A5=B1);--(A1:A5=C1);E1:E5)  (lenta)

    =SUMAPRODUCTO((A1:A5=B1)*(A1:A5=C1)*E1:E5) (lenta)

     

    Supuesto 2:

     

    =SUMAPRODUCTO(--(A1:A5="x");--(B1:B5="y");--(C1:C5="z");E1:E5)

    =SUMAPRODUCTO((A1:A5="x")*(B1:B5="y")*(C1:C5="z")*E1:E5)

    Sunday, July 01, 2007 2:49 PM
  •  

    Gracias KL por tus soluciones, que me las guardo para otra ocasión ya que en esta no me han servido porque no  me expliqué bien. Lo siento. Se vé que entiendes del tema. Lo vuelvo a exponer de otra manera.

     

    La cuestión es saber si esta dichosa función admite más de un criterio.

     

    Sea el siguiente ejemplo :

    La col. A contiene carácteres "U" ó "V" y sólo uno de los dos en cada celda.

    La col. B contiene carácteres "S" ó "N" y sólo uno de los dos en cada celda.

    La col. C contiene valores numéricos.

    Se trata de averiguar la suma (col.C) que correspondería a los carácteres "U" (col.A) cuando van seguidos de los carácteres "S" (col.B) en la misma fila.

    Creo que ahora sí me he explicado. Parecido problema ocurre con la función "CONTAR.SI()"

     

    Gracias nuevamente, si puedes ayudarme.

     

    Luis.

     

     

    Monday, July 02, 2007 3:34 PM
  • Opcion 1: Lenta - normal

    =SUMAPRODUCTO(--(A1:A100="U");--(B1:B100="S");C1:C100)

     

    Opcion 2: Rapida - matricial (se confirma mediante CTRL+SHIFT+ENTER)

    =SUMA(SI(A1:A100="U";SI(B1:B100="S";C1:C100)))

     

    Opcion 3: Rapida, pero aparatosa

    Usar la funcion BDSUMA (revisa la Ayuda)

     

    Opcion 4: Lenta - matricial (se confirma mediante CTRL+SHIFT+ENTER)

    =SUMA((A1:A100&B1:B100="US")*C1:C100)

    Monday, July 02, 2007 10:28 PM