none
Branchcache Hosted cache server 2008R2

    Question

  • In test lab we have setup Brach cache in Hosted cache mode, however status command shows Hosted Server as hosted cache client, I do not want to use netsh command mode (wanted to use GP method) to set it as Hosted Server

    BranchCache Service Status:
    ----------------------------------------------------------
    Service Mode   = Hosted Cache Client (Set By Group Policy)
    Current Status = Running

    Warning: The Windows Firewall is Currently Disabled.

    How do i set it as Hosted Cache server using GP Policy

    Methods mentioned in documnets are confusing and not specific and should not be mixed or not to be used, which policy needs to be used for Hosted-Cache-Server, Content-Server, Client-1, Client-2

    Wednesday, September 25, 2013 3:40 PM

Answers

  • Hi,

    From the description of the policy "set BranchCache Hosted Cache mode", it said "To use this policy setting, you must specify the address of the BranchCache server and this address must match the FQDN of the server specified in the certificate for the BranchCache Server. "

    So you still need to set a hosted cache server.

    Detailed steps could be found here:

    Configure a domain joined computer as a hosted cache server, and to register a service connection point in Active Directory for automatic hosted cache server discovery by client computers, type the following command at the Windows PowerShell prompt, and then press ENTER.

    Enable-BCHostedServer -RegisterSCP
    Verify the correct configuration of the hosted cache server, type the following command at the Windows PowerShell prompt, and then press ENTER.

    Get-BCStatus

    Quoted from this article:

    BranchCache in Microsoft Windowws Server 2012

    http://blogs.technet.com/b/brianlewis/archive/2012/11/14/branchcache-in-microsoft-windowws-server-2012.aspx


    TechNet Subscriber Support in forum |If you have any feedback on our support, please contact tnmff@microsoft.com.

    Monday, September 30, 2013 12:16 PM