none
Send email notification in scom 2007 r2

    Question

  • i get this error

    Failed to send notification using device/server 'mail.netxpert.ir' over 'Smtp' protocol to 'taheri.seyedmajid@gmail.com'. Exception 'Microsoft.EnterpriseManagement.HealthService.Modules.Notification.SmtpNotificationException': Failure sending mail. --> Unable to connect to the remote server --> An attempt was made to access a socket in a way forbidden by its access permissions 172.16.44.39:25. Smtp status code 'GeneralFailure' 

    what shall i do?

    Wednesday, August 21, 2013 10:09 AM

All replies

  • I don't think that this problem is related to SCOM, can SCOM send email notifications to the internal users? If yes, check if the SMTP server/relay allows SCOM server to send email to an external contacts.
    • Edited by Ayman Yassine Wednesday, August 21, 2013 12:00 PM Update
    Wednesday, August 21, 2013 11:59 AM
  • Hi. Is mail.netxpert.ir a smtp server managed by you? You will need to enable smtp relay access for the SCOM IP address on this smtp host to enable mails to be relayed

    Http://blog.theinfraguys.com | Please remember to click “Mark as Answer” on my answer if it helps. :)

    Wednesday, August 21, 2013 12:15 PM
  • i have used another applications such as PRTG or Event Log Analyzer and i am receiving notifications by the same mail server frequently.

    considering this point, you think cause of that problem is the smtp server side??

    Wednesday, August 21, 2013 12:59 PM
  • Hi,

    Are you running the applications of the same server. (I would doubt so?)

    The IPs where the applications are working should have been allowed for relay

    for the below in command prompt

    1) telnet mail.netxpert.ir 25

    2) Mail from:<emailaddress where you are sending the notificaitons from>

    3) Rcpt to:<Recipient Address>

    If relay is not allowed, you should get a message that you cannot relay.

    Thanks it out and let me knomw


    Http://blog.theinfraguys.com | Please remember to click “Mark as Answer” on my answer if it helps. :)

    Wednesday, August 21, 2013 1:26 PM
  • as I mentioned before, you need configure the SMTP to trust the SCOM IP address server.

    on a side note: if there's more than one SCOM server, then all the IPs of the SCOM servers must allowed through the SMTP.

    Wednesday, August 21, 2013 1:51 PM
  • agreed

    :)


    Http://blog.theinfraguys.com | Please remember to click “Mark as Answer” on my answer if it helps. :)

    Wednesday, August 21, 2013 1:55 PM
  • i have tested those steps and this result


    Thursday, August 22, 2013 3:09 AM
  • Does your smtp server require authentication?

    Can you check on the Email Notification Channel that you have created to see the authentication setting if its "anonymous" or "windows integrated"?


    Http://blog.theinfraguys.com | Please remember to click “Mark as Answer” on my answer if it helps. :)

    Thursday, August 22, 2013 3:39 AM
  • Step for troubleshoot

    1. Make sure that email server is allow your SCOM MS to replay the email : you previous check is OK

    2. Whether you email server is allow anonymous connection: If not, make sure that your email channel use windows-integrated authentication method and then configure profile, notification account, by adding windows user account , has right to send email.

    Roger

    Thursday, August 22, 2013 4:11 AM
  • how to check whether my email server is allow anonymous or windows integrated?

    current setting for channel is windows integrated.

    Regards

     
    Thursday, August 22, 2013 5:16 AM
  • when i create run as account in Distribution tab which radio box should be selected? (less secure or more secure) and below these two radio boxes in selected computers which computer should be selected?

    current setting i have selected more secure and in selected computer i have selected my scom 2007 r2  Server

    Regards

    Thursday, August 22, 2013 5:23 AM
  • Most SMTP Server should be anonymous. I would suggest you change the channel setting.

    Http://blog.theinfraguys.com | Please remember to click “Mark as Answer” on my answer if it helps. :)

    Thursday, August 22, 2013 6:03 AM
  • when change to anonymous does not get any error but no email in my inbox form scom
    Thursday, August 22, 2013 6:17 AM
  • For the email side, you should confirm it with your email server administrator whether it is support anonymous or not.

    Roger

    Thursday, August 22, 2013 7:24 AM
  • how do i check it?
    Thursday, August 22, 2013 7:31 AM
  • If you mail server is exchange 2010, pls. refer to
    http://technet.microsoft.com/en-us/library/bb232021(v=exchg.141).aspx
    How To Allow Relaying in Exchange 2010 and Exchange 2007
    http://exchangepedia.com/2007/01/exchange-server-2007-how-to-allow-relaying.html
    Configuring Exchange 2007 as an Authenticated or Anonymous SMTP Relay
    http://www.petri.co.il/authenticated-or-anonymous-smtp-relay-with-exchange-2007.htm
    Roger
    Thursday, August 22, 2013 8:22 AM
  • Suggest that you test the notification channel if its working as expected by using the tool

    http://blogs.technet.com/b/momteam/archive/2009/05/19/notifications-test-tool.aspx

    This will allow you to isolated the issue if its the subscription configuration or still SMTP Server related since you no longer get the error when you have change the channel to anonymous.


    Http://blog.theinfraguys.com | Please remember to click “Mark as Answer” on my answer if it helps. :)

    Thursday, August 22, 2013 1:59 PM
  • i do not get any error message in scom 2007 R2 but i do not receive any notification in my email.

    what shall i do?

    how to test it?

    Tuesday, August 27, 2013 4:44 AM
  • Suggest that you test the notification channel if its working as expected by using the tool

    http://blogs.technet.com/b/momteam/archive/2009/05/19/notifications-test-tool.aspx

    This will allow you to isolated the issue if its the subscription configuration or still SMTP Server related since you no longer get the error when you have change the channel to anonymous.


    Http://blog.theinfraguys.com | Please remember to click “Mark as Answer” on my answer if it helps. :)

    i get this error

    Tuesday, August 27, 2013 5:34 AM
  • Can you run this on your workstation instead?

    Use an account with Operations Manager access to run.


    Http://blog.theinfraguys.com | Please remember to click “Mark as Answer” on my answer if it helps. :)

    Tuesday, August 27, 2013 7:44 AM