none
Cannot create AlwaysOn High Availability Group

    Question

  • Hello!

    I'm succesfully created 2 HA Groups on test environments but when i trying to create them on production, getting stuck with error Cannot bring the WSFC resource online (error code 5018):

    I definitely can't find solution for this error..

    Tried to

    • remove and recreate cluster and cluster objets in AD
    • reassign permissions to AD objects
    • restart SQL services and servers
    • create HA Group using T-SQL instructions on technet

    But all with no success, still getting the same error.

    Cluster config: 2 Nodes with fileshare witness, 1 subnet with static IP addresses, domain account with all privilieges (http://technet.microsoft.com/en-us/library/cc731002(WS.10).aspx)

    Last part of error informing me that i didn't create listener, but in HA creation wizard, on Specify Replicas - Listener tab, when a click Create an availability group listener option and Static IP mode, an Add.. button greyed out and no subnets available!


    Monday, September 09, 2013 4:11 PM

All replies

  • Can you try creating a Client Access Point in your Failover Cluster Resource Group inside Failover Cluster Manager? This is not the right way to create the listener name but it will give you some ideas as to why this step is failing. Keep in mind that the creation of the Availability Group listener name is being passed to the WSFC to create the Client Access Point.

    Edwin Sarmiento SQL Server MVP
    Blog | Twitter | LinkedIn

    Monday, September 09, 2013 9:01 PM
    Moderator
  • Thanks, I'll try that, but i need to create HA group before.. Now i can't proceed this step getting error from first screenshot, even when i choose "Do not create availability group listener now"

    I'm already tried to Remove and recreate manually "SQL Server Availability Group" resource type in WSFC (via Add-ClusterResourceType), still no success.

    Could be a reason that NetBIOS name is different from FQDN-name?



    • Edited by lehus pohus Tuesday, September 10, 2013 2:21 AM
    Tuesday, September 10, 2013 2:13 AM