none
Internal mail sent to Junk E-mail folder

    Question

  • Hello,

    We have Exchange Server 2010 and our users have Outlook 2010.

    One of our internal application servers running on citrix sends an email to all staff once a week. This week we found that for the majority of users the email went into their Junk E-mail folder.

    I have found some useful information on this forum about SCLs and setting up a transport rule to set the SCL to -1 for certain users.

    I would like to know in Exchange/Outlook 2010 how can I find the SCL that was applied to a particular mail? Is it a good idea to turn off all Anti Spam features for internal mail?  

    Also, if I add a transport rule should I do it for the email address that sent the mail or the CITRIX server that sent it?

    Here is the message header:

     

    Received: from CITRIX_SERVER (10.23.15.10) by EXCHANGESERVER.ourdomain.local
     (10.47.14.165) with Microsoft SMTP Server id 14.1.270.1; Tue, 17 Jan 2012
     15:34:13 +1100
    From: Joe Smith jsmith@ourdomain.com
    To: myemailaddress@ourdomain.com
    Subject: Email from internal application server
    MIME-Version: 1.0
    Content-Type: multipart/mixed; boundary="66364131"
    Message-ID: <c0ce153a-ebf9-4f7f-ad66-9c78969b8733@exchangeserver.ourdomain.local>
    Return-Path: jsmith@ourdomain.com
    Date: Tue, 17 Jan 2012 15:34:13 +1100
    X-MS-Exchange-Organization-AuthSource:  EXCHANGESERVER.ourdomain.local
    X-MS-Exchange-Organization-AuthAs: Anonymous




    • Edited by crongity Wednesday, January 18, 2012 3:55 AM
    Tuesday, January 17, 2012 10:54 PM

Answers

  • On Tue, 17 Jan 2012 22:54:28 +0000, crongity wrote:
     
    >We have Exchange Server 2010 and our users have Outlook 2010.
    >
    >One of our internal application servers running on citrix sends an email to all staff once a week. This week we found that for the majority of users the email went into their Junk E-mail folder.
    >
    >I have found some useful information on this forum about SCLs and setting up a transport rule to set the SCL to -1 for certain users.
    >
    >I would like to know in Exchange/Outlook 2010 how can I find the SCL that was applied to a particular mail? Is it a good idea to turn off all Anti Spam features for internal mail?
     
    It's in the agent log.
     
    >Also, if I add a transport rule should I do it for the email address that sent the mail or the CITRIX server that sent it?
     
    Why not just add the IP address (or network) to the
    InternalSMTPServers with Set-TransportConfig? Your internal servers
    aren't subject to anti-spam agent actions.
     
    >Here is the message header:
     
    >Received: from CITRIX_SERVER (10.23.15.10) by EXCHANGESERVER.ourdomain.local (10.47.14.165) with Microsoft SMTP Server id 14.1.270.1; Tue, 17 Jan 2012 15:34:13 +1100 From: Joe Smith jsmith@ourdomain.com To: myemailaddress@ourdomain.com Subject: Email from internal application server MIME-Version: 1.0 Content-Type: multipart/mixed; boundary="66364131" Message-ID: <c0ce153a-ebf9-4f7f-ad66-9c78969b8733@exchangeserver.ourdomain.local> Return-Path: jsmith@ourdomain.com Date: Tue, 17 Jan 2012 15:34:13 +1100 X-MS-Exchange-Organization-AuthSource: EXCHANGESERVER.ourdomain.local X-MS-Exchange-Organization-AuthAs: Anonymous
     
    I don't see any SCL header in there. Are you sure it's not the Outlook
    junk mail filter that's the problem? If it is, you can have the users
    turn it off or add "ourdomain.com" to their safe-senders list.
     
    ---
    Rich Matheisen
    MCSE+I, Exchange MVP
     

    --- Rich Matheisen MCSE+I, Exchange MVP
    • Marked as answer by crongity Thursday, January 19, 2012 1:55 AM
    Wednesday, January 18, 2012 1:07 AM
  • hi,

    The Outlook client side filter also may cause emails to move to junk floder.Have you check it in your outlook,you can find this option in home page,and then click junk>>>junk E-mail options.you can see this:

    http://blogs.technet.com/b/outlooking/archive/2010/02/09/deploying-junk-e-mail-safe-senders-lists-in-outlook.aspx

    http://blogs.technet.com/b/evand/archive/2005/01/31/363935.aspx

    Or do you have some 3rd-party or another anti-spam software.

    >>>Also, if I add a transport rule should I do it for the email address that sent the mail or the CITRIX server that sent it?

    This link maybe can help you:http://social.technet.microsoft.com/Forums/zh/exchange2010/thread/6a0b4d7f-9f8a-4ca8-acf0-2d1bc59dc925.

    thanks,

    castin


    • Edited by Castinlu Thursday, January 19, 2012 1:31 AM
    • Marked as answer by crongity Thursday, January 19, 2012 1:55 AM
    Thursday, January 19, 2012 1:29 AM

All replies

  • On Tue, 17 Jan 2012 22:54:28 +0000, crongity wrote:
     
    >We have Exchange Server 2010 and our users have Outlook 2010.
    >
    >One of our internal application servers running on citrix sends an email to all staff once a week. This week we found that for the majority of users the email went into their Junk E-mail folder.
    >
    >I have found some useful information on this forum about SCLs and setting up a transport rule to set the SCL to -1 for certain users.
    >
    >I would like to know in Exchange/Outlook 2010 how can I find the SCL that was applied to a particular mail? Is it a good idea to turn off all Anti Spam features for internal mail?
     
    It's in the agent log.
     
    >Also, if I add a transport rule should I do it for the email address that sent the mail or the CITRIX server that sent it?
     
    Why not just add the IP address (or network) to the
    InternalSMTPServers with Set-TransportConfig? Your internal servers
    aren't subject to anti-spam agent actions.
     
    >Here is the message header:
     
    >Received: from CITRIX_SERVER (10.23.15.10) by EXCHANGESERVER.ourdomain.local (10.47.14.165) with Microsoft SMTP Server id 14.1.270.1; Tue, 17 Jan 2012 15:34:13 +1100 From: Joe Smith jsmith@ourdomain.com To: myemailaddress@ourdomain.com Subject: Email from internal application server MIME-Version: 1.0 Content-Type: multipart/mixed; boundary="66364131" Message-ID: <c0ce153a-ebf9-4f7f-ad66-9c78969b8733@exchangeserver.ourdomain.local> Return-Path: jsmith@ourdomain.com Date: Tue, 17 Jan 2012 15:34:13 +1100 X-MS-Exchange-Organization-AuthSource: EXCHANGESERVER.ourdomain.local X-MS-Exchange-Organization-AuthAs: Anonymous
     
    I don't see any SCL header in there. Are you sure it's not the Outlook
    junk mail filter that's the problem? If it is, you can have the users
    turn it off or add "ourdomain.com" to their safe-senders list.
     
    ---
    Rich Matheisen
    MCSE+I, Exchange MVP
     

    --- Rich Matheisen MCSE+I, Exchange MVP
    • Marked as answer by crongity Thursday, January 19, 2012 1:55 AM
    Wednesday, January 18, 2012 1:07 AM
  • hi,

    The Outlook client side filter also may cause emails to move to junk floder.Have you check it in your outlook,you can find this option in home page,and then click junk>>>junk E-mail options.you can see this:

    http://blogs.technet.com/b/outlooking/archive/2010/02/09/deploying-junk-e-mail-safe-senders-lists-in-outlook.aspx

    http://blogs.technet.com/b/evand/archive/2005/01/31/363935.aspx

    Or do you have some 3rd-party or another anti-spam software.

    >>>Also, if I add a transport rule should I do it for the email address that sent the mail or the CITRIX server that sent it?

    This link maybe can help you:http://social.technet.microsoft.com/Forums/zh/exchange2010/thread/6a0b4d7f-9f8a-4ca8-acf0-2d1bc59dc925.

    thanks,

    castin


    • Edited by Castinlu Thursday, January 19, 2012 1:31 AM
    • Marked as answer by crongity Thursday, January 19, 2012 1:55 AM
    Thursday, January 19, 2012 1:29 AM
  • Thank you both for the quick response.

    I'm beginning to think that it is the client side filter that is in fact moving it to Junk as you have both suggested.

    I will investigate adding this sender to the client's safe senders list via a GPO.

    Cheers!


    • Edited by crongity Thursday, January 19, 2012 1:55 AM
    Thursday, January 19, 2012 1:52 AM
  • You can use also EMS to configure safe senders:

    Set-MailboxJunkEmailConfiguration -Identity "user" -enabled $true -TrustedSendersAndDomains "sender1, sender 2"

     

    You can also use another method:

    Create recieve connector that is accpeting messages only from IP address of your Citrix server, and after that you Header Firewall permissions to mark all messages send from this conenctor to bypass anti-spam agents:

    If your Cintrix server is connecting as anonymous use this:

    Get-ReceiveConnector "server\name of the recieve connector" | Add-ADPermission -User "NT Authority\Anonymous Logon" -AccessRights ExtendedRight -ExtendedRights ms-exch-bypass-anti-spam

    If your Cintrix server is connecting as domain user:

    Get-ReceiveConnector "server\name of the recieve connector" | Add-ADPermission -User "domain\username" -AccessRights ExtendedRight -ExtendedRights ms-exch-bypass-anti-spam

     

    http://technet.microsoft.com/en-us/library/aa997242.aspx

     

    Tuesday, January 24, 2012 3:58 PM