none
NFS Mount always readonly

    Question

  • I have a NFS share I need to mount on my Windows 7/64bit/Ultimate machine.  I can mount it okay, but it is readonly.  I have played with the default UID/GID settings in the registry - no luck.  My windows machine is listed rw and root on the NFS export.  What could be the problem?

    Any ideas?

    Wednesday, September 25, 2013 12:12 AM

Answers

  • HI,

    Please first ensure that the read-only attribute is not set on the file or the directory, check the permission on NFS sharing.

    And pay attention to the command line you used to mount the share.

    For example: Syntax error on client mount command or server's /etc/exports:  Typically, failure to mount or failure to write enable. A space between the mount point and the (rw) causes the share to be read-only -- a frustrating and hard to diagnose problem.

    For detailed information, I’d like to share the following article with you:

    Mounting an NFS shared resource to a drive letter

    http://technet.microsoft.com/en-us/library/cc754350.aspx

    Regards,

    Yolanda

    Friday, September 27, 2013 2:21 AM