none
ARRANQUE DUAL XP y 7 - Windows XP se me queda congelado

    Question

  • Estoy configurando un arranque dual Windows XP y Windows 7 y tengo problemas con ello. Os cuento los pasos lo más detallado para no crear malinterpretaciones.

    Hice una instalación de XP en la partición 1 del disco de la que hice una IMAGEN con Acronis true image QUE GUARDÉ. Comencé a instalar en la partición 2 el Windows 7 y tras el primer reinicio recibí un mensaje de "error de lectura". Intenté diversas soluciones infructuosas, así que decidí partir de cero con Windows 7.

    Borré particiones y restauré imagen de XP para probar que funcionaba. OK.

    Volví a borrar las particiones y lancé la instalación de Windows 7 y con su configurador creé partición 1 de 100 Mb de sistema (activa), partición 2 para futuro XP, partición 3 para el 7 y dejé espacio por particionar. Terminada instalación de Windows 7 empleé el particionador de Acronis para crear dos particiones 4 y 5 lógicas. Y con Acronis true image restauré a la partición 2 la imagen de XP.

    Siguiendo un tutorial de JOSÉ MANUEL TELLA (http://multingles.net/docs/jmt/wvrecarranque.html) copié ntldr,  ntdetect.com y boot.ini a la partición 1 de 100mb activa. el boot.ini es

    [boot loader]
    timeout=0
    default=multi(0)disk(0)rdisk(0)partition(2)\WINDOWS
    [operating systems]
    multi(0)disk(0)rdisk(x)partition(2)\WINDOWS="XP" /NOEXECUTE=OPTIN /FASTDETECT

    Y por último edite el bcd a mano.


    bcdedit -create {ntldr} -d "Windows XP"
    bcdedit -set {ntldr} device partition=C:  
    bcdedit -set {ntldr} path \ntldr
    bcdedit -displayorder {ntldr} -addlast

    Con esto pude seleccionar el arranque de XP. Falló; no era partition=C: Usé el EasyBCD y me lo cambió por partition=F (luego me di cuenta en el administrador de discos de Windows 7 que 'F' era la letra asignada a la partición 2, la de XP).

    Ahora podía entrar a windows 7 y al tratarlo de hacer a XP éste comenzó a cargar, pero se me queda colgado en la pantalla azul de Bienvenida.

    He echado un vistazo al contenido de la partición 1 de sistema y he visto que ha aparecido un directorio de "Archivos de programa", lo que me lleva a pensar de que como la imagen de XP se creó en una partición 1 y activa parece que se empeña en ejecutarse desde ésta.

    ¿Alguna idea? Gracias.

    Tuesday, October 19, 2010 10:53 PM

Answers

  • Las!

    Le quité la letra de unidad a la partición lógica desde el administrador de discos de XP sin ningún resultado negativo... aparentemente ^_^ Hacérselo a la partición activa, por ser esto último, no me lo permite, por lo que me tocará decirle al familiar para el cual es el pc este de marras, que ni se le ocurra tocarla. Se me acaba de ocurrir mientras escribo esto que tal vez debería buscar si hay programas congeladores de unidades (no lo sé, pero parece lógico que los haya) para que no haga perrerías a dicha partición ni por activa ni por pasiva.

    Lo de la recuperación yo también lo he probado con la partición de Windows. Apliqué una imagen sobre ella y ningún problema.

    Saludos.

    El arreglo es simple: comprueba que en la particion activa esté el NTLDR y el NTDETECT.COM así como el boot.ini. Si están o no arranca, dejanos aqui el contenido del boot.ini así como una imagen del administrador de discos para ver el orden exacto de las particiones-.

    Estos dos articulo miso te darán una pista de la secuencia de arranque:

    http://multingles.net/docs/jmt/wvarranque2.html

    http://multingles.net/docs/jmt/wvrecarranque.html

    (son para VIsta pero el 7 es identico...)

    Un saludo,


    Jose Manuel Tella Llop news://jmtella.com

    Thursday, November 04, 2010 7:13 PM

All replies

  • Bueno, bueno, a la hora de instalar hay que tener en cuenta que la versiones VISTA y SEVEN ya no tienen botini...los pasos son dos particiones limpias en un hdd con tablas  MBR, instalas windows seven, y luego windows xp, luego veras que no puedes iniciar en ninguno para eso arrancas desde el disco de instalacion de windows 7 si eliges reparar el inicio. Una ves reparado el inicio puedes iniciar en seven pero no en xp, desde seven instalas EasyBCD, y después ejecutas EasyBCD  y añades la entrada del windows xp y de esta forma tendrás arranque selectivo. Saludos.
    Wednesday, October 20, 2010 9:22 AM
  • Gracias por las respuestas.

    Pues sí, he formateado y reinstalado... varias veces.

    He decidido simplificar y concentrarme en instalar XP en la 2ª partición, dejando la 1ª como "boot". He empleado diskpart del disco de W7 para crear una partición 1 de 110MB primaria y ACTIVA y una 2ª primaria de 60GB. Después instalaba XP en la 2ª, pero tras el primer reinicio me daba error. El uso de fixmbr, fixboot y comprobar que ntldr, ndetect.com y boot ini (apuntando a la 2ª partición) estaban en la primera no sirvió de nada.

    Después probé simplemente a crear las 2 particiones desde el cd de XP y ¡éxito! Sólo que al echar un vistazo a las particiones veo q la 1ª es primaria y activa (bien!), pero la 2ª con el XP es lógica (mal!).

    He pasado a enfocar el problema de otra forma, creando 3 particiones desde el instalador de W7  (100mb activa, 60GB para XP y 36GB para 7) e instalando a continuación W7 en la 3ª. Terminado esto he instalado XP en la 2ª y, como viene siendo costumbre, en el primer reinicio (tras copiar datos al HD) falla. Uso de comandos de recuperación no me han servido. (NOTA: aunque he tratado de ser cuidadoso y probarlo todo, pero con lo quemado que voy con el tema -llevo más de una semana con él- no descarto que me se me haya pasado en ese momento el uso de algún comando de restauración y realmente sí puediese haberlo hecho funcionar).

    Al final he distribuido 1ª 100mb activa, 36GB para W7 y 60GB XP. He instalado W7 y después XP en la  3ª. Fallo primer reinicio, pero esta vez bootrec /fixmbr, bootrec /fixboot y bootrec /rebuildbcd me han permitido acceder a W7. Desde allí probé a meter a mano en el bcd la entrada de menú de XP, pero falló. Harto, instalé easybcd y que lo hiciese él. ¡Funcionó el dual boot!

    Como curiosidad decir que en la partición 2 de W7 me he encontrado al autoexec.bat, config.sys y otros ficheros; cosa que no me preocupa porque ni falta q me hacen.

    Voy a ponerme a hacer backups como un loco antes de meter software, pero dos preguntas para después de eso. Windows 7 no muestra la partición de 100mb, pero XP sí (lo que es molesto), ¿es posible ocultársela? Y me queda espacio no asignado que pretendía usar para crear una partición extendida con 2 lógicas dentro; no veo que el administrador de discos me deje crear extendidas, ¿me toca usar Diskpart?

    Edito: Acabo de lanzar el Diskpart y aunque la partición 1 de 100mb es la activa, con el comando "detail partition" enfocando la 2ª con W7 me muestra con que en el campo "Info" pone "Arranque". ¿Esto a santo de qué?

    • Edited by Carlitos Ntldr Wednesday, October 20, 2010 9:34 PM corrección en el texto
    Wednesday, October 20, 2010 9:32 PM
  • Vaaale lo de las particiones extendidas-lógicas es con Diskpart.

    Otra cosa. Ni con diskpart ni con el administrador de discos de Win 7 he asignado letra de unidad a la partición 1 ACTIVA ni a la partición 5 lógica, por lo que Win 7 no me las muestra. Sin embargo cuando entro en XP éste sí que asigna letra de unidad a ambas. Si desde el administrador de discos de este último quito a las mencionadas particiones la letra de unidad, ¿hay algún problema?

    Por último. ¿Algún software de confianza para hacer backup del mbr y las tablas de partición? ¿Y para las particiones? Llevo tiempo usando acronis, ¿recomendáis algún otro?

    Gracias

    Wednesday, October 20, 2010 11:18 PM
  • Gracias por las respuestas.

    Pues sí, he formateado y reinstalado... varias veces.

    He decidido simplificar y concentrarme en instalar XP en la 2ª partición, dejando la 1ª como "boot". He empleado diskpart del disco de W7 para crear una partición 1 de 110MB primaria y ACTIVA y una 2ª primaria de 60GB. Después instalaba XP en la 2ª, pero tras el primer reinicio me daba error. El uso de fixmbr, fixboot y comprobar que ntldr, ndetect.com y boot ini (apuntando a la 2ª partición) estaban en la primera no sirvió de nada.

    Después probé simplemente a crear las 2 particiones desde el cd de XP y ¡éxito! Sólo que al echar un vistazo a las particiones veo q la 1ª es primaria y activa (bien!), pero la 2ª con el XP es lógica (mal!).

    He pasado a enfocar el problema de otra forma, creando 3 particiones desde el instalador de W7  (100mb activa, 60GB para XP y 36GB para 7) e instalando a continuación W7 en la 3ª. Terminado esto he instalado XP en la 2ª y, como viene siendo costumbre, en el primer reinicio (tras copiar datos al HD) falla. Uso de comandos de recuperación no me han servido. (NOTA: aunque he tratado de ser cuidadoso y probarlo todo, pero con lo quemado que voy con el tema -llevo más de una semana con él- no descarto que me se me haya pasado en ese momento el uso de algún comando de restauración y realmente sí puediese haberlo hecho funcionar).

    Al final he distribuido 1ª 100mb activa, 36GB para W7 y 60GB XP. He instalado W7 y después XP en la  3ª. Fallo primer reinicio, pero esta vez bootrec /fixmbr, bootrec /fixboot y bootrec /rebuildbcd me han permitido acceder a W7. Desde allí probé a meter a mano en el bcd la entrada de menú de XP, pero falló. Harto, instalé easybcd y que lo hiciese él. ¡Funcionó el dual boot!

    Como curiosidad decir que en la partición 2 de W7 me he encontrado al autoexec.bat, config.sys y otros ficheros; cosa que no me preocupa porque ni falta q me hacen.

    Voy a ponerme a hacer backups como un loco antes de meter software, pero dos preguntas para después de eso. Windows 7 no muestra la partición de 100mb, pero XP sí (lo que es molesto), ¿es posible ocultársela? Y me queda espacio no asignado que pretendía usar para crear una partición extendida con 2 lógicas dentro; no veo que el administrador de discos me deje crear extendidas, ¿me toca usar Diskpart?

    Edito: Acabo de lanzar el Diskpart y aunque la partición 1 de 100mb es la activa, con el comando "detail partition" enfocando la 2ª con W7 me muestra con que en el campo "Info" pone "Arranque". ¿Esto a santo de qué?

    Esa ni tocar ....mira mi video tal como te dije, lo hice en una maquina virtual vmware y no es gran historia http://www.youtube.com/watch?v=K-RAGnb_KIQ .Y ojo un solo disco duro.Las copia de seguridad lo puedes seguir haciendo con acronis en sentido que respaldas cada particion por separados, menos la intocable.Saludos
    Thursday, October 21, 2010 12:37 PM





    • Edited by Robert. _ Saturday, October 23, 2010 7:15 PM
    Thursday, October 21, 2010 5:04 PM
  • Las!

    Le quité la letra de unidad a la partición lógica desde el administrador de discos de XP sin ningún resultado negativo... aparentemente ^_^ Hacérselo a la partición activa, por ser esto último, no me lo permite, por lo que me tocará decirle al familiar para el cual es el pc este de marras, que ni se le ocurra tocarla. Se me acaba de ocurrir mientras escribo esto que tal vez debería buscar si hay programas congeladores de unidades (no lo sé, pero parece lógico que los haya) para que no haga perrerías a dicha partición ni por activa ni por pasiva.

    Lo de la recuperación yo también lo he probado con la partición de Windows. Apliqué una imagen sobre ella y ningún problema.

    Saludos.

    • Edited by Carlitos Ntldr Friday, October 22, 2010 10:33 PM corrección de una palabra
    Friday, October 22, 2010 10:32 PM
  • Cada vez que tengo XP y 7 siempre se me congela. Ya puedes ignorar el XP como el 7 cuando salgo el 8.
    Monday, October 25, 2010 4:48 PM
  • Hola,

    Hay algún avanzo en la solucion de este problema?

    Saludo


    Ismael Borche
    Thursday, November 04, 2010 5:27 PM
  • Las!

    Le quité la letra de unidad a la partición lógica desde el administrador de discos de XP sin ningún resultado negativo... aparentemente ^_^ Hacérselo a la partición activa, por ser esto último, no me lo permite, por lo que me tocará decirle al familiar para el cual es el pc este de marras, que ni se le ocurra tocarla. Se me acaba de ocurrir mientras escribo esto que tal vez debería buscar si hay programas congeladores de unidades (no lo sé, pero parece lógico que los haya) para que no haga perrerías a dicha partición ni por activa ni por pasiva.

    Lo de la recuperación yo también lo he probado con la partición de Windows. Apliqué una imagen sobre ella y ningún problema.

    Saludos.

    El arreglo es simple: comprueba que en la particion activa esté el NTLDR y el NTDETECT.COM así como el boot.ini. Si están o no arranca, dejanos aqui el contenido del boot.ini así como una imagen del administrador de discos para ver el orden exacto de las particiones-.

    Estos dos articulo miso te darán una pista de la secuencia de arranque:

    http://multingles.net/docs/jmt/wvarranque2.html

    http://multingles.net/docs/jmt/wvrecarranque.html

    (son para VIsta pero el 7 es identico...)

    Un saludo,


    Jose Manuel Tella Llop news://jmtella.com

    Thursday, November 04, 2010 7:13 PM