locked
Copying appsFolder.itemdata-ms file to Default Profile not working in Release Candidate

    Question

  • Hi

    In Windows 8 RC, I've tried copying the appsFolder.itemdata-ms file to c:\users\default\AppData\Local\Microsoft\Windows so that all users who login for the first time receive the same Start/Metro screen. This seemed to work on consumer preview edition, but no longer works on release candidate.

    Anybody else noticed this behaviour or found a solution to standardise the start screen for all users? In our environment (education) I need to be able to specify which tiles the students can see otherwise I can't see how Windows 8 is going to work for us.

    Thanks

    Andrew

    
    Thursday, June 07, 2012 1:33 PM

Answers

  • Hi

    Thanks for the reply. In the end, changing the appFolder.itemdata-ms to read-only was the same solution I found.

    (On reflection, I think the observed behaviour is intended because of how Apps interact with the start screen.)

    Andrew

    Monday, June 11, 2012 7:18 AM

All replies

  • If you change c:\users\default\AppData\Local\Microsoft\Windows\appFolder.itemdata-ms to readonly then it doesn't get overwritten when a new profile is created. To remove the read only attrib on the file I've used regedit to import the c:\users\default\ntuser.dat hive and add the entry  

    Name = MetroFudge

    Type = REG_EXPAND_SZ

    Data = c:\windows\system32\attrib.exe %USERPROFILE%\appdata\local\microsoft\windows\appfolder.itemdata-ms -R

    to the Software\Microsoft\Windows\RunOnce key in the mounted hive. Don't forget to dismount the hive afterwards!!!

    I know its not elegant, but it will probably change again in the final release.

    Friday, June 08, 2012 3:45 PM
  • hello Tomás de Torquemada,

    thank you for the post - sorry can you explain again?

    I did not found c:\users\default\ntuser.dat?

    I made a REG_EXPAND_SZ key in hklm\Software\Microsoft\Windows\RunOnce how you explained...but it not works?

    thank you and greetings

    Saturday, June 09, 2012 7:29 AM
  • Hi

    Thanks for the reply. In the end, changing the appFolder.itemdata-ms to read-only was the same solution I found.

    (On reflection, I think the observed behaviour is intended because of how Apps interact with the start screen.)

    Andrew

    Monday, June 11, 2012 7:18 AM
  • Good to see you got it working.

    The registery edit is just to remove the readonly attribute from the appfolder.itemdata-ms file in the newly created profile - maybe you want to keep it on in your environment.

    You can't see the c:\users\default\ntuser.dat becuase it is hidden - it is there. You can see the file if you go to the Control Panel/Folder Options/View (Change View By to Large icons if you can't see the Folder Options). Then tick "Show hidden files, Folders and drives" and untick "Hide extensions of known file type" and "Hide protected operating system files (Recommended)".

    Run regedit. Click On HKEY_LOCAL_MACHINE, then File/Load hive to import c:\users\default\ntuser.dat. Called the loaded hive xxx, then create the entry above in HKLM\xxx\Software\Microsoft\Windows\RunOnce. You will have to create the RunOnce key.

    To write the changes back, select xxx the the registry tree and click file/unload hive. 

    Monday, June 11, 2012 9:08 AM
  • Data = c:\windows\system32\attrib.exe %USERPROFILE%\appdata\local\microsoft\windows\appfolder.itemdata-ms -R

    Your solution is heroic, but there are two typo's in your solution:

    The Data value should be: c:\windows\system32\attrib.exe %USERPROFILE%\appdata\local\microsoft\windows\appsfolder.itemdata-ms -R

    The location of the RunOnce key should be: HKLM\xxx\Software\Microsoft\Windows\CurrentVersion\RunOnce

    Now it works like a charm!


    • Edited by MpDay Thursday, March 14, 2013 11:23 AM
    • Proposed as answer by MpDay Thursday, March 14, 2013 11:23 AM
    Thursday, March 14, 2013 10:27 AM