none
Can not connect PC to server using Connector (http://servername/connect) on 2012R2 Essentials

    Question

  • Hi

    I have just installed Windows Server 2012R2 Essentials on Azure. I have set up Anywhere Access VPN so domain name and cert is installed. I have also created some user accounts.

    I was trying to connect a PC (win7) to server using Essentials Connector (http://ServerDomainName/connect) and this otherwise connects to server but "Select the server at the drop-down list." there are no servers to select from? I have also tried to type the server name manually (prefix.mycompany.com, this domain was configured during Anywhere Access configuration) but no servers are found.

    I am trying to connect from home without any firewall/VPN established.


    • Edited by IKFI Tuesday, November 19, 2013 4:36 AM
    Tuesday, November 19, 2013 3:42 AM

Answers

  • Found a solution for my problem but ran into another one.

    I am using a test environment and hence using a self-signed certificate. Problem was that servers root cert was not installed to client PC. After installing server CAs root cert to client, connector started to work.

    But now the problem is that when connector is trying to establish a VPN connection, connection is beeing disconnected because no network protocols were successfully negotiated. 

    I think that this is because client is not receiving IP address from server but where can I configure the IP pool for VPN clients?? RAS role is installed to the server but there is no management link for RAS and I cannot find a setting for IP pool from Network Policy Server settings.

    Tuesday, November 19, 2013 5:38 AM
  • Found a solution for this too.

    You need to open RRAS management using MMC snap-in. Add server and from there you can configure IP pool for VPN connections.

    I just wonder why the server DHCP server dont share IPs for VPN clients..

    Tuesday, November 19, 2013 5:17 PM

All replies

  • Found a solution for my problem but ran into another one.

    I am using a test environment and hence using a self-signed certificate. Problem was that servers root cert was not installed to client PC. After installing server CAs root cert to client, connector started to work.

    But now the problem is that when connector is trying to establish a VPN connection, connection is beeing disconnected because no network protocols were successfully negotiated. 

    I think that this is because client is not receiving IP address from server but where can I configure the IP pool for VPN clients?? RAS role is installed to the server but there is no management link for RAS and I cannot find a setting for IP pool from Network Policy Server settings.

    Tuesday, November 19, 2013 5:38 AM
  • Found a solution for this too.

    You need to open RRAS management using MMC snap-in. Add server and from there you can configure IP pool for VPN connections.

    I just wonder why the server DHCP server dont share IPs for VPN clients..

    Tuesday, November 19, 2013 5:17 PM
  • Hi,

    I’m glad to hear that you have resolved the issue and thanks for sharing your solution in the forum. This will help others who face the same scenario resolve the issue quickly. If there is anything else I can do for you, please do not hesitate to let me know. I will be very happy to help.

    Best Regards,

    Andy Qi


    Andy Qi
    TechNet Community Support

    Wednesday, November 20, 2013 9:37 AM
    Moderator