none
Messages Record Management - not working

    Question

  • Exchange 2007 Enterprise Server
    Version 8.2 (Build 176.2)
    08.02.0176.002

    We are currently on the above version on Exchange with all roles in one box.

    We are in no position to update the current system & are planning on moving to Exchange 2010 by the year end.

    We are facing so many issues because of our inability to update the system.

    We are on a simple project to implement Messages Record Management to delete items in the "Deleted Items" older than 1 day.We have created this Managed folder content & policy & scheduled the "Manage Folder Assistant" to run from 12:00AM to 08:00AM. Now for testing purpose we have applied this policy to 6 Mailboxes that have more than 100 items in their respective "Deleted Items" folder.

    However, everyday morning I take the reports & I dont see any change in the mailboxes.I have not created any custom managed folder. I have done this directly with the Managed Default Folder.

    The links I used to deploy MRM

    http://www.msexchange.org/articles-tutorials/exchange-server-2007/compliance-policies-archiving/exchange-2007-messaging-records-management-part1.html

    http://www.msexchange.org/articles-tutorials/exchange-server-2007/compliance-policies-archiving/exchange-2007-messaging-records-management-part2.html

    https://www.simple-talk.com/sysadmin/exchange/an-introduction-to-messaging-records-management/

    http://www.microsoft.com/resources/msdn/en-us/office/media/video/video.html?cid=ehlo&VideoID=e92a03d1-0989-42a5-b288-5cfbd3aad2d3&from=sharepermalink&src=v5:share:sharepermalink:uuids

    I am somehow unable to get this to work. Kindly help me.
    Thursday, August 01, 2013 8:42 AM

Answers

All replies

  • Exchange 2007 Enterprise Server
    Version 8.2 (Build 176.2)
    08.02.0176.002

    We are currently on the above version on Exchange with all roles in one box.

    We are in no position to update the current system & are planning on moving to Exchange 2010 by the year end.

    We are facing so many issues because of our inability to update the system.

    We are on a simple project to implement Messages Record Management to delete items in the "Deleted Items" older than 1 day.We have created this Managed folder content & policy & scheduled the "Manage Folder Assistant" to run from 12:00AM to 08:00AM. Now for testing purpose we have applied this policy to 6 Mailboxes that have more than 100 items in their respective "Deleted Items" folder.

    However, everyday morning I take the reports & I dont see any change in the mailboxes.I have not created any custom managed folder. I have done this directly with the Managed Default Folder.

    The links I used to deploy MRM

    http://www.msexchange.org/articles-tutorials/exchange-server-2007/compliance-policies-archiving/exchange-2007-messaging-records-management-part1.html

    http://www.msexchange.org/articles-tutorials/exchange-server-2007/compliance-policies-archiving/exchange-2007-messaging-records-management-part2.html

    https://www.simple-talk.com/sysadmin/exchange/an-introduction-to-messaging-records-management/

    http://www.microsoft.com/resources/msdn/en-us/office/media/video/video.html?cid=ehlo&VideoID=e92a03d1-0989-42a5-b288-5cfbd3aad2d3&from=sharepermalink&src=v5:share:sharepermalink:uuids

    I am somehow unable to get this to work. Kindly help me.
    Thursday, August 01, 2013 8:37 AM
  • Hello,

    I recommend you restart managed folder assistant. You can use stop-managedfolderassistant cmdlet to stop managed folder assistant and then use start-managedfolderassistant cmdlet to start MRM processing of mailboxes to check the result.

    Here are some articles for your reference.

    Start-ManagedFolderAssistant

    http://technet.microsoft.com/en-us/library/aa998864(v=exchg.80).aspx

    Stop-ManagedFolderAssistant

    http://technet.microsoft.com/en-us/library/bb123532(v=exchg.80).aspx


    Cara Chen
    TechNet Community Support

    Saturday, August 03, 2013 9:09 AM
    Moderator
  • Hi,
    Which setting did you configure for the retention..."When delivered*" or "When Item is moved to the folder"
    I have many times found that the later (WhenMoved) is not working good, so if that was the setting you choosed...can you change it to WhenDelivered and see if that works for you.

    This was also discussed in this thread: http://social.technet.microsoft.com/Forums/exchange/en-us/427b0b86-ebc6-4ad5-889b-38a12b30f89d/how-to-configure-deleted-items-policy-on-database-level


    Martina Miskovic

    Sunday, August 04, 2013 9:57 AM