none
search not working in SharePoint 2010

    Question

  • Hello,

    I am on SharePoint Server 2010. I set up a intranet site with one name sharepoint2010:48109. I set up search and it was running properly. Then when we rolled out the site to internal users we changed the name in IIS and DNS to a friendly name. Now search does not work. I am getting the error:

    The item could not be accessed on the remote server because its address has an invalid syntax.

    I am assuming it is because the site has a new name now. We tried adding the new friendly name to the content source but that did not make a difference.

    Thank you for any advice you have.

    GL

    Friday, July 12, 2013 5:59 PM

Answers

All replies

  • Hi GL,

    I understand that you cannot search after you change the name in  IIS and DNS. Where do you get the error ? In crawl log or on the search results page?

    You can check these settings:

    1. After changing the name in IIS and DNS, have you added an Alternate Access Mapping in Central Administration? Make sure the Alternate Access Mapping has been configured correctly. You can try to view the site using new URL.
    2. Edit search service application. Add a new Server Name Mappings. You can specify the address at which the content will be crawled (this can be http://server_name:port) and the address (http://xyz) that will be displayed in search results.

    Thanks,

    Entan Ming


    Entan Ming
    TechNet Community Support

    Monday, July 15, 2013 2:28 AM
    Moderator
  • Hi Entan,

    I see the error in the crawl log. The results page just says could not find any results.

    I did add an Alternate Access Mapping adding the new friendly name url and choosing intranet zone. What else should I be checking? Another thing to mention is once we updated IIS with the friendly named site the initial sharepoint site with its specific port did not work anymore only the friendly name site does. We could not get both to work at the same time.

    I did previously add a Server Name Mapping. I put the address for indexing as the original site and address for display as the friendly name.

    What else can I check?

    Thanks,

    Ga-Hsin


    GL

    Monday, July 15, 2013 9:38 PM
  • Hi,

    Thank you for your post.
    I'm trying to involve someone familiar with this topic to further look at this issue. There might be some time delay. Appreciate your patience.

    Thanks ,
    Entan Ming


    Entan Ming
    TechNet Community Support

    Tuesday, July 16, 2013 10:12 AM
    Moderator
  • Hi GL,

    do you able to copy and paste the crawl log that capture the issue?

    actually, perhaps you can create a new search service application and have a comparison between the old and the new results.

    for AAM settings, the site i think need to be extend first then we can set the extended site to be intranet.

    if we add the site name only and we didnt extend it, seems it will not work as in favor as some links that cover them may not connected.

    please have a try also, if connected directly to the links, if based on the IE able to locate and access the site, the crawl should able to do as the same.


    Regards,
    Aries
    Microsoft Online Community Support


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.

    Tuesday, July 16, 2013 10:26 AM
  • Thanks Aries,

    Should I take the existing site and extend that one and then set up AAM again?

    Should I extend the site first  before setting up a second search service applications?

    This is the error I see. Is there anything else you want to see?

    Thanks for your help!


    GL

    Thursday, July 18, 2013 7:21 PM
  • Hi GL,

    thanks for the reply,

    i saw the count quite alot, seems everytime it crawl its add up. i guess if you click the numbers there will show your the details.

    if this is a development environment, you may extend it then configure the AAM at the same dialog box on below, you shall find the public URL area, and you may select as intranet over there.

    after you done that, you can re-crawl the whole site, and have a check if should the new extended URL is having the issue or not.

    to re-crawl, you may create your new search application, or if you want to check on the first part should your search having issue or not, you may create this new search application and re-crawl that first, and see the result, if should the result is different, then perhaps your previous search settings have some issues, if the same, then you may try with the extend the site steps, then re-crawl.


    Regards,
    Aries
    Microsoft Online Community Support


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.

    Friday, July 19, 2013 2:23 AM
  • Thanks Aries,

    Unfortunately, it is not a development site but it is in production. Is there any danger in extending the prod site?

    Thanks,

    Ga-Hsin


    GL

    Friday, July 19, 2013 2:51 PM
  • Hello GL,

    Based on information you have provided here I understand this as following.

    You had a sharepoint site which was created as http://sharepoint2010:48109 and site was working fine and search was also working as expected.

    Later on you changed bindings in IIS removed port 48109 from IIS and replaced it with host header and port 80. Updated DNS and users are able to browse the site.

    You have added friendly name (http://xyz) as intranet zone in AAM and also tried to crawl http://xyz but no luck witht that either.


    If above understanding is correct then do following

    First of all for each zone you have in AAM you should have backing IIS site. the way you should have done is by extending the site as Friendly name site and keep crawling Default Zone URL.

    Now that you did not extend the site but just changed IIS bindings your AAM for this web app should look like following.


    Internal  Zone Public
    http://xyz Default http://xyz

    Once you have AAM's as above make sure that your Content Source is also having url http://xyz


    also make sure that you can browse the Friendlynamed url (http://xyz) from Servers hosting Crawl Components with default content access accounts.


    I am including a really good 3 part blog post which explains Alternate Access Mappings

    http://blogs.office.com/b/sharepoint/archive/2010/08/16/what-every-sharepoint-administrator-needs-to-know-about-alternate-access-mappings-part-1-of-3.aspx
    http://blogs.office.com/b/sharepoint/archive/2010/08/16/what-every-sharepoint-administrator-needs-to-know-about-alternate-access-mappings-part-2-of-3.aspx
    http://blogs.office.com/b/sharepoint/archive/2010/08/16/what-every-sharepoint-administrator-needs-to-know-about-alternate-access-mappings-part-3-of-3.aspx



    Reagrds,

    Hiran
    Microsoft Online Community Support


    Friday, July 19, 2013 11:46 PM
  • hi GL,

    as hiran posted earlier, perhaps that is what happened on your environment before.

    for testing on production level, usually we try to create new dummy web app, and the dummy site collection, then we reproduce the issue, for this you may also create a new search application that is different for the testing purpose, by adding the content sources that target the dummy site.

    as those dummy environment, we may retract them after the test, and will have less impact to the production site.


    Regards,
    Aries
    Microsoft Online Community Support


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.

    Monday, July 22, 2013 3:18 AM