none
Acceso denegado al acceder, guardar o publicar flujos de trabajo.

    Question

  • Buenas, tengo el siguiente problema en una de mis colecciones de sitios:

    - Tengo una serie de flujos de trabajo en las listas, dichos flujos de trabajo son OOTB.

    - Desde hace unos días al intentar acceder a los flujos de trabajo desde SP Designer, me da acceso denegado cuando intento guardar o publicar un flujo.

    - Lo mismo me ocurre cuando accedo a la lista desde SharePoint y en la cinta hago click en el icono de flujos de trabajo.

    - Mi usuario es administrador de la colección de sitios.

    ¿Se os ocurre alguna solución?.

    Gracias por adelantado!!!


    Tomás González. Twitter://@tgmourino

    Tuesday, January 08, 2013 9:08 AM

Answers

  • Bueno, ya encontré el problema.

    Las cuentas de la aplicación del pool del IIS y la cuenta de servicio de la colección de sitios deben ser la misma.

    En este caso no estaban así, tal vez alguien cambió la cuenta en el SP (me extraña, pero bueno). El caso es que al configurar ambas cuentas, ya vuelven a estar operativo el acceso a los flujos de trabajo.

    Gracias!!


    Tomás González. Twitter://@tgmourino

    Tuesday, January 08, 2013 10:29 AM

All replies

  • Buenas Tomás,

    En el caso de que hagas clic sobre el icono de flujos, ¿has mirado si en los logs se está registrando más detalle del motivo por el que se está dando un error de acceso denegado?

    Un saludo


    ------------------------------------------------------------
    Juan Carlos González Martín MVP de SharePoint Server
    Director revista CompartiMOSS: http://www.gavd.net/servers/compartimoss/compartimoss_main.aspx
    Blog: http://geeks.ms/blogs/ciin
    Twitter: @jcgm1978
    ------------------------------------------------------------

    Tuesday, January 08, 2013 9:16 AM
  • Hola Juan Carlos,

    Sí, disculpa, me olvidé de incluir el error que da en el log:

    Unknown SPRequest error occurred. More information: 0x80070005

    Saludos.


    Tomás González. Twitter://@tgmourino

    Tuesday, January 08, 2013 9:49 AM
  • :-)...si señor,

    Un error muy explicativo...¿este problema sólo te pasa con esa colección de sitios o con cualquier otra? ¿Has probado a añadir otro usuario también administrador de la colección para ver qué pasa?

    Un saludo


    ------------------------------------------------------------
    Juan Carlos González Martín MVP de SharePoint Server
    Director revista CompartiMOSS: http://www.gavd.net/servers/compartimoss/compartimoss_main.aspx
    Blog: http://geeks.ms/blogs/ciin
    Twitter: @jcgm1978
    ------------------------------------------------------------

    Tuesday, January 08, 2013 9:54 AM
  • Jejeje, sí, a veces los errores del log son así de claros :P

    El error sólo se reproduce en esa colección de sitios y también probé a añadir otros usuarios como administradores de la colección de sitios, reproduciéndose el mismo error.

    En algún hilo encontré problemas similares a la hora de añadir flujos de trabajo desarrollados con VS, pero este no es el caso.

    Saludos.


    Tomás González. Twitter://@tgmourino

    Tuesday, January 08, 2013 10:01 AM
  • Bueno, ya encontré el problema.

    Las cuentas de la aplicación del pool del IIS y la cuenta de servicio de la colección de sitios deben ser la misma.

    En este caso no estaban así, tal vez alguien cambió la cuenta en el SP (me extraña, pero bueno). El caso es que al configurar ambas cuentas, ya vuelven a estar operativo el acceso a los flujos de trabajo.

    Gracias!!


    Tomás González. Twitter://@tgmourino

    Tuesday, January 08, 2013 10:29 AM