none
Software Deployment via GPO's all of sudden not working

    Question

  • 2008 R2 mixed 2003 Domain level. 2008 R2 DC FSMO role holder and GC.

    Okay, all of a sudden my msi software deployments via AD GPO aren't working. I can't add any new policies or even use any old (current) policies. When I run a gpupdate on the client machine I get two different messages:

    C:\>gpupdate
    Updating Policy...

    User Policy update has completed successfully.

    The following warnings were encountered during user policy processing:

    Windows failed to apply the Software Installation settings. Software Installatio
    n settings might have its own log file. Please click on the "More information" l
    ink.
    Windows could not record  the Resultant Set of Policy (RSoP) information for the
     Group Policy extension <Software Installation>. Group Policy settings successfu
    lly applied to the computer or user; however, management tools may not report ac
    curately.
    Computer Policy update has completed successfully.

    For more detailed information, review the event log or run GPRESULT /H GPReport.
    html from the command line to access information about Group Policy results.

    and

    The Group Policy Client Side Extension Software Installation was unable to apply

    one or more settings because the changes must be processed before system startu

    p or user logon. The system will wait for Group Policy processing to finish comp

    letely before the next startup or logon for this user, and this may result in sl

    ow startup and boot performance.

    Anyone else seen this or experiencing this all of a sudden?

    Thanks,

    SM

     

    Thursday, June 27, 2013 6:55 PM

Answers

All replies

  • Do you see anything in the Event Viewer? Check the 'System' log - filter by source: 'Application Management Group Policy', as well as 'Applications and Services' > 'Microsoft' > 'Windows' > 'Group Policy' > 'Operational'.
    Thursday, June 27, 2013 8:20 PM
  • Depending on the event ID in the event logs this page may provide the solution you need: http://technet.microsoft.com/en-us/library/cc727267

    Thursday, June 27, 2013 8:56 PM
  • I see events 108, 204.

    I also see Event 1085:

    Windows failed to apply the Software Installation settings. Software Installation settings might have its own log file. Please click on the "More information" link.

    and Event 1091:

    Windows could not record  the Resultant Set of Policy (RSoP) information for the Group Policy extension <Software Installation>. Group Policy settings successfully applied to the computer or user; however, management tools may not report accurately.

    Friday, June 28, 2013 11:53 AM
  • Hi Thanks for the reply.

    Everything in the operational is Informational except an occasional Error Event ID 7016:

    "Completed Software Installation Extension Processing in xx milliseconds"

    Friday, June 28, 2013 11:56 AM
  • I would focus on event 204. Try the resolutions here: http://technet.microsoft.com/en-us/library/cc727326
    • Marked as answer by Skelleyman Tuesday, July 02, 2013 6:22 PM
    Friday, June 28, 2013 3:14 PM