none
Updates image does not autologon during task sequence

    Question

  • We use MDT 2010 to image out Thin Clients. I used an existing image to create a new installation (added windows updates, updates software), sysprep’d the installation and captured it back to the WDS server (Server 2008r2). I created in MDT a new Task Sequence which matches the Task Sequence from the original image and removed unnecessary steps like installing application updates.
    The problem I face now is that autologon does not work. I need to manually enter  the local admin password (did not need to change the login name) to login and the task sequence continues.
    We do not have any GPO restrictions on the local passwords on the OU where the computer resides.
    Steps I tried so far:

    • Recreation of the Task Sequence
    • Checked the logfiles (Event log and those in c:\Windows\panther\) Found no login failure errors
    • Copied the working task sequence form the original image
    • Move the ‘Domain Join’ task to be the final step and even disabled the task.
    • Used search engine to find similar issues, but none found which resolved this issue
    • Checked the original image and it does logon automatically during the Task Sequence

    Any help would be appreciated.


    • Edited by Primator Monday, June 10, 2013 9:57 AM
    Monday, June 10, 2013 9:47 AM

All replies

  • Try to copy over the unattend.xml from the task sequence that you based the new task sequence on.

    Example, your original task sequence had the task sequence id "ts-001" and the new task sequence has tsid " ts-002". Go to the deploymentshare, and copy the file \Control\TS-001\Unattend.xml to \Control\TS-002.

    Seeing the other steps you've tried, this would be the only thing that still would differ from the first TS compared to the new one.


    Kind regards,

    Stephan Schwarz.


    If one of these posts answered your question or issue, please click on "Mark as answer".

    My Blog | Twitter: @Schwarz_Stephan | MCTS, MCITP, MCSA, MCSE (Charter Member), MCC-2011.
    Automatically determine target OU from ComputerName with PS for MDT2012 U1/ConfigMgr
    How to configure Windows RE/OEM Recovery Partition with MDT 2012 Update 1

    Monday, June 10, 2013 11:01 AM
  • I will try it (though I can not imagine that I have not tried this before).

    I'll return with the results.

    Update:

    And the results are the same as before; unknown username or bad password.

    • Edited by Primator Monday, June 10, 2013 2:45 PM Updated with the results
    Monday, June 10, 2013 11:55 AM
  • Do you have a legal disclaimer or some other GPO that would prevent the automatic log on? If you set the machine to join the domain, that will happen during Windows setup, regardless of where you move "Recover From Domain" in the TS.

    -Nick O.

    Monday, June 10, 2013 4:35 PM
  • There are no legal disclaimers or other restrictions on the OU. The same OU is used to roll out other images which do not have this password error.

    But I did notice something else. The value of the reg key 'defaultpassword' in HKLM\software\microsoft\windows nt\currentversion\winlogon\ is empy. When I add the local admin password through remote registry and reboot, the TC autologon does work and the Task Sequence contintues.

    Tuesday, June 11, 2013 6:30 AM
  • Update:

    Never found a solution for this problem.

    Created a new image from scratch, Task Sequence (and the autologon) run as it should.

    Tuesday, July 02, 2013 9:58 AM
  • If a new one from scratch worked, then it's likely either something that was done to the Unattend.xml (my guess) or in the Task Sequence.  Glad it's working now!


    David Coulter | http://DCtheGeek.blogspot.com | @DCtheGeek

    Tuesday, July 02, 2013 1:01 PM