none
Virtual Machines are taking IP V6 automatically

    Question

  • Hi All,

    I have created  VMM 2012 R2 lab environment with WK12 R2 servers.

    All the VM's created in the Vmm are taking IPV6 automatically...  how to force VM's to take IPV4 by default?

    Thanks

    Wednesday, August 21, 2013 11:11 AM

Answers

All replies

  • All Windows Servers since 2008 (possibly prior, I can't recall when they began appearing 2003 might be a better answer) generate a 'link local' IPv6 address.

    Is this the IPv6 address you are seeing?

    If you are assigning an IPv4 address from a pool, the VMs will get one.  And, the OS should self-generate both if one is not assigned or DHCP is not available.


    Brian Ehlert
    http://ITProctology.blogspot.com
    Learn. Apply. Repeat.
    Disclaimer: Attempting change is of your own free will.

    Wednesday, August 21, 2013 2:47 PM
  • The VM is taking both IPV4 and IPV6

    if I want to take RDP of the VM I am manually disabling IPV6 on client machine.

    Is  it possible to Disable IPV6 in VMM environment?

    Thanks,

    Pradeep


    Wednesday, August 21, 2013 2:51 PM
  • There should be no need to disable IPv6.  In fact, MSFT claims in many cases to just leave it alone and do not disable it.

    What is the issue that you are experiencing that is requiring that you disable IPv6?

    And, how are you assigning IP addresses?  DHCP?  IP pools from VMM? etc.? 

    (like I said, the OS will self-generate both APIPA and Link Lock IP addresses if a network connection is available - it is default OS behavior, but this is not an 'assigned' IP address).


    Brian Ehlert
    http://ITProctology.blogspot.com
    Learn. Apply. Repeat.
    Disclaimer: Attempting change is of your own free will.

    Wednesday, August 21, 2013 3:10 PM
  • I am assigning form  IP pool 192.168.1.0/24 form VMM.

    I have Created Service management portal(Azure Pack), and Tenants are able to create VM's successfully from Tenant site.

    after creating the VM if Tenant tries to access the VM from RDP option available in Tenant site it is showing with IPv6 and not able to take RDP

    I have logged in to VM and disabled the IPv6 and tried accessing from Tenant site and able to take RDP

    Wednesday, August 21, 2013 3:20 PM
  • So, I have not tried this yet myself, but the Azure Pack - how do you set it up to hand the customer the RDP connection?

    I am guessing that it is attempting to use the self assigned IPv6 address, not a public IPv6 address.


    Brian Ehlert
    http://ITProctology.blogspot.com
    Learn. Apply. Repeat.
    Disclaimer: Attempting change is of your own free will.

    Wednesday, August 21, 2013 3:35 PM
  • I have Built the setup in Lab environment ( Private Cloud)

    Used WK12 R2 Preview, Scvmm 2012 R2 Preview, Azure Pack, SPF

     

    Wednesday, August 21, 2013 3:45 PM
  • Deeper into SCVMM setup..

    Does your Logical Network have associated IP Pools?  Are you using some DHCP infrastructure to assign the IP addresses?

    Do you have this issue due to incomplete setup?


    Brian Ehlert
    http://ITProctology.blogspot.com
    Learn. Apply. Repeat.
    Disclaimer: Attempting change is of your own free will.

    Wednesday, August 21, 2013 4:11 PM
  • This setup has 3 hosts where they are getting Ip from Production DHCP server(192.168.160.0/24)

    Lab setup is done as below : used Static Ips of production network

    DC : 192.168.160.31

    VMMHOST : 192.168.160.32

    HYPERVHOST : 192.168.160.33

    1. Added hypervhost to VMM
    2. created IP pool on the Logical network (192.168.1.0/24)
    3. Created Cloud
    4. Created VM Templates(Modified Network to take Ip form STATIC IP pool)
    5. VM's successfully created

    VM is getting IP from the Static ip pool(192.168.1.11) and IPV6 also(fe:01:f6....)

    if i disable IPv6 on the VM only i am able to RDP with IP4



    • Edited by Pradeep_babcy Wednesday, August 21, 2013 5:57 PM modified
    Wednesday, August 21, 2013 5:54 PM
  • So, you are not granting IPv6 IP addresses, it is the self-generated link local address.

    IMHO - the issue is not there, the issue is the IP that is being given to the user when they attempt to connect to a VM.

    How is the user getting the IP to use to connect to the VM?  (that is the level that needs to be configured properly).

    I am hoping that Kristian will drive by and notice this thread as well, as he has been playing around with the Pack.


    Brian Ehlert
    http://ITProctology.blogspot.com
    Learn. Apply. Repeat.
    Disclaimer: Attempting change is of your own free will.

    Wednesday, August 21, 2013 6:54 PM
  • Just to make sure: no network virtualization is involved here? 

    If not, I can confirm that this has been reported as a bug.

    -kn


    Kristian (Virtualization and some coffee: http://kristiannese.blogspot.com )

    Tuesday, August 27, 2013 4:06 PM
  •  No network virtualization is involved

    Wednesday, August 28, 2013 6:44 AM
  • Good to know.

    This one should be addressed in the final release.

    thx.

    -kn


    Kristian (Virtualization and some coffee: http://kristiannese.blogspot.com )

    Friday, August 30, 2013 11:56 AM