none
Mount Database Failure - Exchange 2013

    Question

  • Hi, 

    I'm trying to create a new database in Exchange 2013 Enterprise edition. The new database fails to mount and remains in a dismounted state. 

    I'm running the following command in Exchange Powershell:

    Mount-Database -Identity SERVERNAME.DOMAIN.LOCAL\DATABASENAME and the following error occurs:

    Cannot process argument transformation on parameter 'Identity'. Cannot convert value
    "SERVERNAME.DOMAIN.LOCAL\DATABASENAME" to type
    "Microsoft.Exchange.Configuration.Tasks.DatabaseIdParameter". Error:
    "'SERVERNAME.DOMAIN.LOCAL\DATABASENAME.4.Single' is not a valid value for the identity.
    Parameter name: Identity"
        + CategoryInfo          : InvalidData: (:) [Mount-Database], ParameterBindin...mationException
        + FullyQualifiedErrorId : ParameterArgumentTransformationError,Mount-Database
        + PSComputerName        : SERVERNAME.DOMAIN.LOCAL

    I've had a look around online and I'm struggling to find an answer.

    Can anyone offer any advise?

    Thanks

    Monday, September 30, 2013 9:04 AM

Answers

  • Hello,

    The identity parameter specifies the GUID or distinguished name (DN) that represents a specific database.

    I recommend you use get-mailboxdatabase cmdlet to check your mailbox database name or use get-mailboxdatabase | fl guid to check your database guid. And then use mount-database cmdlet to mount your database.


    Cara Chen
    TechNet Community Support

    Tuesday, October 01, 2013 2:58 AM

All replies

  • Hello,

    The identity parameter specifies the GUID or distinguished name (DN) that represents a specific database.

    I recommend you use get-mailboxdatabase cmdlet to check your mailbox database name or use get-mailboxdatabase | fl guid to check your database guid. And then use mount-database cmdlet to mount your database.


    Cara Chen
    TechNet Community Support

    Tuesday, October 01, 2013 2:58 AM
  • Thank you so much! That has helped massively! I've been fighting with this for a few days lol.
    Tuesday, October 01, 2013 8:03 AM