none
Windows Server 2012 Windows Update hangs at every step

    Question

  • This has happened on every 2012 server I've installed except for the one I installed in Oracle VirtualBox.

    When I try to open Windows Update from the control panel, it hangs for 20-30 minutes (can't even move the window), then when it finally opens, when I click any option (Change settings or Check for Updates) it hangs for another 20-30 minutes.  After the half hour wait and Check Updates finally runs and I click Install, it hangs for another 20-30 minutes before downloading.  When it finishes downloading, it hangs for ANOTHER 20-30 minutes before installing.

    Anybody have any idea what is going on?

    Tuesday, April 30, 2013 6:50 PM

All replies

  • What does say the WindowsUpdate.log?

    This KB may help http://support.microsoft.com/kb/2700567/en-us

    Rgds

    Milos

    Wednesday, May 01, 2013 9:05 AM
  • Best I can suggest is to refresh it all.

    1. Open a Command Prompt. Click Start > Run and type “cmd” then hit “OK”
    2. Type “net stop wuauserv”. This shuts down the windows update service so you can delete the files.
    3. Still on the Command Prompt, type “cd /d %windir%”
    4. Type “rd /s SoftwareDistribution”
    5. Type “net start wuauserv” to restart the service then check for updates as normal

    • Proposed as answer by Adrian-A Thursday, December 05, 2013 8:27 PM
    Thursday, May 02, 2013 2:08 AM
  • This KB is about hanging after the downloading and installing has already started, so it doesn't apply.  I'm getting the hang just from opening the Windows Update console.

    Thursday, May 02, 2013 1:48 PM
  • Tried that already... I found a temporary fix:

    1. Stop the Windows Update Service

    2. When it hangs at 50%, open a command prompt and run "sc queryex wuauserv" and find the PID

    3. Open Task Manager and kill the process with that PID

    4. Stop the Background Intelligent Transfer Service

    5. Start the Windows Update service

    6. RESTART the Windows Update service (I don't know why this is needed, but it doesn't work if I don't do it)

    7. Start the Background Intelligent Transfer Service

    This will fix it long enough to start a scan for new updates.  At that point it starts hanging again (20-30 minutes before it actually scans and shows you updates, then another 20-30 minutes after clicking install)

    This process has to be repeated every time you want to check for updates, even if it's immediately after a reboot.  Very irritating.

    Thursday, May 02, 2013 1:52 PM
  • Hi,

    I once heard that it had something to do with Norton Internet Security.Anyway, pls do the followings to narrow down the issue.More likely,it had sth to do with 3rd party application. 

    Disable your Antivirus security software / Firewall

    • To do this, right click on your antivirus program in taskbar
    • Click on Disable product protection or a similar looking button

    Disabling non-Microsoft services temporarily

    • Press Windows Logo key + R to open run
    • Type msconfig
    • Go to the services tab
    • Click on Hide all Microsoft Services

       

    regards,

    Clarence


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.



    Tuesday, May 07, 2013 5:49 AM
    Moderator
  • Unfortunately, this issue came up immediately upon booting the server for the first time. There were no 3rd party applications installed and no anti-virus had been installed yet.
    Tuesday, May 07, 2013 4:29 PM
  • I'm experiencing the same issue, but on Windows 8 and it's not just VirtualBox; it's also VMware Workstation 9. Seems to be a problem with Windows since Windows 7 VMs work fine...

    And in both cases, it's a fresh install with no 3rd party apps installed.


    • Edited by briangw Tuesday, June 11, 2013 2:53 PM
    Tuesday, June 11, 2013 2:50 PM
  • I also have the same problem....

    I have also 2 Datacenter server 2012 installed with the same iso.

    One server hat the same symptoms.

    Is there any solution                                          

                                                     


    Thursday, July 11, 2013 8:49 PM
  • Same problem here, incredibly frustrating.

    Tuesday, July 16, 2013 10:34 AM
  • I continued to have these same problems until I switched Windows Update settings back to "Never check for updates (not recommended)". I previously had it set to "Download only". I was then able to manually check and install updates (tried 1 at a time first) normally after that. This solved the problem on 2 different 2012 servers...
    Saturday, July 20, 2013 2:37 PM
  • I have found another trick, when update block, just virtually remove the "network cable" (vitualbox: network icon, config network un thick cable, save, wait 10 sec, then thick again) each time it was blocking (so 3-4 times for each update).

    But setting to "never" is like a pain relief, while still blocking sometimes :-(. in that case the network trick is giving a "you have to be connected to internet" message, a retry button, and sync cable on/off with update behavior is sometimes...ouch.

    Anyway, big thanks for the "never" solution !

    Tuesday, July 23, 2013 7:40 AM
  • None of the answers here worked for me.  I ended up taking the server out of the domain and updates ran fine for me.  Just avoid update KB2821895 causes problems with RD services.

    Monday, August 05, 2013 8:02 PM
  • I had the same problems with a brand new 2012 VM.

    No other software loaded. First I got the red X when trying check for updates.

    Rebooted a few times. Then it showed the updates needed but never downloaded them.

    It would sit at 0% 0KB downloaded and not change.

    I had my download settings set to -Download updates but let me choose when to install them.

    I have since made the following changes:

    1. deleted everything out of the softwaredistribution folder

    2. set updates to notify me of updates but do not download or install them

    3. Rebooted

    4. seems to be working now.

    Fix your software Microsoft...

    Wednesday, September 11, 2013 5:31 PM
  • FWIW - I've been seeing the same thing happening across multiple (but not all) physical machines.
    Saturday, September 21, 2013 5:41 PM
  • Try this at an elevated command-prompt:

    netsh winhttp import proxy source=ie
    Everything should now work and be nice and fast, as expected.
    • Proposed as answer by schooltechbham Monday, October 14, 2013 2:09 PM
    Wednesday, September 25, 2013 11:30 AM
  • Try this at an elevated command-prompt:

    netsh winhttp import proxy source=ie
    Everything should now work and be nice and fast, as expected.

    Nothing else worked, this did. Thanks mfah!
    • Edited by Twelvety Thursday, September 26, 2013 8:24 AM
    Thursday, September 26, 2013 8:17 AM
  • Try this at an elevated command-prompt:

    netsh winhttp import proxy source=ie
    Everything should now work and be nice and fast, as expected.

    This worked for me too.  (Fresh install of Win Srv 2012 trial behind http proxy)
    Monday, October 14, 2013 2:10 PM
  • Try this at an elevated command-prompt:

    netsh winhttp import proxy source=ie
    Everything should now work and be nice and fast, as expected.

    Spot on, thank you. Brand new Server 2012 Standard OEM from Dell. Was sitting behind a proxy I had set in IE. Update was crashing and I kept having to reboot. This did the trick and it's nice and zippy again. For now...
    Friday, November 01, 2013 1:45 PM
  • Try this at an elevated command-prompt:

    netsh winhttp import proxy source=ie
    Everything should now work and be nice and fast, as expected.
    This fixed the issue for me on a number of newly cloned Win2012 virtual machines
    Monday, December 02, 2013 7:32 PM
  • Great - thanks for good solution.
    Thursday, January 30, 2014 2:05 PM
  • Try this at an elevated command-prompt:

    netsh winhttp import proxy source=ie
    Everything should now work and be nice and fast, as expected.
    Need to reboot after apply this. Then, works great
    Tuesday, March 25, 2014 4:13 PM
  • Restart WUS after apply this fix and works like a charm ! Thankz
    Wednesday, April 09, 2014 8:02 AM
  • Try this at an elevated command-prompt:

    netsh winhttp import proxy source=ie
    Everything should now work and be nice and fast, as expected.

    Damn... after looking everywhere for a solution, this finally worked on several 2012 physical machines. Most were brand new builds, so obviously this is a common problem with the proxy setting being incorrect out of the 'box'. 

    Thanks again for posting the fix.

    Wednesday, April 16, 2014 2:47 PM