none
Recupération Windows 7 à partir d'un disque externe réseau ou USB impossible

    General discussion

  • Bonjour à tous

    Je suis confronté à un problème de reconnaissance des sauvegardes Windows sur des disques externes, que ce soit sur un NAS, autre PC sous Windows ou disque dur USB externe

    Configuration générale
    - Modem-Routeur : Freebox revolution
    - Portable à réinstaller : Windows 7 Professionnel Service Pack 1, connecté par câble au modem-routeur. Nommé "Port-Epernay" par la suite dans ce post.
    - Disque dur USB : WD MyBook Essential , connecté directement par USB3 du portable à réinstaller.
    - NAS : Synologie DiskStation sous système DSM 4.3, connecté par câble au modem-routeur.
    - Portable 2 : Windows 7 Intégral Service Pack 1, connecté par Wifi au modem-routeur. Nommé "PC2" par la suite dans ce post.
    - Groupe de travail : libellé "WORKGROUP" modifié en "RESO" sur toutes les machines (les 2 PC et le NAS).

    Configuration NAS Synologie
    Panneau de configuration Win/Mac/NFS, options cochées :
    - Activer le service de fichiers Windows
    - Groupe de travail "RESO"
    - Activer SMB 2 et large MTU
    - Prendre en charge les fichiers hors ligne Windows
    - Activer NFS
    Dossiers partagés, partition "R" : données partagées avec Windows (Volume 1)

    Etape 1 : sauvegarde
    J'effectue une sauvegarde complète du système "C" de "Port-Epernay" par l'outil de sauvegarde proposée par Windows 7.
    Je décide d'utiliser le NAS pour stocker cette sauvegarde, j'utilise le dossier "R/Sauvegardes_Systèmes".
    Pour les options de sauvegarde, je coche toutes les cases pour les fichiers de données (bibliothèques), la case "Systeme (C:)" et "Inclure une image système de lecteurs : Réservé au système, Systeme (C:)".
    Tout se passe correctement.

    Etape 2 : création du CD de récupération Windows
    Je créé un CD de récupération sur "Port-Epernay" par l'outil standard de Windows 7 : créer un disque de réparation système.
    Je me retrouve avec le fichier "bootmgr" et les dossiers "boot" et "sources" sur le CD.
    Tout se passe correctement.

    Etape 3 : copies des fichiers de sauvegarde
    Ayant parcouru quelques forum sur les problèmes de récupération, je copie le contenu du dossier de sauvegardes à plusieurs endroits :
    - à la racine du dossier "R" sur le NAS Synologie
    - à la racine de la partition "U" correspondant au disque externe USB
    - à la racine de la partition "R:\" sur mon PC2
    Je me retrouve donc avec 4 emplacements différents pour la même sauvegarde. A chaque emplacement, je me retrouve avec :
    - Le fichier "MediaID.bin"
    - Le dossier "WindowsImageBackup" (contenant le dossier "Port-Epernay")
    - Le dossier "PORT-EPERNAY"

    Etape 4 : redémarrage à partir du CD de récupération
    Je redémarre "Port-Epernay" avec le CD de récupération dans le lecteur DVD et "boot" sur ce dernier.
    Windows s'exécute correctement et me propose différentes opérations :
    - Réparation du démarrage
    - Restaurer le système
    - Récupération de l'image système
    - Diagnostic de mémoire Windows
    - Invite de commande

    Etape 5 : récupération de l'image système
    - Lorsque je choisis cette option, le programme m'indique que Windows ne peut pas trouver d'image système sur cet ordinateur. Ceci me semble correct car je n'ai pas sauvegardé sur un disque interne mais sur le disque externe USB.
    - J'annule donc l'opération et choisit "Sélectionner une image système". On me demande d'insérer le dernier DVD de sauvegarde si l'image est sur un DVD (ce que je n'ai pas) ou de cliquer sur "Avancé..." pour ajouter un emplacement réseau ou installer un pilote pour un périphérique de sauvegarde.
    C'est ici que tout ne va plus...

    Problèmes avec le réseau (NAS et PC2)
    - Lorsque j'essaie d'insérer une image système sur le réseau, on me demande un nom d'utilisateur et un mot de passe. J'utilise un utilisateur existant (que ce soit sur PC2 ou sur le NAS) et j'ai systématiquement l'erreur "0x800704CF" en m'indiquant que l'emplacement réseau ne peut être atteint. J'essaie pas différentes solutions et obtient toujours le même message.
    - par le nom du NAS
    - par le nom du mon PC2
    - par leurs adresses IP (\\192.168.0.xxx)
    - avec ou sans le nom de la partition contenant les sauvegardes, exemple : \\192.168.0.104 ou \\192.168.0.104\R

    Problème avec le disque externe USB
    Je ne vois pas comment ni où indiquer l'emplacement de ce disque.
    Lorsque je choisis l'option "Invite de commande", je teste toutes les lettres de l'alphabet pour vérifier si ce disque est associé à une lettre et je n'obtiens rien.
    Seuls, les disques internes de "Port-Epernay" sont accessibles ainsi que le CD-ROM interne.
    Il semblerait que les drivers USB ne soit pas actifs...
    Je me trompe ? Pourquoi le programme de restauration ne me propose-t-il pas directement la sauvegarde déposée sur ce disque ?

    Bref ! après ce "petit roman", je suis bloqué et incapable de restaurer Windows avec une sauvegarde typique Microsoft. Peut-être devrais-je utiliser un autre outil de sauvegarde ? Si c'est le cas merci de ne pas me proposer d'outils commerciaux (payants) et de ne rester qu'aux programmes "Open Source"...

    Merci de m'indiquer vos conseils pour débloquer cette situation en sachant que j'aimerai en priorité m'en sortir avec les outils de base proposées par Windows 7.
    Je ne peux pas utiliser un DVD pour récupérer mon système car il est trop volumineux.

    Merci d'avance.
    Jean-Marie

    Saturday, October 26, 2013 9:15 AM

All replies

  • Je continue mes tests...

    J'ai modifié le groupe de travail de mon PC2 et ai utilisé exactement le nom de domaine proposé par l'outil de restauration : MININT-MJRPRVO. Je me connecte avec un utilisateur existant sur PC2. J'ai indiqué des droits d'accès pour "Tout le monde" à "Lecture et exécution" + "Affichage du contenu du dossier" et "Lecture"

    ==> Même problème : erreur "0x800704CF"

    Je lance une invite de commande et effectue quelques tests de communication réseau :

    Ping localhost

    Tout OK

    Ping Portable-JM (le nom de mon PC2)

    ==> Erreur : la requête Ping n'a pas pu trouver l'hôte PORTABLE-JM. Vérifiez le nom et essayez de nouveau.

    Ping 192.168.0.104

    ==> Erreur : PING : échec de la transmission. Défaillance générale

    ipconfig /all

    Nom de l'hôte : minint-mjrprvo
    Suffixe DNS principal : <rien>
    Routage IP activé : NON
    Proxy WINS activé : NON

    Tout ceci ressemble à une carte réseau ne fonctionnant pas...
    Encore un problème de driver comme pour l'USB ?

    Saturday, October 26, 2013 11:48 AM
  • Bonjour Jean-Marie,

    Bienvenue sur les forums TechNet France et merci pour votre message.

    Vous utilisez la fonctionnalité de sauvegarde dans un environnement d'entreprise ou pas?

    Avez-vous installé toutes les mises à jour pour votre système?

    Quelle carte réseau utilisez-vous ? Pouvez-vous mettre à jour les pilotes pour elle ? 

    Merci de nous montrer une imprime d'écran avec l'erreur complète reçue et nous dire si que vous voyez dans l'observateur d'évènements.

    Cordialement,

    Dan


    Dan BAJENARU, MSFT Votez! Appel à la contribution
    TechNet Community Support. LE CONTENU EST FOURNI "TEL QUEL" SANS GARANTIE D'AUCUNE SORTE, EXPLICITE OU IMPLICITE.
    S'il vous plaît n'oubliez pas de "Marquer comme réponse" les réponses qui ont résolu votre problème. C'est une voie commune pour reconnaître ceux qui vous ont aidé, et rend plus facile pour les autres visiteurs de trouver plus tard la résolution.

    Monday, October 28, 2013 10:53 AM
  • Bonjour Dan

    Je vais tout d'abord répondre à tes questions...

    - J'effectue ces opérations dans un cadre privé (un ami qui n'est pas informaticien et qui est "un peu" perdu avec toutes ces opérations)

    - J'ai effectué toutes les mises à jour de tous les drivers du matériel à réinstaller : carte mère, carte réseau, USB, SATA, et tout le tralala... J'ai utilisé pour cela le programme "MaConfig_win.exe" : détection automatique de drivers et propositions des mises à jours (Tous les drivers.com).

    - J'ai effectué toutes les mises à jour des softs : Windows, Java, Antivirus, etc...

    - Ma carte réseau : Realtek PCIe GBE Family Controller. Fournisseur du pilote (Realtek), date du pilote (27/08/2013), version du pilote (7.75.827.2013). La mise à jour de ce driver m'affiche "Le meilleur pilote pour votre périphérique est déjà installé".

    Je ne peux pas aujourd'hui vous donner les copies écran car ne suis plus près du PC, n'ai plus en place le disque de réinstallation sous la main, ...

    Par contre, j'ai de mon côté avancé. Je me suis rendu compte que les périphériques USB ne sont pas reconnus lorsque je démarre le PC avec le CD de restauration uniquement sur 2 prises, la troisième étant reconnue. Je m'en suis aperçu en débranchant ma souris et en branchant le disque dur USB à sa place.
    D'après les couleurs des prises, il semblerait que les 2 prises bleues (USB 3 il me semble) ne fonctionnent pas, alors que la prise noire (USB 2) fonctionne. Ceci s'est avéré exacte lorsque j'ai essayé de faire fonctionner ma souris sur une des prises bleues : souris non reconnue également.

    Je suis arrivé à la conclusion suivante : le CD de restauration ne sait pas faire fonctionner les sorties USB 3 avec les bons drivers alors que Windows lui-même sait le faire. Il y a donc un problème lors de la création du CD de restauration qui devrait (et ce n'est certainement pas le cas) copier les drivers du matériel sur le CD de façon à reconnaître le matériel au moment de la restauration avec le CD.

    Je me trompe ?

    Pour m'en sortir, j'ai donc utilisé la prise USB2 pour :

    1) Brancher une clé USB bootable avec le nouveau driver de mon disque SSD, booter sur ce dernier et flasher sa ROM (perte de données de mon SSD au moment du flash, donc de toutes mes données perso et de Windows).

    2) Brancher le disque dur externe contenant la sauvegarde, booter sur le CD de restauration et récupérer les données à partir du disque dur externe sur le disque SSD.

    J'ai donc réussi à restaurer mon système Windows mais ceci ne me permet pas d'être satisfait du processus car il me reste 2 questions très importantes à mon sens :

    1) Pourquoi les sorties USB 3 ne sont pas reconnues avec le CD de restauration alors qu'ils le sont avec Windows ? Le CD de restauration utilise-t-il des drivers "standards" ou prends-t-il en compte ceux installés sur la machine au moment de la constitution du CD de récupération système ?

    2) Pourquoi ne suis-je pas arrivé à me connecter sur mon deuxième PC sous Windows, ni sur mon NAS Synologie tous les deux connectés au réseau 1Gb/s filaire sur ma Freebox REVOLUTION ? Le driver de la carte réseau est-il en cause ? Si oui, est-ce le même type de problème qu'avec les drivers USB 3 ?

    La maîtrise des processus de sauvegarde et de restauration sont absolument indispensables pour moi et pour l'instant, c'est encore le brouillard.

    Quelqu'un pourrait-il me donner plus de renseignement sur ces deux problèmes, voir me donner des explications ?

    Si le problème vient des drivers"standards"  présents sur le CD de restauration (et pour l'instant ce n'est qu'une supposition), comment obliger Windows à prendre en compte ceux installés sur le disque système au moment de la constitution du CD de restauration ?

    Merci d'avance.
    Jean-Marie

    Monday, October 28, 2013 12:08 PM
  • Bonjour,

    Merci pour ces informations.

    Je comprends que dans votre cas, plusieurs problèmes possibles se posent…

    1. ''Pourquoi les sorties USB 3 ne sont pas reconnues avec le CD de restauration alors qu'ils le sont avec Windows ? Le CD de restauration utilise-t-il des drivers "standards" ou prends-t-il en compte ceux installés sur la machine au moment de la constitution du CD de récupération système ?’’

    Je pense à un souci matériel.

    Les drivers utilisés sont celles installés au moment de la création du CD de récupération.

    1. ''Pourquoi ne suis-je pas arrivé à me connecter sur mon deuxième PC sous Windows, ni sur mon NAS Synologie tous les deux connectés au réseau 1Gb/s filaire sur ma Freebox REVOLUTION ? Le driver de la carte réseau est-il en cause ? Si oui, est-ce le même type de problème qu'avec les drivers USB 3 ?’’

    Problème de connectivité ou de la configuration du NAS Synologie – à revérifier.

    Vous pouvez essayer de désinstaller le driver fourni par Realtek et installer ceux de Microsoft.

    Veuillez noter que vous pouvez poser aussi cette question sur les forums Microsoft Answers, ou vous pourriez recevoir plusieurs réponses : Microsoft Answers : Windows 7, Réparation et récuperation.

    Vous ne pouvez pas forcer Windows à prendre en compte les pilotes installés, ceci est faite par défaut.

    Quel est l’antivirus utilisé ? Pouvez-vous essayer de le rendre inactif au moment de la récupération ?

    Pouvez-vous nous fournir les sources dont vous parlez dans l’étape 3 : copies des fichiers de sauvegarde ?  Je ne pense pas que le scénario de récupérer Windows à partir d’un dossier copié depuis l’endroit de sauvegarde initial, faite par l’outil de sauvegarde Windows, est indiqué.

    Cordialement,
    Dan


    Dan BAJENARU, MSFT Votez! Appel à la contribution
    TechNet Community Support. LE CONTENU EST FOURNI "TEL QUEL" SANS GARANTIE D'AUCUNE SORTE, EXPLICITE OU IMPLICITE.
    S'il vous plaît n'oubliez pas de "Marquer comme réponse" les réponses qui ont résolu votre problème. C'est une voie commune pour reconnaître ceux qui vous ont aidé, et rend plus facile pour les autres visiteurs de trouver plus tard la résolution.

    Tuesday, October 29, 2013 8:45 AM
  • Bonjour Dan

    Merci encore pour la rapidité et qualité de ta réponse.
    Voici mes remarques suite à ta réaction...

    Prises USB3

    Tu penses plutôt à un problème matériel... Pourquoi pas mais...
    Le matériel ne change pas entre un boot Windows 7 installé sur un disque dur et un boot sur le CD de restauration. Dans un cas, le matériel est reconnu, et dans l'autre il ne fonctionne pas.
    Les seules modifications apportées dans ces deux types de redémarrage sont l'utilisations de logiciels (drivers) éventuellement différents.
    Je suis d'accord sur le fait qu'il puisse y avoir un problème matériel mais dans ce cas, les logiciels et drivers exécutés pas Windows lors du boot sur le disque dur permet de solutionner le problème matériel alors que le boot sur le CD ne le fait pas.
    Il y a pour moi forcément une différente logicielle et non pas matérielle sauf si le BIOS de ma machine effectue des modifications de reconnaissance matérielle si je choisis un boot disque ou CD. Ceci me parait vraiment invraisemblable car les 2 périphériques sont gérés par SATA interne et je ne vois vraiment pas la logique de tout ceci...

    Prise réseau Ethernet

    L'analyse de la problématique réseau ressemble aussi à celle de l'USB mais avec un peu de recul, je m'explique...
    Lorsque le logiciel de récupération me demande de récupérer une sauvegarde à partir du réseau (je clique sur le bouton "Avancé..."), il affiche pendant quelques secondes une fenêtre indiquant une connexion réseau. Pendant cette période, je n'ai pas d'erreur. J'imagine donc que la connexion réseau a fonctionné (je n'en suis pas certain bien entendu), donc que ma carte réseau et les drivers ont bien fait leur travail...
    A la fin de cette opération (qui dure quelques secondes), j'obtiens la fenêtre me demandant d'entrer l'adresse de la machine sur laquelle se connecter et j'obtiens donc l'erreur "0x800704CF". Cette erreur apparaît dans tous les cas, que ce soit avec le NAS Synologie et l'autre PC sous Windows 7, tous les deux connectés au modem/routeur de la même façon, et possédant une adresse IP interne en 198.168.0.xxx.
    Les résultats des instructions "Ping" et "ipconfig" me poussent quand même à croire à un problème sur le PC à restaurer et non pas sur la configuration des machines cibles sur lesquelles j'essaie de me connecter.

    Ta remarque sur l'utilisation du driver Microsoft à la place de Realtek est en effet une bonne idée mais je reviens à ma remarque logicielle entre Windows 7 sur disque et le CD de récupération. Pourquoi ce driver Realtek fonctionnerait-t-il avec un Windows 7 "standard" et pas avec le CD de récupération ?

    Copies des sauvegardes

    J'ai effectué dans mes premiers tests une copie des sauvegardes à différents endroits. Ces copies ont été effectuées par Copier/Coller à travers le navigateur Windows. Je ne sais pas en effet si une sauvegarde effectuée dans un dossier (ou à la racine d'une partition) peut se copier ailleurs et être récupérée...
    Avant d'effectuer mes autres essais, j'ai mis à jour tous les drivers du matériel du PC et ai effectué une autre sauvegarde mais cette foi-ci sur le disque dur externe USB (et non pas dans un dossier sur le NAS). Lorsque j'ai récupéré la sauvegarde, j'ai utilisé ce disque dur externe et n'ai donc pas utilisé des fichiers "copiés".

    Vous avez peut-être l'impression d'un "pinaillage" de ma part... Pour moi ce n'est que des questions logiques de compréhension pour maîtriser un processus.

    Pour moi, à ce stade d'analyse, il y a un problème de "compatibilité" entre les logiciels présents sur le CD de restauration et le matériel du PC portable et forcément une différence entre les drivers exécutés par un boot CD et un boot "disque dur". Je suis prêt bien entendu à avoir d'autres explications, changer ma vision des choses et me remettre en question.

    Si vous pensez que je dois inscrire ces questions dans un autre forum je ne vois pas d'inconvénient.
    Merci d'avance.
    Jean-Marie


    Tuesday, October 29, 2013 11:08 AM
  • Bonjour,

    Je suis intéressé par la réponse à ce PB, car j'ai exactement le même problème, lors d'un test professionnel pour valider la fonction (ce que je ne peux pas faire donc...) :

    Toutes les opérations ont été faites à la suite pour test:

    - Sauvegarde sur un disque branché sur port USB, création CD de récupération, copies des fichiers de sauvegardes du disque USB vers le HDD d'un 2ème PC en réseau, redémarrage à partir CD récup, récupération image système : réseau : erreur 0x800704CF ; HDD USB : pas d'accès possible.

    Impossibilité donc de récupérer l'image système ailleurs que sur une partition du même HDD que le disque C: sauvegardé.

    A+

    jules.legorand@laposte.net

    Saturday, January 04, 2014 8:26 PM
  • PS :

    Pour Info : "Je ne pense pas que le scénario de récupérer Windows à partir d’un dossier copié depuis l’endroit de sauvegarde initial, faite par l’outil de sauvegarde Windows, est indiqué."

    Si !

    J'ai fait le test en recopiant la sauvegarde initiale (dossier WindowsImageBackup du disque externe) sur une partition D (sur même HDD que C: (partition sauvegardée)) et j'ai pu écraser l'ancienne C: par la récupération, qui fonctionne...

    Saturday, January 04, 2014 9:07 PM
  • Il semblerait que les drivers USB3 ne soient pas intégrés au CD de Récupération Windows 7 (En tout cas dans cette version W7 : SP1 seul, sans autres maj).

    Ceci est vérifié par le test :Si je branche le disque dur sur une prise USB1 ou USB2, la sauvegarde est bien vue et on peut récupérer.

    L'intégration des drivers USB3 par les fonctions prévues (AVANCé, Installation de Pilote, ..) prend bien les drivers mais plante en fin d'installation de ceux-ci et ils ne sont pas actifs.

    Il faudrait tester d'intégrer les drivers soi-même dans l'image du CD par les outils adéquats.

    Voir : http://www.forum-des-portables-asus.fr/www/threads/n56vz-cr%C3%A9ation-restauration-image-syst%C3%A8me-sur-depuis-disque-dur-externe-usb3.9688/


    Saturday, January 04, 2014 9:49 PM
  • Est-ce que Microsoft pourrait confirmer ou infirmer que les drivers USB3 se trouvent sur le CD/DVD de récupération de Windows 7 dans un environnement Windows 7 SP1 sans les maj suivantes.

    D'avance merci.

    Monday, January 06, 2014 12:00 PM
  • Bonjour

    Je reviens un peu dans ce post...

    Je suis quand même étonné (déçu) de voir à quel point une opération aussi importante que la sauvegarde système ne soit pas aussi bien aboutie qu'il le faudrait.

    Faire une sauvegarde système c'est bien, mais proposer de faire un CD qui sera par la suite incapable de récupéré la sauvegarde effectuée sur un support externe... C'est quand même "fort de café" non ?

    D'autant plus que l'utilisation d'un support externe me semble "LA" solution la plus sécurisée. Ne pas avoir les sauvegardes sur le même support que les données sauvegardées n'est-elle pas une règle essentielle ? L'utilisation des NAS (en réseau) et des disques durs USB (version 3 maintenant) n'est-il pas maintenant rentré dans les mœurs et habitudes de chacun (sous condition de s'y connaître un minimum en informatique j'en conviens !)

    Faire un CD de "restauration" avec des drivers génériques ? Oui sous condition que les matériels les acceptent et ne bloquent pas les périphériques raccordés. Ceci ne semble pas forcément le cas pour tout le matériel... Faire un CD de "restauration" avec les drivers actuellement présents sur le PC sauvegardé serait quand même utile non ? Microsoft ne propose même pas cette solution lors de la constitution du CD...

    Tout ceci manque de sérieux d'autant plus que rien n'indique à l'utilisateur après sa sauvegarde et la création de son CD qu'il ne pourra pas récupérer ses sauvegardes...

    Un "coup de gueule" de ma part en effet, il y a du "laisser-aller" chez Microsoft.

    Monday, January 06, 2014 1:40 PM
  • ATTENTION !!!

    Faire "le disque de réparation système" lorsque windows vous le propose automatiquement à la fin du processus de création de l'image système sur un disque dur externe.

    C'est le seul moyen que connait windows pour embarquer sur un cd de BOOT les pilotes nécessaires au disque dur externe.

    Si vous annuler et que vous créer le disque de réparation système plus tard, vous ne pourrez jamais accéder à votre disque dur externe.

    Wednesday, June 04, 2014 9:28 PM