none
RMS Scheduled Task GPO

    Question

  • I want to enable the RMS Scheduled task via GPO.  I created a schedule task via Computer GPO > Preferences > Control Panel Settings > Scheduled Tasks:

    Run Only When User is Logged On (Run With Highest Priveleges)

    Action: Start A Program > C:\Windows\System32\schtasks.exe (With Arguments:) /Change /TN "\Microsoft\Windows\Active Directory Rights Management Services Client\AD RMS Rights Policy Template Management (Automated)" /ENABLE

    The task is created on the target PC, but there is an error:

    "The operation being requested was not performed because the user has not logged onto the network. The specified service does not exist."

    Where am I going wrong? Guessing it is something with the Security Options...

    Tuesday, September 24, 2013 5:12 PM

Answers

  • I opened a ticket with MS Support. Here was the solution:

    •          Copy the following script to a text file and save it with a .vbs extension. (I put it in Netlogon share)

    Option Explicit
    Dim WshShell
    Set WshShell = WScript.CreateObject("WScript.Shell")
    WshShell.Run "schtasks /Change /TN ""Microsoft\Windows\Active Directory Rights Management Services Client\AD RMS Rights Policy Template Management (Automated)"" /ENABLE"        

    •     Edit the concerned Group Policy and open the Startup option.
    •     Click on the ‘Show files’ button and copy the vb script file to this location.
    •          Click on the ‘Add’ button and browse the script file.
    •          Click Ok and Apply the settings.
    •          Update the GPO and restart a client computer which is part of this Group Policy and now the Scheduled Task should be enabled.
    • Marked as answer by IT2B Monday, September 30, 2013 2:25 PM
    Monday, September 30, 2013 2:25 PM

All replies

  • I opened a ticket with MS Support. Here was the solution:

    •          Copy the following script to a text file and save it with a .vbs extension. (I put it in Netlogon share)

    Option Explicit
    Dim WshShell
    Set WshShell = WScript.CreateObject("WScript.Shell")
    WshShell.Run "schtasks /Change /TN ""Microsoft\Windows\Active Directory Rights Management Services Client\AD RMS Rights Policy Template Management (Automated)"" /ENABLE"        

    •     Edit the concerned Group Policy and open the Startup option.
    •     Click on the ‘Show files’ button and copy the vb script file to this location.
    •          Click on the ‘Add’ button and browse the script file.
    •          Click Ok and Apply the settings.
    •          Update the GPO and restart a client computer which is part of this Group Policy and now the Scheduled Task should be enabled.
    • Marked as answer by IT2B Monday, September 30, 2013 2:25 PM
    Monday, September 30, 2013 2:25 PM
  • Hi.

    Rather using this option, I strongly recommend using new RMS 2.1 Template propagation functionality. this does not need this Schedule task anymore.

    More info Here:

    http://blogs.technet.com/b/rms/archive/2013/06/06/office-2013-ad-rms-client-2-x-and-template-distribution.aspx

    Cristian Mora (Synergy Advisors)

    www.synergyadvisors.biz

    Tuesday, October 29, 2013 9:04 AM