none
mdt 2010 - esx 4 vm's - rediculously slow

    Question

  • Hello,

    trying to add support for esx 4 virtual machines... vm's are using the e1000 nic so no issues there, also, from a 2008 R2 vm and grabbed and added all the drivers from 'program files\vmware\vmware tools\drivers' and 'program files\common files\vmware\drivers' to the workbench... copied them to folder used for my winPE profile so that the drivers get injected into PE.

    thats it, haven't tried anything but 2k8 r2 so far, and no go. Tried to use an existing deploy task sequence with an existing custom wim I have and no go... ran for many hours and I just killed it... now, to eliminate 'other stuff' going on in my task sequences, I just started a default 'standard server task sequence' to try to run an install of 2k8r2 from original source and it is currently at 54% 'expanding windows files' after about 4 hours! On atual server hardware, my 2k8r2 custom wim's deploy in 25 minutes, including a couple application installs in that task sequence.

    So this is obviously a VM thing...  Based on what I've described, what is my current issue? More generally, what do I need to know to successfully add support for deploying to ESX 4 vm's?
    Tuesday, February 09, 2010 7:10 PM

Answers

  • Issue was on ESX host... changed nic to auto negotiate and that fixed it. It was negotiating to 100Mbs half duplex for some reason, now it is negotiating to 100Mbs Full duplex... problem solved. Back to testing MDT on the vm's now.
    • Marked as answer by c0pe Friday, February 12, 2010 5:26 PM
    Friday, February 12, 2010 5:26 PM

All replies

  • try setting it up as an IDE drive and leaving out the VMWare drivers for now.. if you use an IDE and e1000 nic theres no need for the VMSCSI drivers or video / base system device drivers that folder includes, they might be causing an issue?
    -Dustin
    Tuesday, February 09, 2010 7:28 PM
  • I had the same problem with all my Windows 2008 R2 and 2003 images, and the only way I found is to remove all the drivers in the workbench (Out of the Box). They all works fine now !

    Bob
    Wednesday, February 10, 2010 5:16 PM
  • thanks for the suggestion Dustin. I may do that to narrow down what the issue is but I need to support the virtual scsi devices and the vmx nics as well. I could see where the scsi drivers could be causing an issue but I had not thought of the video drivers... is that also possible?

    thanks again.
    Thursday, February 11, 2010 4:26 PM
  • thanks for the reply Bob... thats interesting... did you remove all the drivers and then put them back? or just remove them?
    Thursday, February 11, 2010 4:27 PM
  • thanks for the suggestion Dustin. I may do that to narrow down what the issue is but I need to support the virtual scsi devices and the vmx nics as well. I could see where the scsi drivers could be causing an issue but I had not thought of the video drivers... is that also possible?

    thanks again.
    video drivers are optional in WinPE, the only thing *necessary* for winpe is nic and harddisk controllers, i leave video drivers out for the sake of size personally.

    Try setting up an install of a vm workstation and seeing how it performs on that, it might be one of the settings on the VMs during configuration (number of nics/cpus/ram) that is causing some sort of odd slowness.

    -Dustin
    Friday, February 12, 2010 3:42 PM
  • I did a cd install of server 2008R2 on a vm which went fine, but working in the installed OS shows major performance issues trying to copy data from a remote physical server... considering the version of winPE with MDT 2010 is win7/2008r2, and it tries to run the install from the MDT network share, it's the same scenario. So I obviously have some vmware issue here unrelated to MDT.

    After I straighten that out, if I am still having issues using MDT with the vm, I'll start a new thread.

    thanks all for the suggestions.
    Friday, February 12, 2010 4:33 PM
  • Issue was on ESX host... changed nic to auto negotiate and that fixed it. It was negotiating to 100Mbs half duplex for some reason, now it is negotiating to 100Mbs Full duplex... problem solved. Back to testing MDT on the vm's now.
    • Marked as answer by c0pe Friday, February 12, 2010 5:26 PM
    Friday, February 12, 2010 5:26 PM