none
Yea Old ""SharePoint Server Publishing Infrastructure" in site collection features Issue

Answers

All replies

  • try to change the web application pool (where you want to enable publishing) to Central Administration v4 Pool. Restart the pool, then enable publishing on site-collection level, then on site-level, and switch back to the original dedicated application pool for this webapp (and again restart this dedicated web application pool).

    This trick was working before, it may work now too :)


    Regards, Stanisław Delost, NETPRIME. http://www.net-pro.net
    Thursday, October 27, 2011 7:16 AM
  • Thanks Stanislaw

    Can you give me some pointers where the web application pool is, i have not done this enough times to know where things are in the SP Admin menu system ?

    Thanks

    Thursday, October 27, 2011 7:25 AM
  • sure.

    Please go to Administrative Tools - IIS Manager

    Expand the ServerName tree (left window), expand Sites, click on your web application where you want to enable publishing and select Advanced Settings from the right Action Window. Now, change the application pool (click on your current application pool name and change it to Central Administration V4). Look at the picture below

    After you change the APP Pool, in the left-tree go to Application Pools section, select Central Administration V4 and restart it (use stop button, wait few seconds and start it). 

     

    After you deploy the publishing infrastructure, again do the same procedure to change the pool from Central ADministration v4 to your original one.


    Regards, Stanisław Delost, NETPRIME. http://www.net-pro.net
    Thursday, October 27, 2011 7:35 AM
  • ahh and another solution :) it may be more valid now in SPS2010: go to Central Administration, Security, Configure Service accounts (http://yourCAServer/_admin/FarmCredentialManagement.aspx) and select your application pool, then change the account to Farm Account with local administrator rights (same account that the Central Administration V4 and Timer Service runs with). Then restart IIS (may not be needed, but try if you can) and provision the Publishing Infrastructure. After succesfull provisioning, switch back to original pool account.
    Regards, Stanisław Delost, NETPRIME. http://www.net-pro.net
    Thursday, October 27, 2011 7:38 AM
  • Thanks for your time

    For can see the pools, the user showing is a windows admin, admin for sharepoint, admin for the farm, even an admin for SQL.

    My hammer approach is i know i would never be able to get security setup correctly for such a complex system as sharepoint and sql with my knowledge. Rather use the max. access person to get things working, trial then pay an expert to fix up the security / access.

    I tried the Pool hint above with no change in outcome. The phrase "After you deploy the publishing infrastructure" as i am currently only trying to activate the setting in the site collection features.

    Thursday, October 27, 2011 10:45 AM
  • I am going to close this and that you for your time.

    He is how i resolved it :(not sure if these steps were needed, but it is what i did)

    - repaired sharepoint
    - re-installed web apps
    - re-run Farm Wizard and created a fresh site of :80

    Then looked at the site collection features of

    http://abc-sp2010/sites/TopSite/_layouts/ManageFeatures.aspx?Scope=Site

    and all was OK !!

    However not OK on http://abc-sp2010:30000/_layouts/ManageFeatures.aspx?Scope=Site (admin)

    So from my point of view, the problem is most doco does not make it clear that the this should be done from for a site collection  off port 80, NOT off the admin portal.

    Regards

    • Marked as answer by Greg B Roberts Friday, October 28, 2011 12:45 AM
    Friday, October 28, 2011 12:44 AM