none
Windows 7 system reserved partition visible after sysprep

    Question

  • Hello,

    After running the sysprep and capture task and failing in winPE 3.0, I have the problem that after a reboot, the system reserved partition is suddenly visible and taking the drive letter D, thus moving the actual second partition to letter E.

    After this problem I am unable to sysprep and capture because it is giving me an error that it cannot create a wimfile. Probably it is doing a check on sufficient space, where the system reserved partition only has 20MB left.

    Any workaround for not lettering the system reserved partition appear after sysprep? It takes alot of time to recreate a reference computer because of this.

    ps. In my scenario I have 2 partitions.

    Thursday, December 23, 2010 9:46 AM

All replies

  • After sysprep and capture that virtual machine is considered used, and should never be brought up again. If you need to rebuild the image, revert to a previous snapshot and start again.

    As for mulitple partitions it's unfortunately a bad idea, especially for the reference image. It can be worked around, of course, but it requires customization and many hours testing...

    / Johan

    Thursday, December 23, 2010 1:35 PM
    Moderator
  • After sysprep and capture that virtual machine is considered used, and should never be brought up again. If you need to rebuild the image, revert to a previous snapshot and start again.

    As for mulitple partitions it's unfortunately a bad idea, especially for the reference image. It can be worked around, of course, but it requires customization and many hours testing...

    / Johan


    Hello Johan,

    First of all, it's a physical machine. Therefore snapshots are not an option, although it's a good idea.

    As for the multiple partitions, I am not planning to capture the 2nd partition. I only make 2 partitions just to have a standard partition size for C drive. In the image deployment TS, I configured the first partition as the size as in the image, and a second partition for 100% of remaining space (which is actually unused on the reference image).

    I just find it awkward that suddenly the system partition appears after sysprep. If it wasn't appearing, couldn't I simply remove  the newly made user and try again?

    Thursday, December 23, 2010 2:50 PM
  • I highly recommend using virtual machines (any platform) for reference image. First of all you get the best possible image (you can rule out hardware issues out of the picture), second you will save development time since you can use snapshots.

    There is no real point in having multiple partitions on the reference image, if needed they can be created at deployment time.

    The Build and Capture wizard was built with VM's in mind, so that you quickly can revert to a clean state (or a state in the middle of the task sequence, using the Suspend feature of the task sequence), and then rebuild/continue

    / Johan

    Thursday, December 23, 2010 3:08 PM
    Moderator
  • I had the same problem as the capture wizard failed for a random reason as it often does. A restart of the MDT server seemed to fix it.

    However afterwards when trying to capture again I was running into the error saying that there was insufficient space on the drive.

    I saw that the system reserved partition was now visible and using drive D so thought that might be why.

     

    To fix it:

    Go to Start> Right-click computer and choose Manage (accept any UAC prompts which may appear) > Choose "Disk Management" on the left and right click on the partition labeled "System Reserved" and choose "Change Drive Letter and Paths..."

    In the dialogue which appears click a drive letter and select "Remove" (there will normally be only one) until no drive letters remain.

    Press OK and close Disk Management.

     

    The capture wizard should now complete successfully (well unless it fails with a different error!)

    Hope this helps

    Robin


    Robin Wilson
    • Proposed as answer by robinwilson16 Wednesday, December 29, 2010 1:17 PM
    Wednesday, December 29, 2010 1:17 PM