none
Windows server 2012 R2 Slow RDP

    Question

  • Hi 

    I have server 2012 R2 Datacenter installed on HP Proliant 380 G8. All drivers and firmwares are updated and confirmed by HP. The machine is quite powerful with hundreds of gigs of RAM. 

    When I RDP into the machine, The screen hangs on "welcome" screen for a good 10 seconds. Same hardware with server 2012 Datacenter is much faster. It is also fast with 2008 R2. 

    I deployed 4 servers so far and all have the same issue. 

    Has any one experienced this slowness before?

    I appreciate any help.

    Thanks

    Monday, March 10, 2014 1:07 PM

Answers

  • Hi Atif,

    Thank you for your posting in Windows Server Forum.

    First of all please try to provide TP’s answer. In addition, what’s the version of client OS and RDC? If you are using Windows 7 then use RDP 8.1 for better performance. Apart from this, try to DisableTaskOffload in the IP-parameters. For more information, kindly go through beneath article.
    Performance Tuning Windows 2012: Network Subsystem–Part 1

    Also try to configure below setting, might helpful for your case.
    On the server:
    Computer Config > Windows Settings > Administrative Templates > Windows Components > Remote Desktop Services > Remote Desktop Session Host > Connections > Select RDP transport protocol = Use only TCP

    On the client:
    Computer Config > Windows Settings > Admin Templates > Windows Components > Remote Desktop Services > Remote Desktop Connection Client > Turn off UDP on Client = Enabled

    Hope it helps! 

    Thanks,
    Dharmesh
    Wednesday, March 12, 2014 3:44 AM

All replies

  • This forum is utterly useless. 

    I posted this question on spiceworks forum and have got tons of responses thus far.

    Monday, March 10, 2014 4:54 PM
  • Hi,

    1. If you log on to the physical console using the same domain account, does it hang at Welcome or log on instantly?

    2. Have you tried temporarily moving the server and the user into a different OU with no group polices, running gpupdate /force on the server, then test logging on?

    3. Have you looked at a netmon/wireshark trace of the traffic during log on?

    4. Does the user account have a roaming profile configured or local?

    5. Anything else significant happening during log on like a logon script, printer mapping, etc?

    -TP

    Monday, March 10, 2014 8:21 PM
  • Hi Atif,

    Thank you for your posting in Windows Server Forum.

    First of all please try to provide TP’s answer. In addition, what’s the version of client OS and RDC? If you are using Windows 7 then use RDP 8.1 for better performance. Apart from this, try to DisableTaskOffload in the IP-parameters. For more information, kindly go through beneath article.
    Performance Tuning Windows 2012: Network Subsystem–Part 1

    Also try to configure below setting, might helpful for your case.
    On the server:
    Computer Config > Windows Settings > Administrative Templates > Windows Components > Remote Desktop Services > Remote Desktop Session Host > Connections > Select RDP transport protocol = Use only TCP

    On the client:
    Computer Config > Windows Settings > Admin Templates > Windows Components > Remote Desktop Services > Remote Desktop Connection Client > Turn off UDP on Client = Enabled

    Hope it helps! 

    Thanks,
    Dharmesh
    Wednesday, March 12, 2014 3:44 AM