none
varchar(max) 2 GB ??????

    Question

  • I have various shapes in WKT, going into a varchar(max) column, but for some reason they are being truncated after about 1400 geometric nodes. It affects maybe 60+ records., out of a total of 12,000 imported. 

    The entire txt import file itself was only 68MB (all 12,000)!

    How on earth have I reached a 2gb txt max in a varchar(max) for 1 record/column. I tried adding text to the affected columns and got a truncation warning, so i know the problem lies w/in the db engine/schema (not an import issue). 

    The craziest part is I get no truncation warning to the Destination Column, but it's definitely 'overloaded'.

    Any Clues, 

    thx

    Spatio

    Monday, November 04, 2013 4:53 AM

Answers

  • We are not sure of your data here. But, my first thought would be that your file will have lots of unnecessary characters like SPACES, TABS etc which also would count on the size and characters in SQLServer.

    Could you please check it out?


    Please use Marked as Answer if my post solved your problem and use Vote As Helpful if a post was useful.

    Monday, November 04, 2013 5:02 AM

All replies