none
exchnage 2010 and exchnage 2013 coexistance- URL's

    Question

  • How should i configure Outlook Anywere URL's in exc2010 -2013 coxistance?

    should i put the same url's on both exchnage servers?

    i have a situation where dns record mail.contoso.com is poniting to ex2010 CAS NLB, and all the clients are still on the ex2010 server.  i also have two exch2013 cas in round robin configuratiog which dns name is mail2k13.contoso.com.

    Shoud i change DNS record mail.contoso.com to point to ex2013 cas servers or should i do it after migration?

    Friday, August 16, 2013 6:47 PM

Answers

  • You should point your OA URLs to Exchange 2013. If all is configured correctly, it should be able to locate client's mailbox on both E2010 or E2013 Mailbox server. YOu should not have same URLs assigned to both Exchange servers at the same time.

    Please mark as helpful if you find my contribution useful or as an answer if it does answer your question. That will encourage me - and others - to take time out to help you. Thank you! Damir

    Sunday, August 18, 2013 9:02 PM
  • Hi Mari_o,

    As far as I understand, Exchange 2013 will proxy Outlook Anywhere requests to the version of Outlook Anywhere that corresponds to the version of Exchange Server the mailbox is on, and we should make OA url point to CAS2013 no matter where the Mailbox servers reside on. Besides, we must make sure that NTLM authentication at the IIS level is enabled for all. Here are the reference you would like to do:

    1.Change RPCClientAccessServer Attribute to be FQDN of Exchange 2010 Mailbox Databases (repeat for all Databases on Exchange 2010)

    Set-MailboxDatabase –Identity “<Database Name>” –RPCClientAccessServer “<cas2010>.<internaldomain>.local”

    2.Change SCP Object for Exchange 2010 to Point to Exchange 2013 (repeat for all Exchange 2010 CAS Servers), set this to whatever your internal AutoDiscover namespace is.

    Set-ClientAccessServer –Identity “servername” –AutoDiscoverServiceInternalUrl https://outlook.domain.com/autodiscover/autodiscover.xml

    3.Set the authentication method correctly:

    Set-OutlookAnywhere -Identity CAS2010\rpc* -InternalClientAuthenticationMethod Ntlm -ExternalHostname mail.contoso.com -ExternalClientAuthenticationMethod Basic -ExternalClientsRequireSsl $True -IISAuthenticationMethods Basic,Ntlm

    Set-OutlookAnywhere -Identity CAS2013\rpc* -InternalClientAuthenticationMethod Ntlm -ExternalHostname mail.contoso.com -ExternalClientAuthenticationMethod Ntlm -ExternalClientsRequireSsl $True -IISAuthenticationMethods Basic,Ntlm,Negotiate

    Regards,

    Rebecca

    Monday, August 19, 2013 11:36 AM
  • Hi Mario,

    I might not make myself clear. If you have NLB in your 2010 environment, the command should be(please repeat for all Databases on Exchange 2010):

    Set-MailboxDatabase –Identity "<Database Name>" –RPCClientAccessServer "mail.constoso.com" 

    Then please try the following steps I mentioned above.

    Tell me if you need more assistance.

    Regards,

    Rebecca






    Friday, August 23, 2013 7:14 AM

All replies

  • You should point your OA URLs to Exchange 2013. If all is configured correctly, it should be able to locate client's mailbox on both E2010 or E2013 Mailbox server. YOu should not have same URLs assigned to both Exchange servers at the same time.

    Please mark as helpful if you find my contribution useful or as an answer if it does answer your question. That will encourage me - and others - to take time out to help you. Thank you! Damir

    Sunday, August 18, 2013 9:02 PM
  • Hi Mari_o,

    As far as I understand, Exchange 2013 will proxy Outlook Anywhere requests to the version of Outlook Anywhere that corresponds to the version of Exchange Server the mailbox is on, and we should make OA url point to CAS2013 no matter where the Mailbox servers reside on. Besides, we must make sure that NTLM authentication at the IIS level is enabled for all. Here are the reference you would like to do:

    1.Change RPCClientAccessServer Attribute to be FQDN of Exchange 2010 Mailbox Databases (repeat for all Databases on Exchange 2010)

    Set-MailboxDatabase –Identity “<Database Name>” –RPCClientAccessServer “<cas2010>.<internaldomain>.local”

    2.Change SCP Object for Exchange 2010 to Point to Exchange 2013 (repeat for all Exchange 2010 CAS Servers), set this to whatever your internal AutoDiscover namespace is.

    Set-ClientAccessServer –Identity “servername” –AutoDiscoverServiceInternalUrl https://outlook.domain.com/autodiscover/autodiscover.xml

    3.Set the authentication method correctly:

    Set-OutlookAnywhere -Identity CAS2010\rpc* -InternalClientAuthenticationMethod Ntlm -ExternalHostname mail.contoso.com -ExternalClientAuthenticationMethod Basic -ExternalClientsRequireSsl $True -IISAuthenticationMethods Basic,Ntlm

    Set-OutlookAnywhere -Identity CAS2013\rpc* -InternalClientAuthenticationMethod Ntlm -ExternalHostname mail.contoso.com -ExternalClientAuthenticationMethod Ntlm -ExternalClientsRequireSsl $True -IISAuthenticationMethods Basic,Ntlm,Negotiate

    Regards,

    Rebecca

    Monday, August 19, 2013 11:36 AM
  • thanks both of you.

    i have a load balancer, fqdn is mail.contoso.com (exchange2013 cas servers). should i set URL directories on cas2013 servers to Load Balancer fqdn or server fqdn?

    Wednesday, August 21, 2013 8:51 PM
  • Hi Mario,

    Please set URL directories on cas2013 servers to Load Balancer fqdn. More detail in: http://technet.microsoft.com/en-us/library/jj898588(v=exchg.150).aspx

    Regards,

    Rebecca

    Thursday, August 22, 2013 6:59 AM
  • Rebecca, let me just ask you about number 1;

    1.Change RPCClientAccessServer Attribute to be FQDN of Exchange 2010 Mailbox Databases (repeat for all Databases on Exchange 2010)

    Set-MailboxDatabase –Identity “<Database Name>” –RPCClientAccessServer “<cas2010>.<internaldomain>.local”

    my exch2010 cas array is also NLB address mail.contoso.com. i will point mail.constoso.com to exc2013 cas, but before that, i have to change FQDN of 2010 NLB, FQDN of 2010 cas array and than chnageRPCClientAccessServer Attribute of exch2010?

    Thursday, August 22, 2013 7:29 AM
  • Hi Mario,

    I might not make myself clear. If you have NLB in your 2010 environment, the command should be(please repeat for all Databases on Exchange 2010):

    Set-MailboxDatabase –Identity "<Database Name>" –RPCClientAccessServer "mail.constoso.com" 

    Then please try the following steps I mentioned above.

    Tell me if you need more assistance.

    Regards,

    Rebecca






    Friday, August 23, 2013 7:14 AM