none
svchost.exe em 100% - Problema do Sistema Operacional

    Question

  • Olá pessoal,

    Vocês acham que pode ser também algum problema do WinXP? Algum problema do sistema operacional?

    Eu já tentei de tudo, DEP, desativar os processos dentro do svchost.exe, anti-vírus diferente, anti-spyware, pagefile, arquivos temporários em diretório em diferente partição, etc...

    Não sei mais o que posso terntar.

    Se pode ser também algum erro do sistema operacional, irei reinstalar o Windows. O que acham?

    Obrigado

    Abraços

    Friday, December 01, 2006 1:22 AM

Answers

  • Olá Rodrigo,

    O serviço de atualizações automáticas do XP também utiliza o svchost.exe e tem sido comum este problema vinculado a ele.

    Tente o procedimento abaixo:

    1) Parar temporariamente o serviço de atualizações automáticas
    2) Renomear C:\windows\software distribution para C:\windows\software distribution.old
    3) Renomear C:\windows\windowsupdate.log para c:\windows\windowsupdate.log.old
    4) Reiniciar o serviço de atualizações automáticas.

    Boa sorte!

    Saturday, December 02, 2006 8:15 PM

All replies

  • Olá Rodrigo,

    O serviço de atualizações automáticas do XP também utiliza o svchost.exe e tem sido comum este problema vinculado a ele.

    Tente o procedimento abaixo:

    1) Parar temporariamente o serviço de atualizações automáticas
    2) Renomear C:\windows\software distribution para C:\windows\software distribution.old
    3) Renomear C:\windows\windowsupdate.log para c:\windows\windowsupdate.log.old
    4) Reiniciar o serviço de atualizações automáticas.

    Boa sorte!

    Saturday, December 02, 2006 8:15 PM
  • Olá Savio,

    Muito obrigado pela sua dica. Dentre todos os serviços que rodam no svchost.exe um dos poucos que eu não parei para teste foi este, de atualização automática. Mas infelizmente eu já vinha tentando resolver a um bom tempo, e como eu tinha uma imagem de instalação, acabei resolvendo do jeito mais fácil.

    Mas a dica que você me passou tem muito a ver com o meu erro, pois o erro acontecia sempre que eu me conectava á internet.

    Obrigado novamente.

    Um abraço

    Sunday, December 03, 2006 2:13 AM
  • Olá Rodrigo,

    Disponha!

    Um grande abraço!

    Sunday, December 03, 2006 12:05 PM
  • Savio,

     

    Sua solução resolveu meu problema, muito obrigado. Estava quase ligando para a microsoft para consiguir um hotfix.

    Monday, February 19, 2007 7:04 PM
  • Boas, estou com o mesmo problema, o pc da-me o erro de svchost.exe ....... memoria can´t read... etc... O que começou a acontecer quando fez a ultima actualização auto, desactivei as actualizações automáticas e agora mesmo estou a utiliza-lo e parece-me estar perfeito. Agora queria fazer o que dizem acima de mudar os nomes do windowsupdate.log e da pasta softwaredistribution mas não csg por estarem em uso do sistema operativo, ja fechei o processo svchost q é um dos que esta utilizando esses ficheiros mas o sistema bloqueia, como faço para resolver isto??? Intressante e a microsoft nao detectar este problema e na propria actualização vir incluido um Fix.

     

    Cumps

    Wednesday, February 21, 2007 7:45 PM
  • ola savio eu sou novo aqui mas tenho um problema com o svchost ao iniciar o pc com windxpsp2 dame um erro com a seguinte descricao " a intrucao no "0x7c928fea" fez referencia a memoria no "0x00000010" a memoria nao pode ser "written".. sera que me podes ajudar, nao sei como este problema me apareceu tudo estava bem. o meu mail sergiomarquess@sapo.pt... obrigado
    Sunday, February 25, 2007 6:19 PM
  • Srs,

     

     Tentei fazer segundo recomendação de como mudar os nomes do windowsupdate.log e da pasta softwaredistribution.

    Porém  mas não consigo, dá mensagem de sistema dizendo que estão em uso pelo sistema operacional, ja fechei o processo svchost q é um dos que esta utilizando esses ficheiros mas o sistema bloqueia, como faço para resolver isto???

     

    Desde já grato

    Tuesday, May 01, 2007 5:23 PM
  • Bom dia,

     

    Vocês não estão conseguindo renomear, pois o serviço de atualizações automáticas ainda está ativo. Vá até EXECUTAR, digite SERVICES.MSC e pressione ENTER. Procure na lista de serviços, o serviço "Atualizações automáticas", clique com o botão direito e escolha PARAR. Renomeie o diretório e repita o processo, só que desta vez escolhendo INICIAR.

     

    Espero ter ajudado.

    Friday, May 04, 2007 9:51 AM
  • Parabens! Problema resolvido.
    Tuesday, May 08, 2007 7:51 PM
  • Muito bom Eder,

     

    Fiz conforme voce falou e deu tudo certo, espero que resolva o problema definitivamente.

     

    Grato

     

     

    RWagner

    Wednesday, May 09, 2007 11:46 PM
  • Srs.

    tambem tinha esse problema, e resolvi!!! obrigado pelas dicas.

    Thursday, May 10, 2007 2:25 PM
  •  

      OLa , Savio ,espero ter resolvido meu problema,,,e  te agradeço...mas no meu C:windows\windowsupdate       falta o ...log...e por sinal são dois (blocos de notas)..preferi desativar o update  ....te achei objetivo e consiso,,mais uma vez obrigado

    Friday, May 11, 2007 5:55 PM
  • Olá Sávio

     

    Tenho o mesmo problema: svchost comendo 99% da memória.

    Só que meu Windows (XP Professional) não apresenta a pasta c;\windows\windowsupdate (com log ou sem log).

     

    Como devo agir?

     

     

    Monday, May 14, 2007 11:41 AM
  •  

       Como te coloquei antes ,tenho dos blocos de notas (windowsupdate)  botei um como log.old, pois nenhum dos dois era .log ..................

     Mesmo assim continua a aparecer um aviso do norton pedindo permissão para o Svchost.exe como se fosse um executavel de jogos em geral. ,, estou negando todas as vezes

     Procurei outros svchost,exe no PC, além do system.32 e do exe, do sp2,,,mas não encontrei nenhum ,.

     E agora as vezes quando logo o PC, aparece uma aviso de que houve um problema de registro do windows , mas que foi recuperado.

     

     obrigado

    Kramer

    .
    Monday, May 14, 2007 1:06 PM
  • Boa noite pessoal,

     

    É o seguinte, minha visão em relação à isto é que não adianta ficar adiando a instalação destas atualizações. Isso foi feito para garantir a segurança, confiabilidade e estabilidade do sistema. O ideal é deixar rodar até terminar, ou melhor, execute o windows update e baixe todas as atualizações do windows.

    De qualquer forma, Sávio, você talvez você não esteja encontrando o arquivo windowsupdate.log, porque ele pode estar oculto.

    Habilite nas configurações de pasta para exibir os arquivos ocultos e também os objetos ocultos do sistema.

     

    Att,

    Monday, May 14, 2007 10:17 PM
  • M. Worcman, Bom dia!

    Tudo bem?

     

    Favor executar o procedimento abaixo para que possamos analisar melhor:

    1 - Verificar qual o PID do SVCHOST.EXE que está em 100%.

    Como?

    Digitar taskmgr.exe no menu executar e escolher a opção 'EXIBIR' > 'Selecionar Colunas' e checar a opção 'Identificação do processo (PID)'.

    Ainda dentro do Gerenciado de Tarefas do Windows, escolher a opção 'Processos' e ordenar por CPU. Identificar qual o PID que está associado ao processo que está consumindo 100% da CPU.

     

    2 - Abrir o prompt do DOS e digitar 'tasklist /svc'

    3 - Verificar o PID identificado anteriormente e a descrição do serviço que está atrelado a ele. Exemplo: PID 1544 LMHosts...

     

    4 - Desta forma, você conseguirá identificar qual o serviço que está comprometendo o sistema para podermos analisar.

     

    Para saber mais sobre o SVCHOST.EXE ler o artigo abaixo:

    http://support.microsoft.com/default.aspx/kb/314056

     

    Abraço!

    Tuesday, May 15, 2007 1:37 PM
  • segui o procedimento seguido ai em cima, m. worcman, e descobri o erro.

    e agr km faço para o encontrar?kero resolver isto, tou fartinho d ter k reiniciar o pc e restaurar o sistema...

    cumprimentos[[]]

    Friday, May 18, 2007 10:11 PM
  • Savio...Meu computador ta dando um erro quando estou na internet...

    aparece mais ou menos assim

    Generic Host process for win32 services

     

    e eu não sei o que fazer pra arrumar issoo..

    queria uma ajuda sua...

    Tuesday, May 22, 2007 1:54 AM
  • Boa noite Senhores!

     

    Se não me engano as atualizações do windows também podem ser feitas após o comando de encerrar o windows (no meu caso, o XP Service Pack 2). Isso resolveria o problema? E se resolver, como devo proceder para configurá-lo como tal?

     

    Grato pela atenção!

     

    Sunday, May 27, 2007 12:07 AM
  • Problema resolvido pra mim também. É uma pena que demorei um pouco para encontrar este topico.
    Monday, June 04, 2007 7:25 PM
  • Ótimo!!! Ótimo!!!  Ótimo!!!

     

    Segui os passos indicados pelo Sávio para renomear a pasta C:\Windows\SoftwareDistribution e o arquivo WindowsUpdates.log.

    Na primeira tentativa não consegui, aí segui as instruções do Eder e tudo funcionou perfeitamente.

     

    No meu caso, o problema eram as atualizações automáticas, mesmo. Após esses procedimentos indicados pelo Sávio e pelo Eder, o computador voltou ao normal e as atualizações automáticas foram baixadas novamente, funcionando perfeitamente desta vez.

     

    Só uma observação importante!

    Vi alguns usuários dizendo que encontraram o WindowsUpdates sem o ".log".... e outro usuário disse que não encontrou.

    Primeira consideração: trata-se de um arquivo e não uma pasta.

    Segunda consideração: Às vezes, a extensão não aparece porque o Windows está com opção para não mostrar. Para arrumar isso, entre em Ferramentas >> Opções de Pasta >> Modo de Exibição >> DESMARQUE A OPÇÃO "Ocultar as extensões dos tipos de arquivos conhecidos".

     

    Por fim, estou muito grato pelas dicas!!!! Estava achando que era vírus ou algo que danificasse o sistema... Agora está tudo lindo!!! Big Smile

     

    Mais uma vez: Obrigado Sávio e Eder!!!

     

    Abs,

     

    Fernando Ortega

     

    Monday, June 04, 2007 11:20 PM
  • Olá M. Workman,

     

    Não sei se você já resolveu o problema, mas percebi um detalhe no seu texto.... Parece-me que você está procurando a "pasta" c:\windows\windowsupdate, mas na verdade esse é um ARQUIVO.... Se ainda não resolveu o problema, tente procurar na lista de arquivos pelo nome WINDOWSUPDATE.LOG.... Trata-se de um arquivo do Bloco de Notas. Obeserve que ele pode "não ter" a terminação .LOG. Nesse caso, o seu Windows não está mostrando a extensão (que é importante para este procedimento), e para resolver isso, acesse o menu: Ferramentas >> Opções de Pastas >> Modo de Exibição >> DESMARQUE A OPÇÃO Ocultar as extensões dos tipos de arquivo conhecidos.

     

    Importante! Não adianta renomear o arquivo para .OLD se vc não estiver vendo o .LOG....

     

    Retorne dizendo se funcionou e se o problema foi resolvido!

     

    Abs,

     

    Fernando Ortega

    Monday, June 04, 2007 11:39 PM
  • Faço minhas as palavras de Luiz Augusto Christofoletti

     

    ACHO que o problema foi resolvido aqui também... Até agora tá tudo bem... Passei três dias pesquisando e nada. Esse probleminha me tirando do sério. Pensava que fosse um vírus...

     

    Agradeço muito a todos que postaram ai e puderam ajudar a todos que tinham esse problema...

     

    Abraços,

     

    Davi Jamelli

    Tuesday, June 05, 2007 12:17 AM
  • Boas ....

    Eu tambem tenho um problema com o svchost.exe que me utiliza 100 a 99 % do cpu

    Quando ligo o meu pc ele arranca normalmente mas quando abro uma aplicação e depois a encerro ele encrava ...

    Sera que se eu fizer os passos dados por Savio resolvo o meu problema?

    Obrigado e espero resposta rapida !

    Wednesday, June 06, 2007 5:31 PM
  • Olá Vinnny,

    Achei um artigo com o mesmo erro no 'guiadohardware' e foi sugerido realizar as duas atualizações abaixo para resolver (no Windows XP). Não tive tempo para testar .... mas vale a pena tentar.
    (KB894391)

    (KB921883)

    Abraço!
    Monday, June 11, 2007 4:48 PM
  •  

     

    Pessoal, to com o mesmo problema!!!

     a intrucao no "0x7c928fea" fez referencia a memoria no "0x00000010" a memoria nao pode ser "written"..

    Sendo que o meu sistema é o windows2003 server.

    O que posso fazer?

    me mande emails.

     

    lhflima@hotmail.com

     

     

    Muito Obrigado mesmo

    Thursday, June 14, 2007 1:44 PM
  • o problema surgia smp k iniciava o pc km a internet ja ligada.

    assim, dxliguei o modem e deixei d vir a internet por cerca de uma semana e mantive o meu novo av  a fazer scans (avg free).

    knd a semana terminou, xprimentei ligarme a net e so dpois ligar o pc.

    o erro deixou d dar. n sei exactament km foi eliminado, ja k o av n encontrou nada nos seus scans, mas o certo e k ja n tenho este problema enervante ha mais d dois meses...

    exprimentem a mm tecnica, n sei s sera eficaz, mas foi exactament dessa maneira k o svchost.exe deixou d m xatear.

    bem hajam,

    maliciux

     

    Thursday, June 14, 2007 8:56 PM
  • pessoal sou novo aki, to com um problema com o svchost.exe 100% ocupando, ai fiz o que i silvio falow, e apareceupid 664, audioserv, brower, cryptsvc, dhcp, dmserver,ersvc, eventsystem,fastuserswitching,helpsvc, iprip, lammanworkstation, netman,nla, rasman, schedule, seclogon, sens, sharedaccess, shellhwdetection, srservice,tapisrv,themes, trkwks,w32time,winmgmt,wscsvc,wzcsvc. e eu nao consigo entrar na net pois da conexao nula ou limitada, alguem pode me ajudar...
    Friday, August 03, 2007 3:52 PM
  • Olá Sabio

    Eu não sei se o problema que meu micro vem apresentando é o mesmo. De qualquer forma, peço sua ajuda. É o seguinte: depois de algum tempo que estou na internet ( o tempo varia muito), aparece uma janela com o erro:

    svchost.exe - Erro de aplicativo

    Exceção exceção de software desconhecida (0xc0000409) em 0x5bcba3c0

     

    As opções que tenho são Ok, Cancelar ou fecha. Qualquer uma dessas interrompe minha conexão e tenho que reiniciar o meu micro. Já fiz o procedimento que vc informa, mas quando eu reinicio minha máquina, eu vejo que apareceu outra pasta Software distribution (daí fico com duas, uma com .old e outra sem) e aparece tbm outro arquivo windowsupdate (sem log, sem nada, daí fico com dois, um com .log.old e outro sem).

     

    Vc poderia me ajudar?

     

    Abraços,

    Daniel Muñiz

     

    Sunday, October 21, 2007 2:49 PM
  • Savio

     

    Troquei o nome da pasta e o arquivo e diminui o consumo da CPU. Não reiniciei o computador, ativei o serviço e fiz esta instrução e o que encontrei é o explorer.exe consumindo a CPU. Estes processos estão relacionados?

    Se você tiver alguma dica agradeço.

    Wednesday, March 05, 2008 1:30 AM
  •  

     

    Excelente!!

     

    Problema resolvido!!!

     

    Thursday, September 25, 2008 1:40 PM
  • alguem podi me ajuda aqui eu fico pelos menos 24 min na net ai o discadorvip.exe fica 100% de uso da cpu
    ou tem vezes q o svchost.exe fica tbem com 100 % tbem ai nao sei o que eu faço alguem podi me ajuda
    obrigado!

    Microsoft Windows XP [versão 5.1.2600]
    (C) Copyright 1985-2001 Microsoft Corp.

    Nome da imagem            Identi Serviços
    ========================= ====== =============================================
    System Idle Process            0 N/A
    System                         4 N/A
    smss.exe                     396 N/A
    csrss.exe                    452 N/A
    winlogon.exe                 476 N/A
    services.exe                 520 Eventlog, PlugPlay
    lsass.exe                    532 PolicyAgent, ProtectedStorage, SamSs
    svchost.exe                  688 DcomLaunch, TermService
    svchost.exe                  756 RpcSs
    svchost.exe                  804 AudioSrv, BITS, Browser, CryptSvc, Dhcp,
                                     dmserver, ERSvc, EventSystem,
                                     FastUserSwitchingCompatibility, helpsvc,
                                     lanmanserver, lanmanworkstation, Netman,
                                     Nla, RasMan, Schedule, seclogon, SENS,
                                     SharedAccess, ShellHWDetection, srservice,
                                     TapiSrv, Themes, TrkWks, W32Time, winmgmt,
                                     wscsvc, WZCSVC
    svchost.exe                  864 Dnscache
    svchost.exe                  916 LmHosts, RemoteRegistry, SSDPSRV, WebClient
    aswUpdSv.exe                1012 aswUpdSv
    ashServ.exe                 1068 avast! Antivirus
    svchost.exe                 1604 stisvc
    ashMaiSv.exe                1824 avast! Mail Scanner
    ashWebSv.exe                1924 avast! Web Scanner
    alg.exe                      220 ALG
    explorer.exe                 240 N/A
    VTTimer.exe                 1984 N/A
    VTTrayp.exe                 1000 N/A
    SOUNDMAN.EXE                2064 N/A
    ashDisp.exe                 2076 N/A
    jusched.exe                 2096 N/A
    ZSSnp211.exe                2120 N/A
    Domino.exe                  2128 N/A
    ctfmon.exe                  2144 N/A
    TeaTimer.exe                2160 N/A
    baloonvip.exe               2176 N/A
    PropelAC.exe                2184 N/A
    msnmsgr.exe                 2512 N/A
    discadorvip.exe             2528 N/A
    MessengerDiscovery Live.e   2584 N/A
    firefox.exe                 3112 N/A
    usnsvc.exe                  3324 usnjsvc
    taskmgr.exe                 1036 N/A
    cmd.exe                     3320 N/A
    tasklist.exe                3996 N/A
    wmiprvse.exe                 444 N/A



    Sunday, November 23, 2008 3:58 AM
  • Atencao.

    Olá Rodrigo,

    O serviço de atualizações automáticas do XP também utiliza o svchost.exe e tem sido comum este problema vinculado a ele.

    Tente o procedimento abaixo:

    1) Parar temporariamente o serviço de atualizações automáticas
    2) Renomear C:\windows\software distribution para C:\windows\software distribution.old
    3) Renomear C:\windows\windowsupdate.log para c:\windows\windowsupdate.log.old
    4) Reiniciar o serviço de atualizações automáticas.

    Boa sorte!

     

    Ola Silvio eu fiz o procedimento certinho, renomeil pra .old mas e normal ele recriar a pasta sem o .old novamente ? pq aqui aconteceu isso.. aguardo a resposta...

    Sunday, April 05, 2009 11:56 PM
  • Opa Renan... blz?
    O arquivo é recriado sim quando o serviço de atualizações sobe novamente.
    O objetivo é limpar a base local e o arquivo de log para normalizar o cliente.

    Abs.
    Savio Vallochi http://www.activedirectory.com.br http://saviovallochi.spaces.live.com/
    Tuesday, April 07, 2009 1:45 PM
  • Savio,

    Cara nao adianto nada faz dias q to com esse problema ja tentei de tudo, tentei sua sugestao e nada hoje as 16h a svchost ativo 100% de novo, engracado que ela ativa 100% e dura entre 10 a 40 min assim depois para depois volta depois para e assim vai enchendo o meu saco, alem da sua sugestao ja tetei outras como renomear uma pasta chamada Catroot e catroot2 com o .old no final ja tentei outras baixando atualizacoes, ja tentei o fix_svchost.bat.. nada funciona tens alguma outra alternativa? meu sistema e SP2 sera q atualizando pra SP3 arruma ? da uma luz ai savio fico no aguardo..

    meu problema comeco quando ativei a xave do windows para poder usar o msn 8.5 ai no dia seguinte tinha 55 atualizacoes automaticas, como esse problema e no Servidor da minha LAN HOUSE nao pude esperar terminar de instalar as atualizacoes lembro q enterronpi na atualizacao do Office 2007 acho q isso tem alguma relacao pois nas outras 9 maquinas que tenho aqui tbm ativei o windows baixei e instalei o msn 8.5 e as atualizacoes q ele pede porem nao ativei as atualizacoes automaticas.

    OBS: agora a tarde 18h deu novamente o problema svchost puxando 100% dai desconectei a net e conectei quando conectei apareceu o icone amarelo baixando o SP3, entretanto ele ja esta baixado a dias so nao instalei.

    nao estou querendo formatar o pc pois minha mae tem uma pasta de 12 G ¬¬ dai pra mim salvar isso leva horas...

    Repito Savio me da UMA LUZ MANO!! Abraco!!
    Tuesday, April 07, 2009 7:59 PM
  • Renan, blz?


    Tenta o service pack 3.... veja se resolve.


    Esta solução é mais antiga que o SP  3, mas vale dar uma olhada:
    http://support.microsoft.com/kb/927891/
    Savio Vallochi http://www.activedirectory.com.br http://saviovallochi.spaces.live.com/
    Wednesday, April 08, 2009 11:47 AM
  • fala savio,

    Cara ate agora nao tive problemas, mas supondo q ele persista me tire uma duvida,
    eu ja tinha instalado essa atualizacoes 927891, no link esta dizendo que ela e apropriada somente pra SP2 mas queria saber se posso baixa desse link q vc me mando e instala-la novamente lembrando que agora estou no SP3, outra coisa e a parte do WUA agente de atualizacao, nao entendi muito bem qual deles devo baixar
    Baixe o pacote WindowsUpdateAgent30-x86.exe agora.
    Baixe o pacote do WindowsUpdateAgent30-x64.exe agora. ou ainda o
    Baixe o pacote do WindowsUpdateAgent30-ia64.exe agora.

    porque nenhum faz mensao ao windows XP ou SP3, caso eu tenha q verificar meu pc pra saber qual deles usar me passa a dica ok ?!

    Savio vlw mesmo pela ajuda, queria saber se vc ajuda as pessoas por outro lugar tipo msn/orkut que sao mais acessados, caso sim se pode passar, mas desde ja um grande obrigado.



    OBS: SAVIO NAO TEVE COMO AMIGO, FORMATEI O PC ONTEM AS 22H, NAO TINHA COMO DAR MAIS TEMPO PARA SOLUCIONAR O SVCHOST, QUANDO ELE ATIVAVA 100% PUXAVA A NET DA MINHA LAN TODINHA, E MEUS CLIENTES FICAVAM NO PREJUIZO =D, OBRIGADO PELA AJUDA E TODAS AS TENTATIVAS DE SOLUCAO, NEM VOU ATIVAR MEU WINDOWS AQUI NO SERVIDOR DA LAN DEIXA ELE PIRATA MESMO PRA NAO CORRER RISCOS =D, PRA VC TER IDEIA PASSEI DAS 22H ATE AS 04 DA MADRUGADA FORMATANDO/INSTALANDO OS PROGRAMAS NAO E MOLE NAO. EM FIM VLWS POR TUDO.
    Wednesday, April 08, 2009 12:37 PM
  • Savio, meu problema é o mesmo do Vinny, mas esse erro do "Generic Host process for win32 services" so aparece quando eu tento usar o Windows Update, meu anti virus, no caso era o AVG também não estava mais atualizando, antes de ver esse forum achando que o problema era no AVG, acabei mudando pro AVAST so pra testar...
    Enfim, essa mensagem aparece sempre quando suso o Windows Update sendo que também não tenho conseguido jogar jogos online como o Counter Strike.


    Obs: tentei usar aquelas atualizacos que vc mandou pro Vinny, mas diz que a minah versão é mais atual e que não há necessidade de fazer a instalação.
    Friday, April 24, 2009 3:59 PM
  • Olá

    O serviço de atualizações automáticas do XP também utiliza o svchost.exe e tem sido comum este problema vinculado a ele.

    Tente o procedimento abaixo:

    1) Parar temporariamente o serviço de atualizações automáticas
    2) Renomear C:\windows\software distribution para C:\windows\software distribution.old
    3) Renomear C:\windows\windowsupdate.log para c:\windows\windowsupdate.log.old
    4) Reiniciar o serviço de atualizações automáticas.

    Boa sorte!

     

    Bom dia professor fiz exatamente o que citou mas quando entro na internet ele cria embixo da pasta que modifiquei
    a pasta de origem :windowsupdate.log
    O que faço.

    Sunday, May 31, 2009 4:57 PM
  • Vejam se podem tirar minha dúvida:

    Bati uma print de um resultado de uma pesquisa com a chave Svchost e olhem:

    http://img535.imageshack.us/img535/9909/imagemug0.jpg

     

    Os marcados em vermelho são minha dúvida...

    Não sei se excluo-os.

    Podem me ajudar?

    Sunday, December 05, 2010 1:48 PM
  • eu fiz esses procedimentos mas como esses citados por fernando E Eder foi
    ram crucial para isto então resolvi por as 3  respostas que me ajudaram juntas  ( eu acho que uma sem a outra fica dificil)
    By Savio Vallochi
    O serviço de atualizações automáticas do XP também utiliza o svchost.exe e tem sido comum este problema vinculado a ele.
    Tente o procedimento abaixo:
    1) Parar temporariamente o serviço de atualizações automáticas
    2) Renomear C:\windows\software distribution para C:\windows\software distribution.old
    3) Renomear C:\windows\windowsupdate.log para c:\windows\windowsupdate.log.old
    4) Reiniciar o serviço de atualizações automáticas.
    Boa sorte!
    SE NAO CONSEGUIR RENOMEAR
    Vocês não estão conseguindo renomear, pois o serviço de atualizações automáticas ainda está ativo. Vá até EXECUTAR, digite SERVICES.MSC e pressione ENTER. Procure na lista de serviços, o serviço "Atualizações automáticas", clique com o botão direito e escolha PARAR. Renomeie o diretório e repita o processo, só que desta vez escolhendo INICIAR.
    By Eder Pardeiro
    SE NAO CONSEGUIR ACHAR UMA DAS DUAS PASTAS
    Só uma observação importante!
    Vi alguns usuários dizendo que encontraram o WindowsUpdates sem o ".log".... e outro usuário disse que não encontrou.
    Primeira consideração: trata-se de um arquivo e não uma pasta.
    Segunda consideração: Às vezes, a extensão não aparece porque o Windows está com opção para não mostrar. Para arrumar isso, entre em Ferramentas >> Opções de Pasta >> Modo de Exibição >> DESMARQUE A OPÇÃO "Ocultar as extensões dos tipos de arquivos conhecidos".
     
    Por fim, estou muito grato pelas dicas!!!! Estava achando que era vírus ou algo que danificasse o sistema... Agora está tudo lindo!!! 
     
    Mais uma vez: Obrigado Sávio e Eder!!!
     
    Abs,
     
    Fernando Ortega
    Thursday, August 11, 2011 10:18 PM
  • eu fiz esses procedimentos mas como esses citados por fernando E Eder foi
    ram crucial para isto então resolvi por as 3  respostas que me ajudaram juntas  ( eu acho que uma sem a outra fica dificil)
    By Savio Vallochi
    O serviço de atualizações automáticas do XP também utiliza o svchost.exe e tem sido comum este problema vinculado a ele.
    Tente o procedimento abaixo:
    1) Parar temporariamente o serviço de atualizações automáticas
    2) Renomear C:\windows\software distribution para C:\windows\software distribution.old
    3) Renomear C:\windows\windowsupdate.log para c:\windows\windowsupdate.log.old
    4) Reiniciar o serviço de atualizações automáticas.
    Boa sorte!
    SE NAO CONSEGUIR RENOMEAR
    Vocês não estão conseguindo renomear, pois o serviço de atualizações automáticas ainda está ativo. Vá até EXECUTAR, digite SERVICES.MSC e pressione ENTER. Procure na lista de serviços, o serviço "Atualizações automáticas", clique com o botão direito e escolha PARAR. Renomeie o diretório e repita o processo, só que desta vez escolhendo INICIAR.
    By Eder Pardeiro
    SE NAO CONSEGUIR ACHAR UMA DAS DUAS PASTAS
    Só uma observação importante!
    Vi alguns usuários dizendo que encontraram o WindowsUpdates sem o ".log".... e outro usuário disse que não encontrou.
    Primeira consideração: trata-se de um arquivo e não uma pasta.
    Segunda consideração: Às vezes, a extensão não aparece porque o Windows está com opção para não mostrar. Para arrumar isso, entre em Ferramentas >> Opções de Pasta >> Modo de Exibição >> DESMARQUE A OPÇÃO "Ocultar as extensões dos tipos de arquivos conhecidos".
     
    Por fim, estou muito grato pelas dicas!!!! Estava achando que era vírus ou algo que danificasse o sistema... Agora está tudo lindo!!! 
     
    Mais uma vez: Obrigado Sávio e Eder!!!
     
    Abs,
     
    Fernando Ortega
    xD eu Esqueci de dizer, obrigado aos 3 foi muito importante para mim pois foi um grande inconveniente que me irritou opor muitos dias obrigado mesmo.
    Thursday, August 11, 2011 10:20 PM
  • Olá Savio,

    Obrigado pela dica! Resolveu meu problema! direto ao ponto!....Só faltou o detalhe sobre a extensão do arquivo .log, pois temos que tirar a opção de ocultar as extensões de arquivos conhecidos...às vezes a gente esquece deste detalhe pq não usa muito, aí o Fernando Ortega lembrou abaixo....vlw pessoal!!!

    Saturday, November 23, 2013 4:25 PM
  • Olá,

    você pode tentar repetir o mesmo procedimento que foi indicado pelo Sávio só que em modo de segurança assim o processo nao estrará em uso.

    Outra forma de desativar o processo é pelo painel de do services onde pode ser modificado.

    Caso tenha dúvidas como entrar em modo de segurança entre em contato.


    Bruno Lippi IT Profesional

    Sunday, November 24, 2013 1:21 AM
  • Pessoal, bom dia.

    Tive o mesm o problema apos formatar e reisnstalar o Windows XP, nao conseguia atualizar o sistema, o update fazia o SVCHOST consumir todo o processamento (100%) travando tudo.

    Bem, depois de tentar todas as dicas acima, ainda assim o meu nao funcionava.

    Entao encontrei a solucao(que nao é inteiramente minha):

    1º - Crie um arquivo chamado fix-svchost.bat com os seguintes comandos.
    (Para quem nao sabe, abra o bloco de notas, copie os comandos da lista abaixo e salve com a extensao .bat)

    regsvr32 comcat.dll /s
    regsvr32 shdoc401.dll /s
    regsvr32 shdoc401.dll /i /s
    regsvr32 asctrls.ocx /s
    regsvr32 oleaut32.dll /s
    regsvr32 shdocvw.dll /I /s
    regsvr32 shdocvw.dll /s
    regsvr32 browseui.dll /s
    regsvr32 browseui.dll /I /s
    regsvr32 msrating.dll /s
    regsvr32 mlang.dll /s
    regsvr32 hlink.dll /s
    regsvr32 mshtmled.dll /s
    regsvr32 urlmon.dll /s
    regsvr32 plugin.ocx /s
    regsvr32 sendmail.dll /s
    regsvr32 scrobj.dll /s
    regsvr32 mmefxe.ocx /s
    regsvr32 corpol.dll /s
    regsvr32 jscript.dll /s
    regsvr32 msxml.dll /s
    regsvr32 imgutil.dll /s
    regsvr32 thumbvw.dll /s
    regsvr32 cryptext.dll /s
    regsvr32 rsabase.dll /s
    regsvr32 inseng.dll /s
    regsvr32 iesetup.dll /i /s
    regsvr32 cryptdlg.dll /s
    regsvr32 actxprxy.dll /s
    regsvr32 dispex.dll /s
    regsvr32 occache.dll /s
    regsvr32 occache.dll /i /s
    regsvr32 iepeers.dll /s
    regsvr32 urlmon.dll /i /s
    regsvr32 cdfview.dll /s
    regsvr32 webcheck.dll /s
    regsvr32 mobsync.dll /s
    regsvr32 pngfilt.dll /s
    regsvr32 licmgr10.dll /s
    regsvr32 icmfilter.dll /s
    regsvr32 hhctrl.ocx /s
    regsvr32 inetcfg.dll /s
    regsvr32 tdc.ocx /s
    regsvr32 MSR2C.DLL /s
    regsvr32 msident.dll /s
    regsvr32 msieftp.dll /s
    regsvr32 xmsconf.ocx /s
    regsvr32 ils.dll /s
    regsvr32 msoeacct.dll /s
    regsvr32 inetcomm.dll /s
    regsvr32 msdxm.ocx /s
    regsvr32 dxmasf.dll /s
    regsvr32 l3codecx.ax /s
    regsvr32 acelpdec.ax /s
    regsvr32 mpg4ds32.ax /s
    regsvr32 voxmsdec.ax /s
    regsvr32 danim.dll /s
    regsvr32 Daxctle.ocx /s
    regsvr32 lmrt.dll /s
    regsvr32 datime.dll /s
    regsvr32 dxtrans.dll /s
    regsvr32 dxtmsft.dll /s
    regsvr32 WEBPOST.DLL /s
    regsvr32 WPWIZDLL.DLL /s
    regsvr32 POSTWPP.DLL /s
    regsvr32 CRSWPP.DLL /s
    regsvr32 FTPWPP.DLL /s
    regsvr32 FPWPP.DLL /s
    regsvr32 WUAPI.DLL /s
    regsvr32 WUAUENG.DLL /s
    regsvr32 ATL.DLL /s
    regsvr32 WUCLTUI.DLL /s
    regsvr32 WUPS.DLL /s
    regsvr32 WUWEB.DLL /s
    regsvr32 wshom.ocx /s
    regsvr32 wshext.dll /s
    regsvr32 vbscript.dll /s
    regsvr32 scrrun.dll mstinit.exe /setup /s
    regsvr32 msnsspc.dll /SspcCreateSspiReg /s
    regsvr32 msapsspc.dll /SspcCreateSspiReg /s
    regsvr32 /s urlmon.dll
    regsvr32 /s mshtml.dll
    regsvr32 /s shdocvw.dll
    regsvr32 /s browseui.dll
    regsvr32 /s jscript.dll
    regsvr32 /s vbscript.dll
    regsvr32 /s scrrun.dll
    regsvr32 /s msxml.dll
    regsvr32 /s actxprxy.dll
    regsvr32 /s softpub.dll
    regsvr32 /s wintrust.dll
    regsvr32 /s dssenh.dll
    regsvr32 /s rsaenh.dll
    regsvr32 /s gpkcsp.dll
    regsvr32 /s sccbase.dll
    regsvr32 /s slbcsp.dll
    regsvr32 /s cryptdlg.dll
    regsvr32 /s schannel.dll
    regsvr32 /s oleaut32.dll
    regsvr32 /s ole32.dll
    regsvr32 /s shell32.dll
    regsvr32 /s initpki.dll
    regsvr32 /s msscript.ocx
    regsvr32 /s dispex.dll
    regsvr32 jscript.dll /s
    del %temp% /Q /F
    net stop wuauserv
    ren %windir%\system32\catroot2 catroot2.old
    cd /d %windir%\SoftwareDistribution
    rd /s DataStore /Q
    regsvr32 wuapi.dll /s
    regsvr32 wups.dll /s
    regsvr32 wuaueng.dll /s
    regsvr32 wucltui.dll /s
    regsvr32 wuweb.dll /s
    regsvr32 msxml.dll /s
    regsvr32 msxml2.dll /s
    regsvr32 msxml3.dll /s
    regsvr32 urlmon.dll /s
    net start wuauserv
    exit

    2º - Reinicie em Modo de Segurança (Pressione intermitentemente F8 durante a inicialização, no menu que aparecer escolha através da seta de navegação, Modo Seguro).

    3º - Renomei as seguintes pastas:
       De:%windir%\SoftwareDistribution
    %windir%\System32\SoftwareDistribution.log
    %windir%\System32\CatRoot
    %windir%\System32\CatRoot2

    Para:
    %windir%\SoftwareDistribution.old
    %windir%\System32\SoftwareDistribution.log.old
    %windir%\System32\CatRoot.old
    %windir%\System32\CatRoot2.old

    OBS: %windir% significa C:\WINDOWS.

    4º - Execute (dê dois cliques) o arquivo fix-svchost.bat. Aguarde até que a tela do promt de comando (tela preta) suma.

    5º - Reinicie normalmente.

    Isso resolveu totalmente o problema, permitiu que o Windows recebesse todas as atualizacoes automaticamente.

    Espero que seja util a todos.

    Agradeço ao colega que criou o .bat acima, muito bom!

    Friday, November 29, 2013 1:16 PM
  • Aqui tem um Tutorial deste problema, é bem mais facil e simples, serve para qualquer versão do Windows XP,

    Voce só vai precisar desativar o serviço de atualização automática,

    aqui o site pra mais detalhes.

    http://blutavy.webnode.com/products/como-resolver-o-problema-svchost-exe-com-100-no-uso-de-memoria-/

    Abraços,

    espero ter ajudado.

    • Proposed as answer by Paulo Tavie Wednesday, December 04, 2013 10:11 PM
    Wednesday, December 04, 2013 10:10 PM