none
Como montar um Home Web Server com no-ip

    Question

  • Pessoal, boa tarde!

    Apesar de ser usuário assíduo dos fóruns do MSDN, pois developer, esse é meu primeiro post no technet.

    Bom, estou montando um web server em meu computador, para hospedar alguns sites que desenvolvo. Quero que esse seja o meu ambiente de desenvolvimento. Eu criei uma máquina virtual com o Windows 2008 R2 usando o VMWare. O ambiente já tem os softwares que preciso para desenvolver, porém outro desenvolvedor também irá usá-lo e ele vai acessar da casa dele.

    Logo, precisaria de um IP Fixo, mas não consigo isso de forma barata com o Velox. Então pensei no no-ip, porém não consegui fazer funcionar. Criei um host no no-ip e quando tento acessar, cai na página do meu roteador (http://www.encoreelectronics.com.br/winplus/index.php?option=com_k2&view=item&id=23:endsl-a2+wigx2&Itemid=1). Então criei um virtual server no roteador, encaminhando as chamadas HTTP na porta 80 para o IP da minha máquina virtual mas mesmo assim continuou caindo na página do roteador...

    Alguém tem experiência com isso? Pode me ajudar?

    Desde já agradeço.

    Um abraço!


    Não esqueça de marcar a resposta como útil!
    --
    Learn! Think! Produce!
    Leandro Mello
    Sunday, June 19, 2011 8:42 PM

Answers

  • Bom,

     

    Isso não tme nada a ver com o Windows Server nem com o Forum, rsrsrs

    Está errando simplesmente na parte da configuração da infra. O port foward com certeza não está funcionando corretamente, ou o seu roteador está com a opção de "remote admin" habilitada na porta 80.

    O portal cooperati (http://www.cooperati.com.br) citou um software para agilizar nessa parte de liberação de portas, em diversos tipos de roteadores domésticos/SMB. Verifica se com ele melhora: http://www.simpleportforwarding.com/


    Se foi útil marca como resposta! _________________________________________________ Rafael Bernardes - It Hero 2009 Award Microsoft Certified Technology Specialist rafael@bernardes.org http://blog.bernardes.org 21 8162-3956 21 7894-5536
    Sunday, June 19, 2011 9:54 PM
  • Mesma vc fazendo o NAT para o servidor não vai funcionar, pq normalmente a operadora bloqueia a porta 80, tente configurar o NAT em outra porta... Exp: na porta 2020..

     

    Mas não esqueça de alterar o host header no IIS para responder na porta 2020.

     

    []s


    Erick Albuquerque | Moderador Fórum Technet
    Blog: http://erickalbuquerque.com.br |
    Artigos IIS: http://iisbrasil.wordpress.com
    Twitter: @_ealbuquerque
    Linkedin: http://br.linkedin.com/in/easantos
    Monday, June 20, 2011 5:01 PM

All replies

  • Olá.

    Para acessar via TS vc tem que liberar a porta 3389, Vc quer abrir o link pela internet ou conectar remoto no 2008.

    Tente um telnet noip-org 80 e veja se abre, se não abrir  e porque a porta nao está aberta.

    Vc pode tentar criar uma DMZ no modem para o IP interno assim ele libera as portas.

    Até,,,


    MCP/MCDST/MCTS/MCITP/MCSA - www.criptix.com.br
    Sunday, June 19, 2011 9:37 PM
  • Bom,

     

    Isso não tme nada a ver com o Windows Server nem com o Forum, rsrsrs

    Está errando simplesmente na parte da configuração da infra. O port foward com certeza não está funcionando corretamente, ou o seu roteador está com a opção de "remote admin" habilitada na porta 80.

    O portal cooperati (http://www.cooperati.com.br) citou um software para agilizar nessa parte de liberação de portas, em diversos tipos de roteadores domésticos/SMB. Verifica se com ele melhora: http://www.simpleportforwarding.com/


    Se foi útil marca como resposta! _________________________________________________ Rafael Bernardes - It Hero 2009 Award Microsoft Certified Technology Specialist rafael@bernardes.org http://blog.bernardes.org 21 8162-3956 21 7894-5536
    Sunday, June 19, 2011 9:54 PM
  • Pessoal,

    Obrigado pelas respostas, mesmo o assunto não sendo de total compatibilidade com o fórum.

    Vou aplicar as dicas e caso não funcione, volto aqui.  =)

    Mais uma vez obrigado!

    Abs.


    Não esqueça de marcar a resposta como útil!
    --
    Learn! Think! Produce!
    Leandro Mello
    Monday, June 20, 2011 2:00 PM
  • Mesma vc fazendo o NAT para o servidor não vai funcionar, pq normalmente a operadora bloqueia a porta 80, tente configurar o NAT em outra porta... Exp: na porta 2020..

     

    Mas não esqueça de alterar o host header no IIS para responder na porta 2020.

     

    []s


    Erick Albuquerque | Moderador Fórum Technet
    Blog: http://erickalbuquerque.com.br |
    Artigos IIS: http://iisbrasil.wordpress.com
    Twitter: @_ealbuquerque
    Linkedin: http://br.linkedin.com/in/easantos
    Monday, June 20, 2011 5:01 PM