none
Second Table not being populated in SSRS report.

    Question

  • I have a report in SSRS using a tablix.  I wanted to show some summary values in a table in the header of the report.  I created a second dataset.  dataset returns results propery in query window of dataset properties.  I dragged a table into the area of the body being used as the header.  I dragged the fields from the dataset to the table.  Fields of 2nd dataset show up fine in expression view.  but when report is previewed no rows show up in the table.  There should always be 4 rows in the table.  I don't understand why this second table is not populated.

    Update:  The second table is not being populated because the second dataset is not being populate.  Yet when I run the query in the dataset window with the same parameters used in the report it populates correctly.

    Update II:  When the report is deployed to the server and run there, (instead of being run in BIDS), the table shows up correctly populated!?!  Can someone explain this?


    Edward R. Joell MCSD MCDBA



    • Edited by joeller Wednesday, August 21, 2013 8:02 PM More Data
    Wednesday, August 21, 2013 4:05 PM

Answers

  • Hello,

    Based on your description, you have an parameter in the second dataset. When you preview your report, the second table with no data. It maybe the issue about the data cache. You can check if you had choose the Never Refresh of the Advance properties of parameter.

    With a parameter, there is an properties Advanced. It is set the report definition attribute UsedInQuery, a value that indicates whether this parameter directly or indirectly affects the data in a report. UsedInQuery is used to help control cache options for report data and for rendered reports. If we choose Never Refresh, we could case incorrect report data or reports to be cached.

    There is an article about Report Parameter, you can refer to it.
    http://msdn.microsoft.com/en-us/library/dd220464.aspx

    If you still have this issue, you can try to delete the reportname.rdl.data file under your report project folder. It is the cache file of report.

    If there are any misunderstanding, please feel free to let me know.

    Regards,
    Alisa Tang

    • Marked as answer by joeller Thursday, August 22, 2013 2:28 PM
    Thursday, August 22, 2013 10:26 AM

All replies

  • Hello,

    Based on your description, you have an parameter in the second dataset. When you preview your report, the second table with no data. It maybe the issue about the data cache. You can check if you had choose the Never Refresh of the Advance properties of parameter.

    With a parameter, there is an properties Advanced. It is set the report definition attribute UsedInQuery, a value that indicates whether this parameter directly or indirectly affects the data in a report. UsedInQuery is used to help control cache options for report data and for rendered reports. If we choose Never Refresh, we could case incorrect report data or reports to be cached.

    There is an article about Report Parameter, you can refer to it.
    http://msdn.microsoft.com/en-us/library/dd220464.aspx

    If you still have this issue, you can try to delete the reportname.rdl.data file under your report project folder. It is the cache file of report.

    If there are any misunderstanding, please feel free to let me know.

    Regards,
    Alisa Tang

    • Marked as answer by joeller Thursday, August 22, 2013 2:28 PM
    Thursday, August 22, 2013 10:26 AM
  • On the window pane opened by the advanced tab of parameter properties, there is a header that states

    "Refresh Data when the parameter changes:"  with a list of radio buttons that state:

    1. "Automatically determine when to refresh"
    2. "Always refresh"
    3. "Never refresh"

    The first radio button is selected.

    I deleted the rdl.data file under the report project and that enabled the table to display properly in preview.

    Edward R. Joell MCSD MCDBA


    • Edited by joeller Thursday, August 22, 2013 2:28 PM New Data
    Thursday, August 22, 2013 2:16 PM