none
Windows 8.1 not sharing printer hardwired to networked Windows XP PC

    Question

  • Printer is connected to XP Pro desktop PC via USB cable. Shared with other Windows 7 machines currently on my Private Network just fine.

    New Windows 8.1 PC added to my Private Network which share Internet connection via wireless router. 8.1 will not "see" the printer to share on the Private Network.

    8.1 shows it as "offline".

    Current driver is installed on the 8.1 machine. Have been able to use it if I connect via hardwire USB from the 8.1 machine directly to the printer.

    Have been through the recommended steps at the Windows "Sharing files and printers" with Windows 8.1 page (sorry they won't allow me to post the link here for some reason)  MULTIPLE TIMES with no results. Have even turned off Windows Firewall but still the 8.1 machine will not see the printer on the XP machine. (Yes, File and Printer sharing is enabled on all machines and password requirement is off.)

    Tuesday, November 26, 2013 12:41 AM

Answers

  • I am having the exact same issue with a client.  Same situation, windows XP machine has the printer plugged in via USB and shared.  Works fine with windows 7 computers, but if the new windows 8.1 laptop tries to connect, it gives errors saying it found no driver, and if I try to use a downloaded driver it gets the "cannot connect" error.  Does work fine when plugging the printer right into the laptop via USB.

    After searching quite a bit for a solution, did find this post about someone having the same issue and fixing it.  It seems I cannot post links yet, so will summarize it here:

    1. Under devices and printers, hit "Add a printer"

    2. When it opens, hit "The printer that I want isn't listed"

    3. Check "Add a local printer or network printer with manual settings" and hit next

    4. on the Choose a printer port page, check "Create a new port" and choose Local Port.

    5. in the Port Name dialogue box, change the name to the network path of the shared printer, IE:"\\xpname\sharedprinter", replacing the placeholders with the actual name of the XP machine that is sharing it, and the printer's shared name from it. Hit OK

    6. Should go to the install the printer driver page, find the driver on the list, using windows update if you have to.  Can instead hit "Have Disk..." and find the manually downloaded drivers.

    7. Will likely come up with a "which version of the driver do you want to use" dialogue if you plugged it in with USB at some point, just use the currently installed driver.  Should have a fully installed printer now.

    I have not actually tried it yet, but will update this once I'm scheduled to get back out there and complete the ticket.  Hope it works, and helps anyone else looking.

    Thursday, January 16, 2014 2:09 AM

All replies

  • Hi,

    For the issue, I suggest you check the "Turn on network discovery".

    Please refer to the following steps:

    1.Open Control Panel Items>>All Control Panel Items>>Network and Sharing Center>>Advanced sharing settings>>Change advanced sharing settings.

    2.Expand Private, we need to able the "Turn on network discovery" option, and check "Turn on automatic setup of network connected devices"

    Meanwhile, I would like to know if your windows 8.1 PC can see the other windows 7 machines.

    Keep post.

    Regards,


    Kelvin hsu
    TechNet Community Support

    Wednesday, November 27, 2013 11:12 AM
  • Kelvin,

    Yes the network discovery and automatic setup were already turned on.

    Yes the 8.1 PC can see the 7 PC and also the XP PC.

    Operation failed with error 0x0000000a. is what occurs.

    Thank you

    Friday, November 29, 2013 2:52 PM
  • Hi,

    Sorry for my late reply.

    Regarding the issue"0x0000000a",let us try the Fixit below to check if it works.

    Diagnose and fix printer and printing problems automatically:

    http://support.microsoft.com/mats/printing_problems/en-us

    Hope this helps.

    Regards,


    Kelvin hsu
    TechNet Community Support

    Friday, December 06, 2013 2:40 PM
  • I ran the Fixit as you suggested. Unfortunately it is only written for XP not 8.1. It ran on the XP machine (which the printer is connected to via USB cable) and no errors were found. The error message I referred to above occurs on the 8.1 machine. Is it that 8.1 is 64-bit and XP Pro Service Pack 3 are not compatible for some reason???
    Saturday, December 07, 2013 12:02 AM
  • I turn the Firewall off on the XP machine and the 8.1 machine. When I try to print from the 8.1 machine it shows the printer as offline also.
    Saturday, December 07, 2013 1:14 AM
  • Hi,

    For the issue,I think it is caused by driver compatibility.

    I suggest we add the printer manually to check the reuslt.

    Install a printer:

    http://windows.microsoft.com/en-us/windows/install-printer#install-printer=windows-8

    Hope this helps.

    Regards,


    Kelvin hsu
    TechNet Community Support

    Sunday, December 08, 2013 2:57 PM
  • This did not work. When Windows 8.1 is searching for a driver is goes into a loop and never return (60 minutes later I hit "Cancel").

    Please review all of the above and know that I just unplugged the USB printer cable from the XP machine and plugged it into my Windows 8.1 machine and WAS able to print a test page. So, the driver does exist in the Windows 8.1 machine but, it does not allow me to access that same printer via my home network. Again, please see the history above as the HP 3940 printer is hardwired to a machine running XP Pro and I have other Windows 7 machines in my home that share the same printer with no issues at all. Only when I brought a Windows 8.1 machine into the environment have I experienced this problem.

    Any ideas on how to SOLVE this problem or who could further assist?

    Friday, December 13, 2013 2:41 PM
  • I am having the exact same issue with a client.  Same situation, windows XP machine has the printer plugged in via USB and shared.  Works fine with windows 7 computers, but if the new windows 8.1 laptop tries to connect, it gives errors saying it found no driver, and if I try to use a downloaded driver it gets the "cannot connect" error.  Does work fine when plugging the printer right into the laptop via USB.

    After searching quite a bit for a solution, did find this post about someone having the same issue and fixing it.  It seems I cannot post links yet, so will summarize it here:

    1. Under devices and printers, hit "Add a printer"

    2. When it opens, hit "The printer that I want isn't listed"

    3. Check "Add a local printer or network printer with manual settings" and hit next

    4. on the Choose a printer port page, check "Create a new port" and choose Local Port.

    5. in the Port Name dialogue box, change the name to the network path of the shared printer, IE:"\\xpname\sharedprinter", replacing the placeholders with the actual name of the XP machine that is sharing it, and the printer's shared name from it. Hit OK

    6. Should go to the install the printer driver page, find the driver on the list, using windows update if you have to.  Can instead hit "Have Disk..." and find the manually downloaded drivers.

    7. Will likely come up with a "which version of the driver do you want to use" dialogue if you plugged it in with USB at some point, just use the currently installed driver.  Should have a fully installed printer now.

    I have not actually tried it yet, but will update this once I'm scheduled to get back out there and complete the ticket.  Hope it works, and helps anyone else looking.

    Thursday, January 16, 2014 2:09 AM
  • I did get back to the client this morning, and used that method on two windows 8.1 laptops.  Both worked fine, and now are printing.
    Thursday, January 16, 2014 8:09 PM
  • This worked perfectly for me, thank you.  I'm using my laptop from work which is joined to my work domain and have always had problems connecting to my home printer.  Thanks for the help.
    Monday, February 17, 2014 4:31 AM
  • Worked fine for me, thanks

    Ernst

    Monday, February 17, 2014 5:40 PM