none
Outlook Web App users are unable to see body of the e-mail message while connecting with the Exchange Server 2013

    Question

  • Hello Everyone,

    I installed a new exchange 2013 in Windows Server 2012, post which i can login to OWA and getting e-mails.

    When i try to view the e-mail, it says "Your request can't be completed right now. Please try again later"

    When i try to compose an e-mail and click on send option it says "The message can't be sent right now. please try again later"

    I verified authentication and IIS settings, but couldn't able to figure out what could be the problem.

    Kindly share your thoughts.

    Wednesday, January 09, 2013 1:48 AM

All replies

  • Hello Everyone,

    It seems most of them viewed this topic, but i didn't get any suggestion's from you guys. The issue is critical and give some suggestions if you guys familiar with the issue.

    Regards,

    Prashanna


    Mani

    Thursday, January 10, 2013 12:24 AM
  • Hello,

    Does this issue occur on Internal OWA? Try log on OWA on the CAS server and see if the issue persists.

    Thanks,


    Simon Wu
    TechNet Community Support

    Thursday, January 10, 2013 7:09 AM
  • Hi Simon,

    Yes it even happens in localhost either in HTTP or HTTPS.

    Regards,

    Prashanna

    Thursday, January 10, 2013 2:21 PM
  • Hi,

     

    I suggest we run the following commands to remove and recreate the OWA and EWS virtual directory:

     

    Remove-OwaVirtualDirectory "CASName\owa (Default Web Site)"

    New-OwaVirtualDirectory "CASName\owa (Default Web Site)" -InternalURL https://CASFQDN/owa

    Remove-WebServicesVirtualDirectory "CASName\EWS (Default Web Site)"

    New-WebServicesVirtualDirectory "CASName\EWS (Default Web Site)" -InternalURL https://CASFQDN/EWS/Exchange.asmx

    IISReset

    After that, please visit https://localhost/owa on the CAS server and check if OWA is working.

    Regards,

     

    Sean Qiu

    Monday, January 14, 2013 7:07 AM
  • Hi,

    Any update?

    Sean Qiu

    Tuesday, January 22, 2013 7:06 AM
  • Any solutions out there?  I have this same issue on a new 2013 Exchange and I tried the suggestion to recreate the Virtual Directories with no success.   
    Sunday, March 03, 2013 9:58 PM
  • Any Update?

    I have this problem too, and I can't resolve

    But happens just some users.
    Monday, March 04, 2013 8:29 PM
  • To add info to this topic, at least for us, this isn't an issue when using OWA Light in an older browser, just when using the full version.  Could this be a .NET problem?
    Tuesday, March 05, 2013 6:54 PM
  • One more piece of info, I loaded a 2nd Exchange 2013 CAS on a fresh VM, and it does exactly the same thing.   Can't view the emails in the premium version of OWA.  Is there any help on this?
    Wednesday, March 06, 2013 4:53 PM
  • Hello,

    I solved same issue by adding this features from server manager:

    • .NET framework 4.5 -> WCF Services -> HTTP Activation
    • Windows process activation service -> Process model
    • Windows process activation service -> Configuration APIs

    After restart OWA works.

    • Proposed as answer by Zed_S Monday, March 11, 2013 12:19 PM
    Monday, March 11, 2013 12:01 PM
  • I am still suffering from this same issue and I've just realized that I have taken a snapshot of the server (it's a Hyper-V server) could this be the cause of the problem? I already had the features installed as mentioned by Zed_S above. Like all others participating in this thread I would greatly appreciate any help. If I can provide more information please let me know.
    Thursday, March 14, 2013 9:00 AM
  • Zed_S thank you very much for this answer. It worked for us as wel.
    Wednesday, April 03, 2013 10:09 PM
  • Hello,

    I solved same issue by adding this features from server manager:

    • .NET framework 4.5 -> WCF Services -> HTTP Activation
    • Windows process activation service -> Process model
    • Windows process activation service -> Configuration APIs

    After restart OWA works.

    I've been banging my head against the wall for a few days with this. I tried installing these but it didn't do it. JUST fixed it for me by enabling anonymous authentication to the backend OWA folder. 

    I went over the authentication methods two or three times from the MS document showing the defaults. I SWEAR I had it all according to the book. It's 2AM now and I'm too lazy to ready the MS site to see if it's wrong because it's working for me now dammit!

    • Proposed as answer by BCurran3 Monday, April 15, 2013 9:03 AM
    Monday, April 15, 2013 9:02 AM
  • Using your solution, I am able to make the error go away by enabling Anonymous authentication. I feel however this is more of a "band aid" instead of a fix as from my research it should just be set to Windows Authentication.

    Thoughts?

    Thursday, May 09, 2013 8:12 PM
  • Hello,

    I solved same issue by adding this features from server manager:

    • .NET framework 4.5 -> WCF Services -> HTTP Activation
    • Windows process activation service -> Process model
    • Windows process activation service -> Configuration APIs

    After restart OWA works.

    Thanks for this as it seemed to help me get to my solution. My problem was caused by installing .NET 3.5 after exchange and .NET 4.5 were already installed.

    So I uninstalled:

    * .NET Framework 3.5 Features
      -> .NET Framework 3.5
      -> HTTP Activation
      -> Non-HTTP Activation

    * .NET framework 4.5
      -> WCF Services -> HTTP Activation
      -> ASP.NET 4.5

    I then rebooted, re-installed the 3.5 features, rebooted and re-installed the 4.5 features, rebooted again then went into ECP/EAC -> Servers -> Virtual Directories -> Selected "owa (Default Web Site) -> clicked Reset and followed the steps and it worked fine after this.
    Wednesday, October 16, 2013 11:39 AM
  • The only thing that fixed it for me was going into the Exchange Admin Center, clicking on permissions, then under Outlook Web Policies.....file access, I unchecked WebReady Document Viewing in both sections.

    The other thing I did, was under "features", I turned off all the stuff I knew people didn't need....  like all messaging and journaling.


     

    Friday, November 01, 2013 1:40 PM
  • was anyone getting errors or warnings in the event viewer when users were seeing "Your request can't be completed right now. Please try again later"
    Wednesday, November 27, 2013 3:52 PM
  • BCurran3,

    Thank you! The IIS "Exchange Back End" -> OWA -> Enable Anonymous Authentication fixed this issue for us.

    Thanks again for posting this fix!


    • Edited by JoshSRitch Wednesday, February 19, 2014 9:52 PM
    Wednesday, February 19, 2014 9:31 PM
  • Hello,

    I solved same issue by adding this features from server manager:

    • .NET framework 4.5 -> WCF Services -> HTTP Activation
    • Windows process activation service -> Process model
    • Windows process activation service -> Configuration APIs

    After restart OWA works.


    Worked for me, thank you Zed!
    Sunday, February 23, 2014 5:17 PM