none
Multihomed servers with IPv4 and IPv6

    Question

  • We have a set up where we have virtual servers with two NIC's.  One NIC is connected to our corporate network and the other NIC is connected (via layer 2 over MPLS) to the customer network.  The NIC on our network is only assigned an IPv6 address and the NIC on the customer network is only assigned an IPv4 address from the customer DHCP server.  The problem we are running into is when the server does an NSLOOKUP for a URL that is associated with a server located on our network (the server has an IPv6 and IPv4 address and is publicly accessable to the internet) the traffic goes out the customer NIC then out their internet connection and back to our public facing load balancer.  Our application that runs on the server needs to communicate with a server at the customer site and then send that data to a server on our side.  We believe this behavior is happening because the customer server is responding as an "Authoritative" DNS server.  We are trying to avoid using the HOSTS file if possible (when we use the HOSTS file and specify the FQDN with the IPv6 address our application works fine and goes out our NIC).

    Any help would be appreciated

    Thanks,

    Friday, February 28, 2014 7:49 PM

All replies

  • Multihomed networks are always misery. I know. I manage one with 4 physical networks that overlap only partially.

    When you start nslookup, the request goes out over the NIC the is highest in the NIC binding order. You can configure the binding order in the change network adapters screen, and then clicking advanced -> advanced settings (if you don't see the menu, press the 'alt' key once).

    If you move the NIC order in the binding list, you also change the adapter over which the lookup request is sent.

    Monday, March 03, 2014 8:13 AM
  • Thanks for the idea Bruno, however we did try this already.  I moved the adapter with IPv6 to the top of the binding order and rebooted the VM.  However when I run NSLOOKUP it still goes out the adapter with IPv4 which is now second in the binding order.

    Side question.  When I do an IPCONFIG /all what determines the order of listed adapters?  I have changed the adapter names (so it isn't alphabetical), I have looked at the adapters in device manager and it isn't based on which one is #1 next to it.  And now I have changed the binding order and it still hasn't changed.  The adapter with IPv4 is always listed first.  Not sure if that means anything but just an observation.

    Any other ideas?

    Thanks,

    Adam

    Monday, March 03, 2014 4:53 PM