none
Problemas con DNS

    Question

  • Saludos partners IT:

    TEngo un servidor con 2008 r2 que hace de AD DS, DHCP, DNS, WINS tengo un router como mi Puerta de enlace y el ADSL del ISP para internet. El ADSL de Mi ISP esta en modo Bridge pues necesito administrar puertos desde mi Router y hacer NAT.

    El asunto es que desde ayer el servicio DNS de mi server 2008 no me resuelve los reenviadores que le puse de mi ISP y se cae el internet... y si pongo los DNS del ISP en las propiedades de la NIC funciona en los equipos cliente y tienen acceso a internet.

    si ejecuto un dnslookup el me lo encuentra y le tengo que reconosca solo la IP de mi Servidor...

    Tambien desde que sucedio esta caida de internet se perdio la red local.. pero supongo qeu es por razon de mi DNS.. verdad

    Pudiera ser problemas en Router DLINK? Porque dejo de resolverme los reeenviadores?

    Gracias por su colaboracion


    Juan Pablo Vidal http://juanvidal.wordpress.com
    Saturday, February 04, 2012 1:15 AM

Answers

  • Saludos:

    Les comento como se soluciono el problema ... pero ahora quiero entender que paso .. porqueee..

    desinstale el rol DNS y lo volvi a montar y de una me cargaron los reenviadores y el acceso a internet .

    Pero porque seria ?? venia funcionando muy bien.. y en el visor de sucesos no me muestra nada extraño

    gracias muchachos por su ayuda


    Juan Pablo Vidal http://juanvidal.wordpress.com
    Saturday, February 04, 2012 6:08 PM

All replies

  • Hola,

    no debes poner los DNS de tu ISP en los clientes porque entonces estos no podran resolver bien los recursos internos, solo debes configurarles tu DNS Interno.

    En el servidor verifica de nuevo los reenviadores, reinicia el servicio DNS y dejandolo todo correctamente configurado ( el servidor tambien debe apuntarse a el mismo de forma exclusiva a menos que tengas mas servidores DNS internos, nunca a un ISP ).  Una vez este todo correctamente configurado ejecuta un nslookup .. ese se conectara a tu servidor DNS interno, luego escribe  server xxx.yyy.zzz.www  donde esa cadena es la IP del dns de tu ISP,  con esto estas haciendo que nslookup se conecte a el para poder hacerle consultas. Si la conexion es es satisfactoria podras verificar si el DNS de tu ISP funciona correctamente, si la conexion no es satisfactoria puede ser que el DNS de tu ISP este teniendo problemas o simplemente los hayan cambiado y estas IPs ahora sean otras. 

    Tienes muchos servidores DNS publicos, hay listas en internet... puedes probar con varios de ellos y si esos te dan mejor resultado puedes cambiarlos, no es estrictamente necesario que utilices los de tu ISP. 

    Tambien puedes quitar los reenviadores y no configurar ninguno, tu servidor DNS tratara entonces de resolver las direcciones en los servidores root DNS.

    Prueba y comentanos.

    Saludos


    MCITP - Server Administrator (Windows Server 2008) MCC - Microsoft Community Contributor 2011
    Saturday, February 04, 2012 5:50 AM
  • gracias pep_lopez

    si se que los clientes no deben tener los dns del ISP... era por probar

    cuando le di nslookup le di server xxx.xxx.xxx.xxx la dir de mi ISP me conecto.

    pero intente reinicar el DNs y no me deja me dice que no pudo detener o nose pudo iniciar

    y en reenviadores siempre se queda intenando resolver

    Sera que vuelvo a montar el servicio??? gracias.

    esta apuntando a el mismo... y solo a su IP


    Juan Pablo Vidal http://juanvidal.wordpress.com
    Saturday, February 04, 2012 3:21 PM
  • creo que el problema esta en que mi servidor DNS no esta resolviendo host externos???

    porque tampoco me recuelve los DNs de sugerencias Raiz...

    y ayyy que??

     


    Juan Pablo Vidal http://juanvidal.wordpress.com
    Saturday, February 04, 2012 4:12 PM
  • Saludos:

    Les comento como se soluciono el problema ... pero ahora quiero entender que paso .. porqueee..

    desinstale el rol DNS y lo volvi a montar y de una me cargaron los reenviadores y el acceso a internet .

    Pero porque seria ?? venia funcionando muy bien.. y en el visor de sucesos no me muestra nada extraño

    gracias muchachos por su ayuda


    Juan Pablo Vidal http://juanvidal.wordpress.com
    Saturday, February 04, 2012 6:08 PM