none
Excel 2007 - There was a problem sending the command to the program

    Question

  • I am running Windows 7, with Office 2007.  All of a sudden when I open an excel file I get the "There was a problem sending the command to the program".

    I have seen messages relating to Word 2007 generating this but not excel.

    Can anyone help?
    Monday, November 23, 2009 7:18 PM

Answers

  • Found the answer to my problem on another site.  In case anyone else has this problem....


    Bring up the Excel options, go to advanced and then scroll down to the

    "General" section.  Make sure that "Ignore other applications that use

    Dynamic Data Exchange (DDE)" is not checked. 

    This did fix my problem
    • Proposed as answer by howardsydney Monday, January 25, 2010 12:27 PM
    • Marked as answer by David Wolters Saturday, July 17, 2010 3:21 AM
    Tuesday, November 24, 2009 5:24 PM
  • I had the same "there was a problem sending document"-problem when opening word-documents (Windows 7, 64bit, office 2007). Strangely, the problem disappeared when I changed my default printer! Earlier I had an USB-printer connectected to Buffalo Linkstation Pro Duo as the default printer and the problem seems to occur when the printer is not available. When I change the default printer to e.g. "Microsoft XPS Document Writer", file opening by double-clicking works just fine!
     
    • Proposed as answer by AtoBI Thursday, May 13, 2010 2:42 PM
    • Marked as answer by David Wolters Saturday, July 17, 2010 3:25 AM
    Friday, December 11, 2009 3:13 PM
  • if this didn't work
    right click on microsoft office word shortcut -> prosperities-> compatibility-> and uncheck "Run as administrator" worked fine for me

    win7 ultimate x64, office 2003/2007/2010 beta
    • Proposed as answer by Aptcode Saturday, February 27, 2010 4:38 PM
    • Marked as answer by David Wolters Saturday, July 17, 2010 3:25 AM
    Thursday, December 10, 2009 6:29 PM

All replies

  • Ok, now for something completely weird.

    If I open it under Excel -> Open, it works fine.
    If I click on the file Icon, I get the error.
    Tuesday, November 24, 2009 1:09 AM
  • Found the answer to my problem on another site.  In case anyone else has this problem....


    Bring up the Excel options, go to advanced and then scroll down to the

    "General" section.  Make sure that "Ignore other applications that use

    Dynamic Data Exchange (DDE)" is not checked. 

    This did fix my problem
    • Proposed as answer by howardsydney Monday, January 25, 2010 12:27 PM
    • Marked as answer by David Wolters Saturday, July 17, 2010 3:21 AM
    Tuesday, November 24, 2009 5:24 PM
  • Thanks a lot. It helped me to solve the SAME issue on ym acer laptop with WIN 7 64bit with office 2007. Really wierd problem really, and annoying one.
    Thanks again. It works fine with me now.
    Wednesday, November 25, 2009 10:31 AM
  • "General" section.  Make sure that "Ignore other applications that use Dynamic Data Exchange (DDE)" is not checked. 
    It also did it for me - Thank you

    Running Windows 7, 64bit, office 2007
    Wednesday, December 09, 2009 10:47 AM
  • if this didn't work
    right click on microsoft office word shortcut -> prosperities-> compatibility-> and uncheck "Run as administrator" worked fine for me

    win7 ultimate x64, office 2003/2007/2010 beta
    • Proposed as answer by Aptcode Saturday, February 27, 2010 4:38 PM
    • Marked as answer by David Wolters Saturday, July 17, 2010 3:25 AM
    Thursday, December 10, 2009 6:29 PM
  • I had the same "there was a problem sending document"-problem when opening word-documents (Windows 7, 64bit, office 2007). Strangely, the problem disappeared when I changed my default printer! Earlier I had an USB-printer connectected to Buffalo Linkstation Pro Duo as the default printer and the problem seems to occur when the printer is not available. When I change the default printer to e.g. "Microsoft XPS Document Writer", file opening by double-clicking works just fine!
     
    • Proposed as answer by AtoBI Thursday, May 13, 2010 2:42 PM
    • Marked as answer by David Wolters Saturday, July 17, 2010 3:25 AM
    Friday, December 11, 2009 3:13 PM
  • That was a great solution. I checked this option - Ignore DDE - by accident and I've digged Internet for a solution.
    Thanks.
    Friday, December 18, 2009 10:30 AM
  • I have that problem with all Office 2007 programs running on Windows 7. Neither fix worked since the "Ignore DDE" option was not selected and Word was not set to run as an administrator.

    Saturday, January 02, 2010 9:53 PM
  • I'm running windows 7 with Office 2007, encountered the same problem and your suggestion did the trick. What a weird bug. thanks
    Tuesday, January 05, 2010 7:52 AM
  • I am running Microsoft Office Home and Student 2007 and having same problem.  There is no option for "ignore DDE".  Any thoughts?  Very frustrating!!
    Tuesday, January 05, 2010 8:26 PM
  • I have Microsoft Office Home and Student 2007 also, but I am running Windows 7. 

    Open Excel, and click on the Microsoft Icon at the top left.  In the window at the bottom is "Excel Options".  Click it.
    Then select "Advanced" on the left side of the screen.  When the display comes up, you need to scroll almost to the bottom.
    Under the blue "General" category, will be  "Ignore other applications that use Dynamic Data Exchange (DDE )"
    Make sure it is not checked.

    Hope that helps

    • Proposed as answer by zeeshan991 Thursday, September 30, 2010 12:15 PM
    Wednesday, January 06, 2010 1:51 AM
  • Yahoo!  That did it.  Thank you sooo much!!
    Wednesday, January 06, 2010 3:51 PM
  • WoW thank you it was very useful :)
    Sunday, January 10, 2010 8:20 AM
  • Nice one. It worked for me too. But what set the flag on after so many months of successfull invokations ?
    Monday, January 11, 2010 2:48 PM
  • Thank goodness!  Finally a solution that worked for me too.  Thanks!
    Tuesday, January 12, 2010 7:50 PM
  • Awsome that worked.. Thanks

    Tuesday, January 19, 2010 5:17 AM
  • So, that is a nice work around but, what that box does is allow Excel to open more than one instance of the application.  By unchecking that box, you force Excel to open all worksheets in the same window.  You might ask - "why would you want to do that?"  If you have two monitors and want to compare two spreadsheets or want to use Alt-Tab to move between multiple spreadsheets.  This is important in many enterprise environments.  

    Unchecking this box is only a work around.  Has anyone heard from Microsoft on a real solution to this problem?
    Monday, January 25, 2010 4:53 PM
  • howardsydney - perfect solution! Saved me a lot of time, stress and expense! Thanks!
    Monday, January 25, 2010 5:54 PM
  • Actually, that is why I set it in the first place.  I have two monitors and do VB development on the side for some local organizations.  I would like Excel to open more than one instance.  What I did under XP, doesnt seem to work in Windows 7.  So I have been living without it.  If you ever figure out how to do it, please post the answer.  Thanks.
    Tuesday, January 26, 2010 2:26 AM
  • Awesome help.  This was bugging me for two weeks.  Thought I picked up a virus.  Thanks!!!!
    Monday, February 01, 2010 6:03 PM
  • I too recently have experienced this problem, but only recently.  The DDE check box has always and remains unchecked.  The shortcut does not have the Run as Administrator option checked.  Excel has never done this before I began experimenting with libraries where I had to Sync my music from a network storage server and make it available off line.  Then I tried using the Media Center.  Still didn't like it.  So I stopped the Sync operation and undid the offline settings for the network folder of music.  BTW-All under Win7Pro64.  It also trashed my profiles in Firefox and Thunderbird.

    Excel takes an extremely long time to load on its own and won't load from xls files.  I do extensive VBA work and need xls for cross version use.  On a few occassions, Excel starts in Safe mode.

    I am at a loss.  Would prefer to know what is wrong to reinstallation especially since it didn't start until I tried to establish a custom library which required files to be made available offline and Sync Center use.

    Grrrrrr!
    Wednesday, February 10, 2010 3:03 AM
  • I was hopeful that this forum would provide an answer, but it appears that there are more questions than answers. 

    Like NNema, the DDE box and Run as Adminstrator options have not worked.  I am disappointed that Microsoft has not come up with an answer to what, for me, is a very irritating issue.  The issue is the same in both (Office) Excel 2007 Enterprise (used at home) and Excel 2007 Professional (used at work), both with Windows 7.

    What I find interesting is that all the references/posts by others identify that Windows 7 is the OS.  Is that the root of the problem?

    Friday, February 12, 2010 8:37 AM
  • I have the same problem w/ 7 running 64bit. None of the solutions resolved the problem
    Monday, February 15, 2010 12:31 AM
  • It seems to me that the problem is due to another program using Excel. Probably a bad Add-in that's causing this. You can try to disbale Add-ins via 'Excel Options' -> 'Add-Ins'.
    Note that you have to restart Excel after you disable an Add-in.

    Hope this helps you!
    • Proposed as answer by Kris Amerijckx Monday, February 15, 2010 9:07 AM
    Monday, February 15, 2010 9:06 AM
  • Hi Kris

    Thanks for the suggestion.  Tried disabling the add-ins one by one but still have the same issue.
    Monday, February 15, 2010 9:54 AM
  • @mykcooper Do you have all updates installed? And which version of Windows 7 are you using?
    I know some people at Microsoft and will try to escalate this for you.

    Monday, February 15, 2010 10:59 AM
  • Hi Kris

    Windows 7 Home Premium.  The pc is Packard Bell imedia S370 64-bit OS.
    Monday, February 15, 2010 4:00 PM
  • Thanks to JTett20175. It is fixed.

    Thursday, April 01, 2010 11:21 AM
  • That did it for me, thanks a lot!
    Sunday, April 11, 2010 2:32 PM
  • It work!!!!!
    Monday, April 19, 2010 2:58 AM
  • None of the above suggestions work. In addition, this is not just an excel problem. this is a problem for all Office 2007 products.
    Wednesday, April 21, 2010 6:08 PM
  • THANKS TO ALL!!!!

    Work for me as well by changing the :

    File-Options-Advanced-General-Ignore other applications that use Dynamic Data Exchange (DDE) on OFFICE 2010 Professional PLUS.

    This problem start when i had office 2007, i lived with it, then upgraded to office 2010 beta thinking it might resolve, but problem remained. Then with the launch of Production Office 2010 Professional Plus, uninstalled beta version and reinstalled office 2010 pro plus but still the problem remained. Finally, after googling today, reached this link and did the above (as explained earlier) and fixed.

    Regards,

    M.A.B

     

    Friday, April 23, 2010 7:38 AM
  • 100% worked, thank you it was very useful :)
    Monday, April 26, 2010 5:54 AM
  • Tks, it works fine

    Rgs

    Sidney

    Tuesday, April 27, 2010 12:28 AM
  • Thanks  A lot , it worked for me :)

     

    Jazak Allah

    Monday, May 03, 2010 6:38 AM
  • You are a legend......fixed my problem straight away

    Cheers

    Wednesday, May 05, 2010 3:43 AM
  • By unchecking the option of DDE , Excel 2007 works good

    Friday, May 07, 2010 9:22 AM
  • This worked for me too -- but I wanted to add another piece of information. I believe the smoking gun in my case was the recent installation of MS Office Live Update 1.4. This is not something I asked for, and I may never want or need it, but installing it on my computer was part of the normal update process. This gives me  yet another reason to be suspicious of these automatic updates -- if it ain't broke, and all that. This is not the first time I've had a new problem pushed to me under the guise of an "upgrade."
    • Proposed as answer by AtoBI Thursday, May 13, 2010 3:22 PM
    Friday, May 07, 2010 9:45 AM
  • This worked for me too -- but I wanted to add another piece of information. I believe the smoking gun in my case was the recent installation of MS Office Live Update 1.4. This is not something I asked for, and I may never want or need it, but installing it on my computer was part of the normal update process. This gives me  yet another reason to be suspicious of these automatic updates -- if it ain't broke, and all that. This is not the first time I've had a new problem pushed to me under the guise of an "upgrade."

    I want to open 2 separate windows on dual monitor systems, so I click at DDE but then this problem occur.  I'm using Windows 7-64 bits with office 2010 pro plus-64bits.  Could anyone help? I don't want to open excel manually

     

     

    Friday, May 07, 2010 1:58 PM
  • thanks you alot. it solves my problem
    Sunday, May 09, 2010 10:47 AM
  • thank you very much.
    Tuesday, May 11, 2010 2:03 AM
  • thanks you verey much

    you give us acorrect answer for this problem and we try it and it working not 100%

     

    Sunday, May 23, 2010 9:04 AM
  • Thanks mate it worked. why doe this happen? Is this a virus????
    Tuesday, May 25, 2010 12:05 PM
  • solution of DDE worked for me. Now i am not able to open two excel sheets in two seperate windows.

    Wednesday, May 26, 2010 10:34 AM
  • Wonderful. It solved my problem also. I was so frustrated that I uninstalled and reinstalled office to overcome this problem.  Thanks a million
    Thursday, May 27, 2010 3:03 PM
  • It is not working for me.

    The checkbox is not check and I still have this problem

     

    Does Anybody know why???

    Thursday, June 10, 2010 7:54 PM
  • For people who DDE solution fails try this:

    If you have Windows 7 32 bits go to program files --> microsoft office --> office 12 (or if you have office 2010 then go to office 14) --> right click on EXCEL.EXE --> choose Properties, then click on Compatibility tab and if you have anything checked in that tab uncheck it.

    If you have 64 bits then instead of program files go to 'program files x86', the rest is the same.

    Enjoy it.

    Cheers.

    • Proposed as answer by Flukemeister Thursday, September 02, 2010 3:54 PM
    Wednesday, June 16, 2010 8:14 AM
  • solution of DDE worked for me. Now i am not able to open two excel sheets in two seperate windows.

    Opening Excel from the Start Menu will create a new instance (window) for Excel [Dual Monitor Usage]. You can then use Open File... or drag your excel file from Explorer to the Excel you want to view it in.

     

    Set DDE, still have the same issue - Work around is to double click on the file again ~or~ drag the file from Explorer to an open Excel instance.

    Wednesday, June 16, 2010 10:55 PM
  • help me,,,,details step to solve my m.Word......"There was a problem sending the command to the program".
    Friday, June 25, 2010 7:23 PM
  • Thank you, Thank you, Thank you!  The solution worked for me!
    Tuesday, June 29, 2010 10:14 PM
  • Having struggled with this issue for a few weeks on a clients pc, I tried all suggestions including the DDE, Run As Administrator, /regserver etc..

    I discovered somehow the program had set itself to run in XP SP2 compatibility mode.

    Removing this, solved my problem.

    (rightclick Icon, Properties, Compatability - uncheck compatability mode)

    A

    Thursday, July 01, 2010 2:30 PM
  • Thanks a lot. It helped me to solve the SAME issue on ym dell laptop with WIN 7 64bit with office 2007. Really wierd problem really, and annoying one.
    Thanks again. 
    It works fine with me now.
    Monday, July 05, 2010 5:44 AM
  • This is exactly the fix for me, and great presentation of the issue and fix

     

    Oilrigger88

    Monday, July 12, 2010 4:44 PM
  • Thank you!  This has been driving me nuts for weeks now.  Appreciate you posting the resolution to your own inquiry (to my benefit)!
    Thursday, July 22, 2010 10:45 PM
  • This is the only solution that worked.  Thats for the clear answer.
    Tuesday, August 03, 2010 6:36 PM
  • That worked for me. Thanks for the information
    Friday, August 06, 2010 2:57 PM
  • I had the same problem on windows vista, excel 2007. Couldnt open any xls file directly - had to open excel then browse to the file and open.

     

    Fir me, I sorted it out as follows:

     

     

    goto the actual excel shortcut (to a file but to the program).

     

     

    Rhight click, properties, compatibility, then I found "open in compatibility mode for xp sp2" was ticked. Once I unticked that, it all worked fine!!

     

     

    Thanks everyone though because the suggestions here helped me find the problem.

     

    Friday, August 13, 2010 9:22 AM
  • Found the answer to my problem on another site.  In case anyone else has this problem....


    Bring up the Excel options, go to advanced and then scroll down to the

    "General" section.  Make sure that "Ignore other applications that use

    Dynamic Data Exchange (DDE)" is not checked. 

    This did fix my problem
    Hi, thanks for your suggestion -- it fixed the problem!!!
    Wednesday, August 18, 2010 2:47 AM
  • Changing the Compatibility tab worked after trying all the other solutions posted here.  Would be nice if Microsoft offered that or the other solutions posted here in a pop-up box instead of the stupid error box.  This all happened after upgrading to Window 7 running Office 2007.

    See below....

    For people who DDE solution fails try this:

    If you have Windows 7 32 bits go to program files --> microsoft office --> office 12 (or if you have office 2010 then go to office 14) --> right click on EXCEL.EXE --> choose Properties, then click on Compatibility tab and if you have anything checked in that tab uncheck it.

    If you have 64 bits then instead of program files go to 'program files x86', the rest is the same.

    Enjoy it.

    Cheers.

    Thursday, August 26, 2010 5:47 PM
  • For people who DDE solution fails try this:

    If you have Windows 7 32 bits go to program files --> microsoft office --> office 12 (or if you have office 2010 then go to office 14) --> right click on EXCEL.EXE --> choose Properties, then click on Compatibility tab and if you have anything checked in that tab uncheck it.

    If you have 64 bits then instead of program files go to 'program files x86', the rest is the same.

    Enjoy it.

    Cheers.

    I think this is the real solution to the problem, at least it worked for me where the others haven't. Thanks!
    Thursday, September 02, 2010 3:55 PM
  • Hey Flukemeister

    Yours is the only solution that's worked for me after months of trying to fix it. Brilliant!

    Wednesday, September 08, 2010 11:58 AM
  • Worked for me, too.  I am running Office 2007 on Win7 64-bit...
    Monday, September 13, 2010 2:26 PM
  • i too have experienced your identical problem, but have not changed library files.....problem just began after about five months of being in service.  will open in safe mode after failing to from command.......program will open if you let it set there five to ten minutes, then will function......however most times will "fail to respond".....like you, my boxes weren't checked anyway......i need help....kenwal
    Friday, September 17, 2010 1:16 AM
  • me exactly johnny

     

    Friday, September 17, 2010 1:18 AM
  • kris i'm running windows 7 home premium and having same problems as everyone else......would appreciate

    help...thanks... 

    Friday, September 17, 2010 1:26 AM
  • Your solution WORKED PERFECT!!!

    I tried all but only your solution is the best one I found and correct 100%. if anyone facing same error" problem sending command to program" 

    Thank you sooo much 

    Thursday, September 30, 2010 12:21 PM
  • Exellent!! Thank You

    Thursday, October 21, 2010 5:31 PM
  • Thanks - worked like a charm - I wonder where my IT department is at with my service request???  :~  

    Always appreciate those who really seem to know what they are doing.  Thanks again.

    Wednesday, October 27, 2010 10:39 PM
  • Thanks heaps worked a treat - I must have changed these setting when trying to get excel to open .xlsx files by default - you'd think it would be easy but it wasn't!!!!!
    Saturday, October 30, 2010 4:35 AM
  • Excelllent ................  It is workin in 2010 tooooooooooo..

     

    Good job done JTett20175 :)

    Monday, November 01, 2010 1:52 PM
  • I had this problem with Excel 2007 using Windows7.  I tried many of the solutions at this and other sites.  None worked.  The spreadsheet I was trying to open contained data and a chart. I had been trying to email it, and had tried to open it to be sure it would work.  That's when I got the message.  I went back to my original in Excel, and moved the chart to "sheet 2."  It worked.  WR
    Tuesday, November 02, 2010 12:23 AM
  • THX a lot. after i changed the default printer, the problem resolved.
    Sunday, November 07, 2010 3:52 AM
  • Nice find, thank you very much!!!!!!
    Tuesday, November 09, 2010 4:14 PM
  • This worked for me (Excel 2007).  I disabled some COM addins, restarted, and now I can open .csv files by doubleclicking their icons again.  (The "Ignore other applications that use Dynamic Data Exchange (DDE)" option was unchecked already .)
    Thursday, November 11, 2010 4:12 PM
  • None of the solutions given here work. Problem appeared to come suddenly.

    Tried

    1. DDE CheckBox

    2. Set Defaul printer

    3. Compatibility

    4. Addins

     

    None worked

    Monday, November 15, 2010 12:54 PM
  • Worked for me. thank u!
    Friday, November 19, 2010 6:53 PM
  • Dymo label software 8 add-on was it for me.

    Uninstalled the little monster and Excel works fine.


    Computer Condiments
    • Proposed as answer by CiscoKid248 Tuesday, November 23, 2010 9:04 PM
    Tuesday, November 23, 2010 7:07 PM
  • OK, sorry, first time on this forum... 

     

    I put the UAC settings to minimum and that fixed it for us.  We had tried all the other solutions posted above before adjusting the UAC.

    • Proposed as answer by CiscoKid248 Tuesday, November 23, 2010 9:06 PM
    Tuesday, November 23, 2010 9:06 PM
  • I tried everything and this is what worked for me

     

    Right Click on the icon and go to Properties

     

    Under Opens with click on CHANGE button.

     

    Then set it to Microsoft Excel.

     

    I found out on mine they all got set to something else.  When I did it for this one sheet it changed the rest of them. 

     

    I have Office 2007 on windows 7.  HOPE THIS HELPS!!!!

    • Proposed as answer by mostwireless Wednesday, November 24, 2010 7:15 PM
    Wednesday, November 24, 2010 7:15 PM
  • Just in case you are as lame as I am:

     

    You have to go to the windows button AFTER the application will not open.

     

    Then at the Bottom you go to Excel Options.

     

    It took me a while to figure that out.  I'm sure most of you are better at this than I am.  :)

     

    Thanks for the help!

    Wednesday, November 24, 2010 9:55 PM
  • works great, thanks heaps.
    Wednesday, December 01, 2010 3:55 AM
  • thanks it is work now,

    again thank you very much

    Saturday, December 04, 2010 3:13 AM
  • It worked for me. Thanks!
    Thursday, December 09, 2010 8:20 PM
  • This works,thanks a lot.I would recommend others to follow this...
    Justice mokgothukj@live.co.za
    Tuesday, December 14, 2010 11:26 AM
  • Thank you buddy ... it has solved my problem .. Thanks again
    Thursday, December 23, 2010 9:18 PM
  • Hi Tett20175

     

    I wanted to say thank you & to all the rest with the solution.  That fixed the problem !!!!!!!!!!!!!!!!

    Thanks warrior57

    Saturday, December 25, 2010 1:08 AM
  • I finally figured out how to run more than one instance in Excel.  Thank you PC WORLD !!  Sorry it took me so long.

    1.  Open your excel spreadsheet #1. This can be a blank sheet, or an existing file.

    2.  With the <Shift> key pressed, open a blank Excel (a blank initial file, not an existing one).  It will open the new blank spreadsheet in a new second instance. You then navigate to your second file and open it manually.

     

    JTETT20175

    Tuesday, December 28, 2010 9:11 PM
  • Thank you for the post, that fixed the problem.  Does anyone know what this option is for?  I guess I could research it, just curious and tired.  Been working too many hours
    Wednesday, January 05, 2011 1:00 AM
  • thank you.. it works for me.  =)
    Friday, January 07, 2011 2:58 AM
  • That worked great!  Thanks!
    Friday, January 07, 2011 11:27 PM
  • None of the solutions given here work. Problem appeared to come suddenly.

    Tried

    1. DDE CheckBox

    2. Set Defaul printer

    3. Compatibility

    4. Addins

     

    None worked


    Like Shrishail, I have tried everything that is posted.  I am ruunning Win7 x64 and Office 2010.  I had a document open, closed it, tried to open it again and got the message.  Now, if I click on a shortcut to an excel document, I get the message, click OK, then get a message that the document can't be found.  I then have a excel window open with nothing in it, and if I click on the shortcut again, it opens.

    What gives???

    Tuesday, January 11, 2011 4:04 AM
  • That did solve the problem!! Thanks a lot! :)
    Thursday, January 13, 2011 10:05 PM
  • For me, the issue was that IE was running in Protected Mode. Go To Tools, Internet Options, Security Tab, uncheck "Enable Protected Mode".  You'll have to restart IE.
    Friday, January 14, 2011 3:42 PM
  • It seems to me that the problem is due to another program using Excel. Probably a bad Add-in that's causing this. You can try to disbale Add-ins via 'Excel Options' -> 'Add-Ins'.
    Note that you have to restart Excel after you disable an Add-in.

    Hope this helps you!


    As a software developer, Visual Studio 2010 put a Team Foundation COM add-in as an active add-in. After disabling that (I don't use Team Foundation Server) and unchecking DDE, I'm now irritant-free!

    Thanks for pointing me in the Add-In direction, Kris.

    Brian

    Tuesday, January 18, 2011 4:36 PM
  • I have been having this same problem with Excel 2007 recently about half of the times I try to launch Excel. The DDE checkbox is NOT checked and never has been. SOmeone else in this thread suggested that if this fix didn't work then uncheck the Run as Administrator option for Word, but Excel does not appear to have that option.
    Friday, January 21, 2011 7:52 PM
  • I have been having this same problem with Excel 2007 recently about half of the times I try to launch Excel. The DDE checkbox is NOT checked and never has been. SOmeone else in this thread suggested that if this fix didn't work then uncheck the Run as Administrator option for Word, but Excel does not appear to have that option.

    I had the problem with Excel 2010 (on a Windows 7 Ultimate 32 bit machine). On the Excel shortcut I noticed that under 'Compatibility' it was set to in XP SP3 mode. I unchecked that option and the problem was resolved. Hope this helps some of you!
    Monday, January 24, 2011 7:26 AM
  • I had the same problem and this fix worked, Brill!!
    Saturday, January 29, 2011 11:29 AM
  • Just for the record. If you have Microsoft Word Viewer or any Office Viewer installed, maybe the default application that is starting is the viewer. If the viewer is an older version than Office 2007 the  error is going to be displayed.   Right click the .docx then go to open with: and press Change ... Chose the Office Word 2007 instead of the viewer.  Other option, uninstall the office viewer.

     

     

     

    Saturday, January 29, 2011 2:49 PM
  • Hey..thank you so much for the post.. this is great... It worked for me. 

    Today morning one of our employee had the same issue and this quick trick worked fine for us. I think when there is update for Office few options could change without any intervention of ours... Anyways thank you so much for the quick trick.

    My syetm Configuration is: Windows 7 Pro 32-bit & MS-Office 2007 Standard.

    Chrees,

    Ram


    V RamaNaidu Merla
    Monday, January 31, 2011 4:43 AM
  • thank you so much. this worked for me.
    Tuesday, February 01, 2011 1:00 PM
  • This fixed my problem. It is the strangest thing...first time I have encountered it. Do you happen to know the cause? Thank you for the help.
    Tuesday, February 08, 2011 3:47 AM
  • I encountered this issue with Office 2010.  Found "Ignore other applications that use Dynamic Data Exchange" under the ADVANCED tab, way at the bottom, not the GENERAL tab as in 2007.  Solved the problem.  Thanks!
    Sunday, February 13, 2011 3:20 AM
  • Thank you, thank you, thank you!!!  This was driving me crazy for the last couple of days and I was worried that something was screwed up on my computer.  This worked like a charm!
    Monday, February 21, 2011 3:23 AM
  • Thanks! This solved the problem for me!

    Wednesday, February 23, 2011 4:25 PM
  • Extremely helpful

     

    Thanks

    The Buckster

    Tuesday, March 01, 2011 10:20 AM
  • None of the solutions given here work. Problem appeared to come suddenly.

    Tried

    1. DDE CheckBox

    2. Set Defaul printer

    3. Compatibility

    4. Addins

     

    None worked


    I tried the above methods like some of you but the problem remained. At the end, what I did is go to Programs and Features, hit "Change" for Microsoft Office 2007, then "REPAIR" it. After 5 minutes the progress is done and my problem got resolved. I think this is the best solution. Save time, no side issues like the "DDE" thingy may caused.
    Thursday, March 17, 2011 4:23 AM
  • It Works.

    Thanks

    Friday, March 18, 2011 6:47 AM
  • Let me just say that for me, using Excel 2010 that when you have visual studio installed, that it's best to make sure that none of the COM addins are enabled. remove them if possible.

     

    After that is taken care off, make sure that DDE is NOT checked. That also helps.

     

    Finally, in my case, you should right click on the Excel application and make sure that it isn't being run by an administrator. You will need to do this on the original Excel applicaiton itself. not an xls file made with excel.

     

    Cheers!

    • Proposed as answer by Gigafrost Monday, March 21, 2011 3:36 PM
    Monday, March 21, 2011 3:34 PM
  • wow,,great working fine for me thanks a lot!!!!!!!!
    • Proposed as answer by AmjadRaja Thursday, April 14, 2011 6:28 AM
    • Unproposed as answer by David Wolters Monday, April 25, 2011 6:29 PM
    Thursday, March 24, 2011 7:38 AM
  • Wowww it works,thank a loooooooooooottttttt  JTett20175
    Thursday, April 14, 2011 6:29 AM
  • Hi JT,

    I tried this, and it didn't work.

    It would be nice to be able to open an excel sheet by double clicking it. Now it doesn't work. Rather I have to get into a blank sheet, open, and navigate to it.

    Any suggestions for plan B? 

    Thank you!

    Monday, April 25, 2011 6:12 PM
  • Thanks JTett20175, issue got solved after unchecking the said option.
    Sunday, May 01, 2011 12:48 PM
  • I don't know where the "excel options" is.
    Tuesday, May 03, 2011 1:12 AM
  • well, I couldn't find options either until you tipped me off. thanks much
    Tuesday, May 03, 2011 1:46 AM
  • This fixed the problem!  Thank you so much.
    Thursday, May 05, 2011 6:33 PM
  • You don't need to check this box to open excel on both monitors.  Pin Excel to the taskbar if you haven't done so already.Open the first file then right-click Excel on the task bar and click Excel.  This will open another Excel app which you can place on the second monitor. 

     

    Bill Anderson
    IT Administrator
    Mills Products, Inc
    it@millsproducts.com

     

    Tuesday, May 10, 2011 7:41 PM
  • Would a Microsoft review like to weigh in on this issue?  It appears to be not entirely simple, and, while some apparent resolutions are listed here, providing an authoritative link with a clean, step-by-step routine to perform (or to send to users) could go a long way to alleviating user frustration.

    Wednesday, May 11, 2011 4:49 PM
  • YES!!!! that worked for me. I ws needing badly to make that problem go away...........Thank You
    Wednesday, May 18, 2011 3:35 AM
  • Thanks to this answer.  It did fix the same problem as I had.
    Sunday, May 22, 2011 2:27 AM
  • I suddenly saw this error when trying to open .xlsx files by double clicking after changing the Windows UAC setting from "Off" to "Default".  My Excel 2007 Option to Ignore DDE was never checked.  By unchecking the property of "C:\Program Files\Microsoft Office\Office12\EXCEL.EXE" to NOT open as administrator I fixed the issue.

     

    Very odd behavior

    Monday, May 23, 2011 9:26 PM
  • i had the same problem, i followed the steps above and solved the problem!

     

    Thanks

    Anand

    Monday, June 06, 2011 6:34 PM
  • followed the steps and it works, tx. Wonder why it hasn't happened earlier? should I suspect the windows update? -Erik
    Wednesday, June 08, 2011 3:06 AM
  • I had this issue when i was using external drive, with my laptop. I was in Excel file, suddenly Laptop went on hybernate / mode, I have disconnected the External drive before I restart the Laptop. I did the following. "Ignore other applications that use Dynamic Data Exchange (DDE)" is not checked. as you told me. Wow, this is working. Thank you,
    Thursday, June 23, 2011 8:16 AM
  • Let me just say that for me, using Excel 2010 that when you have visual studio installed, that it's best to make sure that none of the COM addins are enabled. remove them if possible.

    This is worth checking even if you didn't select Office Development as part of your Visual Studio install. I starting getting the error with Excel 2007 SP2 on Win7 Pro x64 SP1 after installing VS2010 Pro, and it turns out that even though I only selected VC++ the VS installer kindly added a COM Team Foundation Add-In to Excel.

    Strange thing is that doing a Repair from the Programs control panel as a standard user fixed the error for me, and it was only afterwards that I noticed the unwanted add-in. Maybe the VS installer messed something up in the per-user Excel config?

    Thursday, June 23, 2011 3:49 PM
  • Found the answer to my problem on another site.  In case anyone else has this problem....


    Bring up the Excel options, go to advanced and then scroll down to the

    "General" section.  Make sure that "Ignore other applications that use

    Dynamic Data Exchange (DDE)" is not checked. 

    This did fix my problem
    it works.
    Sunday, June 26, 2011 6:04 AM
  • This fixed my problem(s) as well :-)

    Prior to this I was having two issues:

    1. Excel would not open when I double clicked on any spreadsheet from the Windows Explorer.
    2. Could not open any excel spreadsheets from Outlook.

    Thanks for your answer!

     

    Thursday, June 30, 2011 2:05 PM
  • Hi

    Many thanks, it was amazing. It Solved completly my problem...

    Regards

     

    Wednesday, July 13, 2011 9:40 AM
  • Thanks soooo much, it worked!
    Thursday, July 14, 2011 9:22 AM
  • This problem has plagued me and slowed down my work considerably - driving me absolutely crazy.  None of the issues listed above worked (in fact, some of them really seemed to cause more problems).  However, I followed your advice in going to the program features (I had danced around this folder, but hadn't hit 'change' because I was afraid of what might happen).  And then, once I did this, hit "repair" it was golden after that; my files opened without a hitch, and no more of that annoying error prompt that says that there's an error sending the command to the program...  Thank you so much.

    Saturday, July 16, 2011 1:56 PM
  • This worked 100%, thank you JTett20175!


    Monday, July 18, 2011 11:07 AM
  • Here is the best link for this issue.

    http://support.microsoft.com/kb/211494

     

    Thanks

    Tuesday, July 19, 2011 7:38 AM
  • I get it that it works but what made it change? Did it do it on its own? Is someone messing witht the programs at Microsoft? Siomething so simple causing so many problems.
    Monday, August 01, 2011 9:43 AM
  • This worked for me like a charm!!!!!!

    Thanks a lot.

     

     


    J.Nayi
    Wednesday, August 03, 2011 6:49 AM
  • I tried all the steps mentioned in this forum, but still the issue persist.

     

    When I click on the Excel file that is stored on the desktop, it kick start the Excel application and open up the blank. The contents of the file does not open or display. It is blank. 


    It is all about me
    Wednesday, August 03, 2011 11:25 AM
  • Great resolution for this problem!!!!.... Even though I have not idea what the DDE does or is, oh well this is the solution I was looking for
    Thursday, August 04, 2011 1:39 PM
  • This problem my problem as well under same settings. cheers.
    Friday, August 12, 2011 10:55 AM
  • Yes.Its worked. You did Great job buddy.
    Tuesday, August 16, 2011 5:19 AM
  • thank you.  i just did it and it worked. you saved me fortune as i was about to go pay to get it fixed. :)

    Tuesday, August 16, 2011 6:26 AM
  • This problem has plagued me and slowed down my work considerably - driving me absolutely crazy.  None of the issues listed above worked (in fact, some of them really seemed to cause more problems).  However, I followed your advice in going to the program features (I had danced around this folder, but hadn't hit 'change' because I was afraid of what might happen).  And then, once I did this, hit "repair" it was golden after that; my files opened without a hitch, and no more of that annoying error prompt that says that there's an error sending the command to the program...  Thank you so much.


    i have same problem and tried all other solution but failed all! can you tell me how to go to "program feature", please guide more details hopefully in this solution to solve it! thanks in advance!
    Thursday, August 18, 2011 10:10 PM
  • i have same problem and tried all other solution but failed all! can you tell me how to go to "program feature", please guide more details hopefully in this solution to solve it! thanks in advance!
    Thursday, August 18, 2011 10:11 PM
  • That took care of my problem in Excel 2007
    Wednesday, August 24, 2011 6:26 PM
  • Wow!  Worked!  How did it ever get checked!  Why now!  9/22/11
    Friday, September 23, 2011 12:00 AM
  • This solved my same issue! Thanks a bunch:-) JTett20175
    Wednesday, October 05, 2011 12:26 AM
  • Excellent resolved my issue as well. Thansk
    Monday, October 10, 2011 3:07 PM
  • Thank you -  Thank you  this DID fix my problem immediately.

    Cheers Isagold

    Tuesday, October 11, 2011 11:24 PM
  • Thanks JTett20175 "THIS SOLVES MY PROBLEM, VERY HELPFUL".

     

    SOLUTION:

    Bring up the Excel options, go to advanced and then scroll down to the

    "General" section.  Make sure that "Ignore other applications that use

    Dynamic Data Exchange (DDE)" is not checked.  

    Monday, October 17, 2011 6:26 AM
  • you are a lifesaver man... this really helped..

     thanks....

     

    _____________________________________________________________________________________

    An Open Book on a Marble Tomb

    the wind that walks beneath the leaves

    as the sands of time they slowly Fall

    I KNow me Much and Not at all..

    Monday, October 24, 2011 12:58 PM
  • Have had so much drama with this and has been very frustrating to see solutions that work but not for me. Thanks a buch for sorting me out.

     

    Tuesday, October 25, 2011 6:25 AM
  • I had the same problem.  I could not open an Excel file by clicking on the file itself or its shortcut.  The problem was resolved by changing the compatibility setting to "Windows 7".

    Let me know if it works for you too.

    Wednesday, October 26, 2011 2:20 AM
  • Thanks NordicSound!  DDE was already unchecked on mine but your solution fixed it.  The folder is office 11 if you have 2003
    Thursday, December 01, 2011 11:34 AM
  • This worked for me.
    Monday, December 12, 2011 11:41 AM
  • Unchecking the compatibility worked for me too. Funny thing is I went back and rechecked the box and my files still open up Excel when selecting the file without getting the error there was a problem with the command!
    Thursday, January 12, 2012 2:35 PM
  • Soooooooo glad I found this so quickly ,

     

    was driving me crazy , such a simple thing and its all working again

     

    Thanks for taking the time to post it here , V helpful !

     

    Andy

    Sunday, January 29, 2012 10:44 AM
  • Works fine for me. was planning to reinstall but it works out fine.
    Thursday, February 02, 2012 11:52 AM
  • Found the answer to my problem on another site.  In case anyone else has this problem....


    Bring up the Excel options, go to advanced and then scroll down to the

    "General" section.  Make sure that "Ignore other applications that use

    Dynamic Data Exchange (DDE)" is not checked. 

    This did fix my problem

    Thanks a lot, this fixed the problem.
    Anubhav Bajpai
    Friday, February 03, 2012 9:39 AM
  • OK, sorry, first time on this forum... 

     

    I put the UAC settings to minimum and that fixed it for us.  We had tried all the other solutions posted above before adjusting the UAC.

    bravo...same for me..tried all the solutions that were available but only this one worked for me too....
    Tuesday, February 07, 2012 8:48 AM
  • It was really helpful.. Thanks a ton
    Thursday, February 16, 2012 11:26 AM
  • For people who DDE solution fails try this:

    If you have Windows 7 32 bits go to program files --> microsoft office --> office 12 (or if you have office 2010 then go to office 14) --> right click on EXCEL.EXE --> choose Properties, then click on Compatibility tab and if you have anything checked in that tab uncheck it.

    If you have 64 bits then instead of program files go to 'program files x86', the rest is the same.

    Enjoy it.

    Cheers.


    THANK YOU!
    Monday, February 27, 2012 8:53 PM
  • Worked a treat thanks!
    Thursday, March 01, 2012 1:22 PM
  • This problem seems to happen for me when I use Matlab(R) to read .xlsx files. For some reason it changes the options in Excel to ignore other applications that use dynamic data exchange. Looked for a reason why Matlab(R) would do this without luck. Wonder if this is a Excel Issue?
    • Proposed as answer by Ozziepete Sunday, March 25, 2012 10:06 AM
    • Unproposed as answer by Ozziepete Sunday, March 25, 2012 10:06 AM
    Friday, March 02, 2012 5:27 PM
  • I've had the problem for a couple of months, driving me mad.  

    I have Windows Professional 64 bit with Office Professional 2007.  When trying to load some Excel files that had been created in Office 2003, into Excel 2007, Excel would stop withe the error :"Excel has stopped working".  I tried all the solutions listed above but none worked.  

    I tried copying some of the .xls files that wouldn't open on my PC to my Macbook and they opened in Mac Office 2004.  I then saved them on the Mac as .xlsx and tried to open them in Excel 2007.  Some would open but those with macros still would not. 

    I uninstalled all the s/w I had installed since I first noticed the problem but still no change.

    I eventually found this article on the Office File Validation Add-in at: http://windowssecrets.com/patch-watch/office-file-validation-patch-leads-to-problems/  I uninstalled the add-in and can now open all my old .xls spreadsheets.   Interestingly, the problem did not occur until four months after Windows Update had installed the Add-in.

    PHEW!!

    Sunday, March 25, 2012 10:23 AM
  • Hi,

    For those who are having trouble with the instrcutions, I made a post with screenshots for this solution:

    http://www.out-of-warranty.com/excel-error-message-problem-sending-the-command-to-the-program/

    Hope it helps.

    regards,

    Nik

    Thursday, April 12, 2012 1:55 AM
  • Thanks very much for this tip, JT.  It resolved my issue.

    This happened for the first time in many years so I Googled the error message but I have no idea how I got away opening Excel after all these years.  Again, thanks!

    Monday, April 16, 2012 7:12 PM
  • Problem unresolved:

    I am using MS Office 2010 (service pack 1) 64 bit with Windows 7 Home premium 64 bit (service pack 1).

    When ever I double click any .xls file: "There was a problem...." error message is displayed. But if i first open excel and then open the file, in that case no problem.

    I have unchecked 'Ignore other applications that use DDE'. As a precaution, I checked the DDE option, closed excel, opened excel a 2nd time to uncheck the DDE option.
    I have disabled and removed all COM add-ins
    I have unchecked all compatibility options.

    I have also changed the default printer to XPS writer.


    But still I get the error. I have also reinstalled office 2010 and applied all updates.

    Sunday, April 22, 2012 12:11 AM
  • thanx alot . this fixed our problem. really greatful for your help

    regards,

    Wasim Ahsen

    Sunday, April 22, 2012 9:19 AM
  • That really solved my problems with that! Thanks! Cassiano
    Wednesday, April 25, 2012 1:19 PM
  • Found the answer to my problem on another site.  In case anyone else has this problem....


    Bring up the Excel options, go to advanced and then scroll down to the

    "General" section.  Make sure that "Ignore other applications that use

    Dynamic Data Exchange (DDE)" is not checked. 

    This did fix my problem

    Wednesday, April 25, 2012 1:19 PM
  • Make sure that "Ignore other applications that use Dynamic Data Exchange (DDE)" is not checked.

    This fixed my problem as well.

    I was unable to double-click to open an Excel spreadsheet but able to open one through File/Open.

    Thursday, April 26, 2012 3:20 AM
  • I experienced the same issue. But at first I found the advanced setting was unchecked already. To fix my issue, I checked it on, confirmed temporary setting, closed Excel, opened Excel, opened the advanced settings dialog again, unchecked the setting, confirmed new setting, closed Excel.

    Monday, May 14, 2012 5:48 PM
  • This solution worked for me. Thanks
    Thursday, May 17, 2012 6:53 AM
  • THANK YOU!!! This fixed the problem!!
    Friday, June 01, 2012 5:37 PM
  • I cant bring up Excel application at all. no matter how I try it, I end up with this error "There was a problem sending the command to the program".

    I tried that "Fix it" option from support site... didn't work.

    unable to open Excel application to go to the options --> advanced --> etc etc...

    Any clues ??

    Thursday, June 07, 2012 6:19 AM
  • same problem

    Monday, June 11, 2012 11:49 AM
  • tnx a lot.. my problem is fix.. 
    Saturday, August 11, 2012 11:49 PM
  • Thanks buddy it works... able to solve my issue.
    Wednesday, August 29, 2012 4:08 AM
  • thanks for this, it did help my problem..two thumbs up
    Monday, September 03, 2012 12:50 AM
  • I love when I find answers like this on my first try.  Worked like a charm.
    Thursday, September 06, 2012 2:24 PM
  • Dear

    I am running Windows 7, with Office 2007.  All of a sudden when I open an excel file I get the "There was a problem sending the command to the program".

    Thanks

    Friday, September 07, 2012 6:03 AM
  • I have the same problem w/ 7 running 64bit. None of the solutions resolved the problem

    Tuesday, October 09, 2012 8:04 AM
  • if anyone is having this issue and has tried the DDE setting fix and had no success. I would recommend turning of the multiple processor setting and also the HT setting. 

    Wednesday, October 24, 2012 3:10 PM
  • The message is a general response to a DDE timeout occurring.  (Excel takes too long to respond.)  So anything that makes Excel "hang" could be the culprit.

    In my case it is network related:  Excel seems to want to make connections to all the printers I have defined.  When I am at home my work printers are inaccessible, but the stupid networking takes much too long to figure that out.  Hence the delays and timeouts.  If I turn off my networking Excel starts up immediately.  (The networking is clever enough to time out quickly in this case!)  

    The same sort of problem exists in File Explorer if I map a drive to a share at work, and take the laptop home.  Explorer chokes trying to access the inaccessibe share.

    I'm not sure if there are sensible workarounds: perhaps using fully qualified domain names for shared resources would help, or perhaps rebooting the laptop when I get home.  Or uninstalling my work printers.  Or turning off my networking while Excel starts up.  etc.

    • Proposed as answer by cspwcspw-pete Saturday, October 27, 2012 5:41 AM
    Saturday, October 27, 2012 5:40 AM
  • Thanx It helped........
    Monday, November 12, 2012 5:35 AM
  • To: Austin.W

    Thank you. Thank you.   I too tried the suggestions: DDE, Run As Administrator, to no avail.  Your compatability mode solution was the only working solution to my Windows 7/MS Office 2007 problem.

    I have no idea why my Compatablility mode was checked on Excel and Word.  Unchecked and problem went away immediately!



    • Edited by MikeMontague Wednesday, November 21, 2012 6:10 PM
    Wednesday, November 21, 2012 6:02 PM
  • Fantastic.......Worked perfectly!!!!
    Thursday, November 29, 2012 5:17 PM
  • Awesome - Did the trick
    Wednesday, January 09, 2013 10:42 PM
  • Found the answer to my problem on another site.  In case anyone else has this problem....


    Bring up the Excel options, go to advanced and then scroll down to the

    "General" section.  Make sure that "Ignore other applications that use

    Dynamic Data Exchange (DDE)" is not checked. 

    This did fix my problem
    it solved the problem !
    Thursday, January 10, 2013 3:10 PM
  • This was also a very common problem for us, and your answer fixed it.   thanks

    Friday, February 15, 2013 11:58 AM
  • Thanks a lot. Solution worked for me too. Weird and annoying problem and of unknown origin. 
    Wednesday, February 27, 2013 10:43 PM
  • thank you!

     I don't know what happened but my shortcuts would not open. This fixed my problem!

    Tuesday, March 05, 2013 6:45 AM
  • Thanks, this worked for me as well
    Tuesday, June 18, 2013 7:04 PM
  • After Doing the above two methods still if it does not come then try the following as it worked for me:Open the file and when the error "There was a problem sending the command to the program" still comes press OK and don't close the excel background but keeping it open, again double click the excel file that you were trying to open.
    Saturday, June 29, 2013 10:16 AM
  • you are right Amazing dear..
    Thursday, July 04, 2013 10:47 AM
  • Thanks.Its now working

    Wednesday, August 21, 2013 7:28 AM
  • Waoooo. That works. great. Thanks A lot.

    Thursday, August 22, 2013 2:20 PM
  • Thank you. this solved my issue.
    Wednesday, August 28, 2013 12:44 AM
  • This is great.. Fixed the issue :)
    Thursday, August 29, 2013 5:05 AM
  • Excellent! did work perfectly for me!. Thnak you so much
    Tuesday, September 03, 2013 12:37 AM
  • It's really helpful...

    I have Microsoft Office standard 2007 and I am running Windows 7 Professional 64 bit.  

    Open Excel, and click on the Microsoft Icon at the top left.  In the window at the bottom is "Excel Options".  Click it.
    Then select "Advanced" on the left side of the screen.  When the display comes up, you need to scroll almost to the bottom.
    Under the blue "General" category, will be  "Ignore other applications that use Dynamic Data Exchange (DDE )"
    Make sure it is not checked.

    • Edited by AmitChugh Tuesday, September 03, 2013 8:33 PM
    Tuesday, September 03, 2013 8:29 PM
  • Thanks to the person that found the answer originally and to you for posting it in this forum after finding it on another site!

    It helped me fix two instances of this problem.

    Friday, September 06, 2013 8:26 PM
  • Work very well.
    Thnks.

    Tuesday, September 10, 2013 1:42 AM
  • Mr.Howardsydney thanks  a tonne..............................your answer for this solution helped me out................thank you very much for your help.......
    Saturday, November 02, 2013 7:09 AM
  • Tis fixed my problem as well. Thanks for posting!
    Wednesday, November 20, 2013 4:31 PM
  • It also works for me ,Thanks

    "Bring up the Excel options, go to advanced and then scroll down to the

    "General" section.  Make sure that "Ignore other applications that use

    Dynamic Data Exchange (DDE)" is not checked "
    Friday, December 13, 2013 8:44 AM
  • thanks ...its works for me
    Wednesday, December 18, 2013 5:15 AM