none
MDT 2012 doesn't show custom list of applications for install

    Question

  • I have an MDT task sequence that installs an OS and present an application list based on your OU choice (differing departments need separate applications).  When booting to WinPE and running the task sequence the selection options show properly and install fine (as shown below).

      However, when running the task sequence as a refresh from Windows, the application only shows the default panel with the sample application.  According to the logs, it is accessing and running the right file (plus if it couldn't find the file, it would error out the task sequence) but not displaying properly.

    Logs for the launch of this wizard are copied below:

    Expand a string: WinPEandFullOS TSManager 8/23/2013 9:08:09 AM 17324 (0x43AC)
    Executing command line: smsswd.exe /run: cscript.exe "%DeployRoot%\Scripts\UDIWizard.wsf" /definition:"AppLists\%OSDInstallOU%.xml" TSManager 8/23/2013 9:08:09 AM 17324 (0x43AC)
    [ smsswd.exe ] InstallSoftware 8/23/2013 9:08:09 AM 12564 (0x3114)
    PackageID = '' InstallSoftware 8/23/2013 9:08:09 AM 12564 (0x3114)
    BaseVar = '', ContinueOnError='' InstallSoftware 8/23/2013 9:08:09 AM 12564 (0x3114)
    ProgramName = 'cscript.exe "C:\_SMSTaskSequence\WDPackage\Scripts\UDIWizard.wsf" /definition:"AppLists\OSA.xml"' InstallSoftware 8/23/2013 9:08:09 AM 12564 (0x3114)
    SwdAction = '0001' InstallSoftware 8/23/2013 9:08:09 AM 12564 (0x3114)
    Working dir 'C:\_SMSTaskSequence\WDPackage\Tools\X64' InstallSoftware 8/23/2013 9:08:09 AM 12564 (0x3114)
    Executing command line: Run command line InstallSoftware 8/23/2013 9:08:09 AM 12564 (0x3114)
    Microsoft (R) Windows Script Host Version 5.8 InstallSoftware 8/23/2013 9:08:09 AM 12564 (0x3114)
    Copyright (C) Microsoft Corporation. All rights reserved. InstallSoftware 8/23/2013 9:08:09 AM 12564 (0x3114)
    InstallSoftware 8/23/2013 9:08:09 AM 12564 (0x3114)
    Property definition is now = AppLists\OSA.xml InstallSoftware 8/23/2013 9:08:09 AM 12564 (0x3114)
    Microsoft Deployment Toolkit version: 6.1.2373.0 InstallSoftware 8/23/2013 9:08:09 AM 12564 (0x3114)
    The task sequencer log is located at C:\Windows\CCM\Logs\SMSTSLog\SMSTS.LOG.  For task sequence failures, please consult this log. InstallSoftware 8/23/2013 9:08:09 AM 12564 (0x3114)
    Using tsprogressui.exe for displaying wizard UI InstallSoftware 8/23/2013 9:08:09 AM 12564 (0x3114)
    Working directory: C:\_SMSTaskSequence\WDPackage\Tools\x64 InstallSoftware 8/23/2013 9:08:09 AM 12564 (0x3114)
    Saving edited configuration file as C:\Windows\CCM\Logs\SMSTSLog\OSDSetupWizard.xml InstallSoftware 8/23/2013 9:08:09 AM 12564 (0x3114)
    Copying app file C:\_SMSTaskSequence\WDPackage\Scripts\AppLists\OSA.xml.app to C:\Windows\CCM\Logs\SMSTSLog\OSDSetupWizard.xml.app InstallSoftware 8/23/2013 9:08:09 AM 12564 (0x3114)
    Selected wizard stage option: REFRESH InstallSoftware 8/23/2013 9:08:09 AM 12564 (0x3114)
    About to run command: ServiceUI.exe -process:tsprogressui.exe OSDSetupWizard.exe /xml:"C:\Windows\CCM\Logs\SMSTSLog\OSDSetupWizard.xml" /stage:REFRESH InstallSoftware 8/23/2013 9:08:09 AM 12564 (0x3114)

    I could use some pointers on what is going wrong.

    Friday, August 23, 2013 2:12 PM

Answers

  • On a refresh, in order to get the application list to show up on a second wizard, you must run the Application Discovery scan during the second wizard.  It reads in the .xml.app file and populates the list. 
    • Marked as answer by mkmaster78 Tuesday, September 03, 2013 12:46 PM
    Tuesday, September 03, 2013 12:46 PM

All replies

  • Still having this issue occur, does anyone have any possible resolution?
    Wednesday, August 28, 2013 8:46 PM
  • There are two separate UDI Wizard steps in the task sequence. When you want to use a custom XML config file, you need to modify both of those steps with the /definition switch. It looks like you only did one of them.


    Thanks,
    -Michael Niehaus
    Senior Product Marketing Manager, Windows Deployment
    http://blogs.technet.com/mniehaus
    mniehaus@microsoft.com


    Wednesday, August 28, 2013 8:57 PM
  • Actually, mine has four UDI steps, two in the new computer two in the refresh.  All four list their appropriate XML file.  In both the new computer and the refresh, the UDI wizard runs and gets some info, then based on that info the second UDI wizard runs so the applications can be chosen.  The logs show that the right files are being chosen, and are copied to the spots listed in the logs, but aren't displaying as intended.

    Thursday, August 29, 2013 12:54 PM
  • On a refresh, in order to get the application list to show up on a second wizard, you must run the Application Discovery scan during the second wizard.  It reads in the .xml.app file and populates the list. 
    • Marked as answer by mkmaster78 Tuesday, September 03, 2013 12:46 PM
    Tuesday, September 03, 2013 12:46 PM