none
allow anonymous to post comments in blog

Answers

  • No, you need not to disable Windows Authentication.

     

    Firstly, you could enable the anonymous access in Central Administration > Application Management > Authentication Providers.

     

    Then in the Blog site, enable anonymous access for Entire Web site in Site Settings > Permissions.

     

    Lastly, enable anonymous to add items in the Comments list. (you could see the Comments list in View All Site Content)

     

    See Enable anonymous access (http://office.microsoft.com/en-us/sharepointserver/HA101130181033.aspx) for more information.

     

    Hope the information can be helpful.

    -lambert


    Sincerely,
    Lambert Qin | Microsoft TechNet Managed Forum Support
    Posting is provided "AS IS" with no warranties, and confers no rights.
    Tuesday, July 14, 2009 8:38 AM

All replies

  • Blog questions go to Social Computing.

    Moving this.

    WSS FAQ sites: http://wssv2faq.mindsharp.com and http://wssv3faq.mindsharp.com
    Total list of WSS 3.0 / MOSS 2007 Books (including foreign language) http://wssv3faq.mindsharp.com/Lists/v3%20WSS%20FAQ/V%20Books.aspx
    Thursday, July 09, 2009 3:50 AM
  • No, you need not to disable Windows Authentication.

     

    Firstly, you could enable the anonymous access in Central Administration > Application Management > Authentication Providers.

     

    Then in the Blog site, enable anonymous access for Entire Web site in Site Settings > Permissions.

     

    Lastly, enable anonymous to add items in the Comments list. (you could see the Comments list in View All Site Content)

     

    See Enable anonymous access (http://office.microsoft.com/en-us/sharepointserver/HA101130181033.aspx) for more information.

     

    Hope the information can be helpful.

    -lambert


    Sincerely,
    Lambert Qin | Microsoft TechNet Managed Forum Support
    Posting is provided "AS IS" with no warranties, and confers no rights.
    Tuesday, July 14, 2009 8:38 AM
  • hi, thanks for your answer! i do the steps and works.
    Tuesday, July 21, 2009 8:03 PM
  • Lambert - I wonder if you can help me, since you've posted these instructions several times and I have a problem that nobody else seems to have. 

    I am working with a Discussion Board.  My goal is that when users post something to this discussion board, they have a check box that allows them to "Post as Anonymous." 

    In following your instructions, when I get to the "Change Anonymous Access Settings" for my discussion board, on the right it says "Anonymous Users Can:" and all the permissions are dimmed so I can't check any of the boxes.  4 Options show up - Add Items, Edit Items, Delete Items, View Items.

    Your help is greatly appreciated.

    Christine
    Thursday, November 12, 2009 8:50 PM
  • Is it nice to flood?
    www.hempworx.com
    Wednesday, February 03, 2010 12:50 PM