none
Domain-settings in customsettings.ini will disable "capture"-option

    Question

  • Hello,

    i am building a new customsettings.ini.

    Within this customsettings.ini i want the possiblity to insert the settings for joining a new Cliënt to the domain with specified settings AND the possilibity to capture an reference image.

    But...when i add the following settings to my customsettings.ini and start the litetouch.wsf on my reference computer, i have NO possilibity to set the location for the refence image.

     JoinDomain=domain.corp
     DomainAdmin=MDT
     DomainAdminDomain=domain.corp
     DomainAdminPassword=Password

    When i delete these settings i have the possibility to set the capture-location etc.

     Maybe multiple customsettings.ini or another .ini-file for these settings?

    Thx

    Tuesday, September 25, 2012 10:52 AM

All replies

  • Doing the capture process would automatically remove the computer from the domain before the capture is performed.  If you explain more about what your goal is and why you think you need to have both settings at the same time we could discuss alternative ways of accomplishing the same things you want to do.

    If you really want to brute-force it I think in your CustomSettings.ini file you need to set DoCapture=YES, BackupShare=\\serevr\share, and BackupDir=Foldername, but those settings may also be ignored because of the settings that bind it to the domain. A better alternative (but still not really a recommended course of action) would be to create a new task sequence that just does the Sysprep and Capture steps and manually launch it after the deployment task sequence is complete

    Tuesday, September 25, 2012 2:16 PM
  • Hello, this is my goal:

    - Unattended installation of task-sequence, with less input required. So no domain/credentials to join the cliënt to the domain

    - when making the capture image from, the possibility to have the "capture" tab when starting litetouch.wsf from the reference-machine.

    This is all from the same task-sequence until now...

    Thx

    Tuesday, September 25, 2012 7:56 PM
  • Anybody who has a solution to achieve this goal?

    When i add the domain-credentials to the customsettings.ini and try to start the capture from the reference-computer i don`t have the possibility to start a new capture!

    When i delete the domain-credentials from customsettings.ini this "tab" is available at the reference-computer when starting the litetouch.wsf!

    Thx

    Thursday, September 27, 2012 11:00 AM
  • Anybody?
    Friday, September 28, 2012 6:30 AM
  • Hi there,

    What you're saying really should not happen. I've written a couple of articles that should help.

    MDT 2010: Joining a Domain
    MDT 2010: Backup, Capture and P2V explained
    MDT 2010: Skipping Deployment Wizard Pages

    Hopefully, this should help you to understand what's going on and how to configure the settings correctly.

    Andrew.


    Blog: http://scriptimus.wordpress.com

    Friday, September 28, 2012 11:54 AM
  • Hi Andrew,

    i have retested the situation...but still same problem.

    When i add the following settings to my cs.ini :

    JoinDomain=domain
    DomainAdmin=MDT
    DomainAdminDomain=domain
    DomainAdminPassword=password

    and start "litetouch.wsf" in my "to-be-captured" image...and choose the TS "Sysprep and Capture" i have NO option for the "capture start/location""  etc.

    When i delete these settings from cs.ini ...the option is available....

    What goes wrong here?

    Thx

    Friday, October 19, 2012 9:44 AM
  • Hello,

    when i have the following settings in my cs.ini :

    JoinDomain=domain.local
     DomainAdmin=mdt
     DomainAdminDomain=domain.local
     DomainAdminPassword=Pa$$w0rd

    and starting the litetouch.wsf  in my reference image,

    then choose the task-sequence : Sysprep and Capture

    Then i get the following screen without the option to capture/change capture location:

    When i delete these settings from my cs.ini, i get the following options WITH capture and capture/locations:

    How can i fix this so i can use the domain-settings AND capture-possiblity with the settings in cs.ini?

    Maybe this will happen because the cliënt must be in a workgroup to sysprep/capture so domain-settings will give a conflict?

    Thx

    Monday, October 22, 2012 6:39 AM
  • Hi there.

    It looks like some new logic has been coded in order to follow Best Practices.

    Following Best Practices you should not join the domain and then perform a sysprep and capture(for a thousand reasons).

    Build your reference image on a virtual machine in a Workgroup. Perform a domain join at the time of deployment.


    Blog: http://scriptimus.wordpress.com

    Monday, October 22, 2012 9:23 PM
  • Hi Andrew

    i am doing in the same deploymentshare :

    - Capture a new image

    - Deploy to a domain

    So the conflict is this combination in the same deployment-share?

    What is the best practice for this combination?

    Thx

    Tuesday, October 23, 2012 5:35 AM
  • Best method is to isolate the settings as much as you can to the machine(s) you wish to target. There are a number of ways to tackle this:

    1. Implement the Deployment database, you could then create roles and assign them to machines.
    2. You could move the settings from the customsettings.ini into task sequence variables. This will separate any conflicts.
    3. You could create a rules ini file(just like the customsettings.ini) with the unique settings and apply it to each task sequence under the Gather task sequence step.
    4. You could isolate the settings per machine in the customsettings.ini examples here.


    Blog: http://scriptimus.wordpress.com

    Tuesday, October 23, 2012 9:53 AM
  • Hi Andrew,

    thx for the answer.

    But..many things to do, for a "simple" setting :-)

    Tuesday, October 23, 2012 10:17 AM
  • Many different options.

    It all depends on how you want to tackle it. When I first started using MDT I had 3 deployment shares until I learned how to manage the properties.

    It took me a while.

    I suggest you try using Task Sequence variables as that's the easiest. You can change(improve) this as you learn more about MDT.


    Blog: http://scriptimus.wordpress.com

    Tuesday, October 23, 2012 11:55 AM
  • Thx for the answer.

    I hope there will be a "fix" in the final release for MDT 2012 for this combination!

    Wednesday, October 24, 2012 8:33 AM
  • I've just looked at the code.

    <Pane id="CaptureImage" reference="DeployWiz_CaptureImage.xml">
    <Condition><![CDATA[ Ucase(Property("SkipCapture"))<>"YES" and Property("DeploymentType") <> "REFRESH" and Property("JoinDomain") = "" and Property("DeploymentType") <> "REPLACE"]]></Condition>
    <Condition><![CDATA[ FindTaskSequenceStep("//step[@name='Create WIM']", "ZTIBackup.wsf" ) ]]></Condition>
    </Pane>

    This tells MDT to show the capture wizard pane if 

    "SkipCapture" is not equal to "YES" and "DeploymentType"  is not equal to  "REFRESH" and "JoinDomain" = "" and "DeploymentType"  is not equal to  "REPLACE"

    Solution: edit the DeployWiz_Definition_ENU.xml in the DeploymentShare\Scripts folder and remove the section Property("JoinDomain") = "" from the "CaptureImage" section.

    /Andrew


    Blog: http://scriptimus.wordpress.com

    Sunday, October 28, 2012 10:24 PM
  • Hi Andrew,

    thx for looking to the script.

    i Will test this soon ! Did you already test this?

    Wednesday, October 31, 2012 7:50 AM
  • I would never need to join a domain and perform a capture, its not good practice. My theory above is sound though. Just not recommended.


    Blog: http://scriptimus.wordpress.com

    Thursday, November 01, 2012 8:58 PM
  • what he is saying is if the joindomain= option is set in the cs.ini the wizard prevents you from capturing a harddisk. this is not the same behavior as in MDT2010. All the joindomain setting does it joins the machine to a domain when its DONE capturing. not before it captures it. I have found this very annoying when making new reference images. I need to edit the cs.ini to comment that out then start a capture then uncomment.

    Tech with Alberta Education

    Tuesday, February 12, 2013 8:38 PM
  • Hi Mykel,

    i "Fixed" this by deleting the joindomain-part.

    But still it`s strange there is no possiblity to have both options with "joindomain"-setting in cs.ini.

    Wednesday, February 13, 2013 7:26 AM
  • as Andrew said it is not best practice to join a pc to a domain and then capture an image of it. thats the reason microsoft changed the logic so it wouldn't let you capture domain joined computers anymore.

    Wednesday, February 13, 2013 8:33 AM