none
Disk Defrag service stops on SBS 2011

    Question

  • I am having problems with the defrag service on SBS 2011 stopping for no apparent reason. I have found nothing in the event logs, not even to say that the service has stopped. The only event recorded was that defrag completed a few days ago. I manually restart the service and it may stop after 2 minutes or after several hours - there seems no logic to when it is stopped, but I get email floods when the service is not running.

    On a default installation, the service is set to manual start yet my production machine is set to automatic. I have changed it back to manual.

    Does the service need to be running and if not, how can I turn off the email notifications for this service?


    • Edited by gjross Wednesday, September 05, 2012 8:08 AM
    Wednesday, September 05, 2012 8:08 AM

Answers

  • ok, easier with the actual message :-)

    SBS console, Networking, tab, Notifications Settings option. Untick the service in there.

    Jim

    • Marked as answer by gjross Wednesday, September 05, 2012 8:33 AM
    Wednesday, September 05, 2012 8:31 AM

All replies

  • On all the servers I have access to, the service is manual.

    What is it that is sending the emails? Sounds like you have a third party monitoring solution, or someone has configured WMI to monitor for this service.

    Jim


    • Edited by Jim Willsher Wednesday, September 05, 2012 8:50 AM
    Wednesday, September 05, 2012 8:26 AM
  • I receive a critical event notification and the email is as follows;

    An alert was detected on your
    network. Further investigation into the issue is recommended.

    Computer:
    <server>
    Date/Time generated: 9/5/2012 8:34:00 AM
    Title: A key Windows
    Services service is not running
    Source: Key Windows Services
    Description:

    The Disk Defragmenter service has been stopped.

    Wednesday, September 05, 2012 8:28 AM
  • ok, easier with the actual message :-)

    SBS console, Networking, tab, Notifications Settings option. Untick the service in there.

    Jim

    • Marked as answer by gjross Wednesday, September 05, 2012 8:33 AM
    Wednesday, September 05, 2012 8:31 AM
  • Wow, I feel dumb... I was looking for something far more complicated! I have reset to the defaults and indeed, it has removed the defrag service.

    Thank you very much for your help. I shall leave you to deal with something a little more challenging...!!

    Wednesday, September 05, 2012 8:37 AM
  • No worries :-)
    Wednesday, September 05, 2012 8:39 AM